aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-04-19 02:30:02 +0000
committerWill Andrews <will@FreeBSD.org>2002-04-19 02:30:02 +0000
commite05ed36727813c752300995435b0dc1aee51ecc3 (patch)
treed926f0f9b039ccf866d06988fbb956f5373cb5b9 /deskutils
parenta9115fa27e6e7ffe5911b46d8498cdc5eff851fc (diff)
downloadports-e05ed36727813c752300995435b0dc1aee51ecc3.tar.gz
ports-e05ed36727813c752300995435b0dc1aee51ecc3.zip
Say goodbye to Qt 1.x and all of its dependents. The one port I found
which probably isn't supposed to be removed is misc/instant-workstation, which had a dependency on audio/xamp (being removed), so I removed that dependency and bumped PORTREVISION. All other ports are real dependents upon Qt 1.x, including KDE 1.x stuff. Code in bsd.kde.mk supporting these ports is also removed or adjusted. Also, some adjustments made to accomodate Qt3/KDE3 ports, which will be committed Real Soon Now (TM), pending repo-copies. This commit made in impending view of Qt3/KDE3 entering ports tree.
Notes
Notes: svn path=/head/; revision=57872
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/kproject/Makefile19
-rw-r--r--deskutils/kproject/distinfo1
-rw-r--r--deskutils/kproject/files/patch-aa57
-rw-r--r--deskutils/kproject/pkg-comment1
-rw-r--r--deskutils/kproject/pkg-descr18
-rw-r--r--deskutils/kproject/pkg-plist1
7 files changed, 0 insertions, 98 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index b961d77c4b52..c988b3b8fa18 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -22,7 +22,6 @@
SUBDIR += jlj
SUBDIR += kdepim
SUBDIR += kmymoney2
- SUBDIR += kproject
SUBDIR += kronolith
SUBDIR += krss
SUBDIR += logjam
diff --git a/deskutils/kproject/Makefile b/deskutils/kproject/Makefile
deleted file mode 100644
index 6703ebef96a1..000000000000
--- a/deskutils/kproject/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-# New ports collection makefile for: kproject
-# Date created: 23 May 1998
-# Whom: Hans Petter Bieker <hanspb@persbraten.vgs.no>
-#
-# $FreeBSD$
-#
-
-PORTNAME= kproject
-PORTVERSION= 0.1
-CATEGORIES= deskutils kde
-MASTER_SITES= $(MASTER_SITE_KDE)
-MASTER_SITE_SUBDIR= unstable/apps/office
-EXTRACT_SUFX= .tgz
-
-USE_LIBTOOL= yes
-USE_KDELIBS_VER=1
-WRKSRC= ${WRKDIR}/kproject
-
-.include <bsd.port.mk>
diff --git a/deskutils/kproject/distinfo b/deskutils/kproject/distinfo
deleted file mode 100644
index d2dd8acdc798..000000000000
--- a/deskutils/kproject/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (kproject-0.1.tgz) = fe2c29aab53c28a4e096b02f04298097
diff --git a/deskutils/kproject/files/patch-aa b/deskutils/kproject/files/patch-aa
deleted file mode 100644
index 1c04f80b269f..000000000000
--- a/deskutils/kproject/files/patch-aa
+++ /dev/null
@@ -1,57 +0,0 @@
---- Makefile Thu Dec 18 07:52:15 1997
-+++ Makefile.new Sat Jan 22 16:57:49 2000
-@@ -1,28 +1,28 @@
-
--kde_libraries = /opt/kde/lib
--qt_libraries = /usr/lib
-+kde_libraries = ${LOCALBASE}/lib
-+qt_libraries = ${X11BASE}/lib
- top_builddir = ..
--LIBTOOL = $(SHELL) $(top_builddir)/libtool
-+LIBTOOL = libtool
- KDE_RPATH = -rpath $(kde_libraries) -rpath $(qt_libraries)
-
- ############ Autoconf-generated variables ###################
--CXXFLAGS= -O2 -Wall -I/opt/kde/include -I/usr/lib/qt/include -I..
--LDFLAGS = -s -L/opt/kde/lib -L/usr/lib -L/usr/X11/lib -lkdecore -lkdeui -lqt -lXext -lX11
--CXX = c++
--MOC = /usr/bin/moc
-+CXXFLAGS= -O2 -Wall -I$(LOCALBASE)/include -I$(X11BASE)/include -I$(X11BASE)/include/X11/qt -I..
-+LDFLAGS = -s -L$(kde_libraries) -L$(qt_libraries) -lkdecore -lkdeui -lqt -lXext -lX11
-+CXX ?= c++
-+MOC = $(X11BASE)/bin/moc
-
- install = /usr/bin/install -c
--INSTALL = $(install) -m 0755
-+INSTALL = $(install) -m 0555
- INSTALL_DATA = $(install) -m 0644
- INSTALL_DIR = $(install) -d -m 0755
- INSTALL_DIR_PRIVATE = $(install) -d -m 0700
-
--prefix = /opt/kde
-+prefix = $(PREFIX)
- KDEINC = $(prefix)/include
- BINDIR = $(prefix)/bin
- LIBDIR = $(prefix)/lib
--PICSDIR = $(LIBDIR)/pics
--APPSDIR = $(prefix)/apps
-+PICSDIR = $(prefix)/share/pics
-+APPSDIR = $(prefix)/share/apps
-
- ########### Implicit Rules ###########
-
-@@ -73,10 +73,10 @@
- install: all
- $(INSTALL_DIR) $(BINDIR)
- $(INSTALL) $(TARGET) $(BINDIR)
-- $(INSTALL_DIR) $(prefix)/share/doc/HTML/en/karm
-- $(INSTALL_DATA) $(DOCFILES) $(prefix)/share/doc/HTML/en/karm
-- $(INSTALL_DIR) $(prefix)/share/applnk/Utilities
-- $(INSTALL_DATA) support/KArm.kdelnk $(prefix)/share/applnk/Utilities
-+# $(INSTALL_DIR) $(prefix)/share/doc/HTML/en/karm
-+# $(INSTALL_DATA) $(DOCFILES) $(prefix)/share/doc/HTML/en/karm
-+# $(INSTALL_DIR) $(prefix)/share/applnk/Utilities
-+# $(INSTALL_DATA) support/KArm.kdelnk $(prefix)/share/applnk/Utilities
-
- dist: $(SRCFILES) $(HDRFILES) Makefile
- cd ..
diff --git a/deskutils/kproject/pkg-comment b/deskutils/kproject/pkg-comment
deleted file mode 100644
index fde1d8be797f..000000000000
--- a/deskutils/kproject/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Project planner for KDE (preview version)
diff --git a/deskutils/kproject/pkg-descr b/deskutils/kproject/pkg-descr
deleted file mode 100644
index c2a39d26f535..000000000000
--- a/deskutils/kproject/pkg-descr
+++ /dev/null
@@ -1,18 +0,0 @@
-This is a preview version of kproject, a simple project planner.
-
-At the moment this is not more than a Q&D hack, but it does some
-basic functions, e. g.
-
-- read a project list in the form
- <Start node>:<End node>:<Duration>:<Text>
-
- where <Start node> and <End node> represents the dependencies of each
- process. You can edit this in the programm, but I think, it is
- much easier to edit a file with your favourite editor and load it.
-
- Two sample files are included in this package (see /samples).
-
-- calculate buffer times. A "C" indicates, that this process is critical
- (total buffer time is zero)
-
-- show the project as a GANTT diagram
diff --git a/deskutils/kproject/pkg-plist b/deskutils/kproject/pkg-plist
deleted file mode 100644
index 221fd02b3cbd..000000000000
--- a/deskutils/kproject/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/kproject