aboutsummaryrefslogtreecommitdiff
path: root/devel/ElectricFence
diff options
context:
space:
mode:
authorJames Raynard <jraynard@FreeBSD.org>1997-11-12 23:46:32 +0000
committerJames Raynard <jraynard@FreeBSD.org>1997-11-12 23:46:32 +0000
commit28a5cee651fd463442f1775e948821c02f24c5d8 (patch)
treea6df992f8b831b3b5b19930d69cb0150d6c255e3 /devel/ElectricFence
parentc890f896ed69c8bb8a002736dc8b84a99d70b23d (diff)
downloadports-28a5cee651fd463442f1775e948821c02f24c5d8.tar.gz
ports-28a5cee651fd463442f1775e948821c02f24c5d8.zip
ElectricFence, the debugging malloc library
Notes
Notes: svn path=/head/; revision=8597
Diffstat (limited to 'devel/ElectricFence')
-rw-r--r--devel/ElectricFence/Makefile25
-rw-r--r--devel/ElectricFence/distinfo1
-rw-r--r--devel/ElectricFence/files/patch-aa24
-rw-r--r--devel/ElectricFence/pkg-comment1
-rw-r--r--devel/ElectricFence/pkg-descr15
-rw-r--r--devel/ElectricFence/pkg-plist2
6 files changed, 68 insertions, 0 deletions
diff --git a/devel/ElectricFence/Makefile b/devel/ElectricFence/Makefile
new file mode 100644
index 000000000000..8f6e4065ec4c
--- /dev/null
+++ b/devel/ElectricFence/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: sfio
+# Version required: 2.0.5
+# Date created: 13 November 1997
+# Whom: jraynard
+#
+# $Id$
+#
+
+DISTNAME= ElectricFence-2.0.5
+CATEGORIES= devel
+MASTER_SITES= MASTER_SITE_LOCAL
+
+MAINTAINER= jraynard@freebsd.org
+
+MAN3= libefence.3
+
+#do-build:
+# @cd ${WRKDIR}/src/lib/sfio && ${MAKE} all -f makefile
+# @cd ${WRKDIR}/src/lib/sfdisc && ${MAKE} all
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libefence.a ${PREFIX}/lib
+ ${INSTALL_MAN} ${WRKSRC}/libefence.3 ${PREFIX}/man/man3
+
+.include <bsd.port.mk>
diff --git a/devel/ElectricFence/distinfo b/devel/ElectricFence/distinfo
new file mode 100644
index 000000000000..a31ca703e050
--- /dev/null
+++ b/devel/ElectricFence/distinfo
@@ -0,0 +1 @@
+MD5 (ElectricFence-2.0.5.tar.gz) = d6a8459d2e9ef955eb4d3f76004617f8
diff --git a/devel/ElectricFence/files/patch-aa b/devel/ElectricFence/files/patch-aa
new file mode 100644
index 000000000000..75516213e476
--- /dev/null
+++ b/devel/ElectricFence/files/patch-aa
@@ -0,0 +1,24 @@
+--- Makefile.orig Fri Jan 20 05:33:04 1995
++++ Makefile Wed Nov 12 22:47:51 1997
+@@ -4,7 +4,7 @@
+ INSTALL= install
+ MV= mv
+ CHMOD= chmod
+-CFLAGS= -g
++CFLAGS+= -g -DPAGE_PROTECTION_VIOLATED_SIGNAL=SIGBUS
+ LIB_INSTALL_DIR= /usr/lib
+ MAN_INSTALL_DIR= /usr/man/man3
+
+--- page.c.orig Wed Nov 12 21:57:13 1997
++++ page.c Wed Nov 12 23:19:57 1997
+@@ -30,8 +30,10 @@
+ static caddr_t startAddr = (caddr_t) 0;
+
+ #if ( !defined(sgi) && !defined(_AIX) )
++#if ( !defined(BSD) || (BSD < 199103) )
+ extern int sys_nerr;
+ extern char * sys_errlist[];
++#endif
+ #endif
+
+ static const char *
diff --git a/devel/ElectricFence/pkg-comment b/devel/ElectricFence/pkg-comment
new file mode 100644
index 000000000000..cab5c8f78797
--- /dev/null
+++ b/devel/ElectricFence/pkg-comment
@@ -0,0 +1 @@
+A debugging malloc() that uses the VM hardware to detect buffer overruns.
diff --git a/devel/ElectricFence/pkg-descr b/devel/ElectricFence/pkg-descr
new file mode 100644
index 000000000000..7b04b84fb738
--- /dev/null
+++ b/devel/ElectricFence/pkg-descr
@@ -0,0 +1,15 @@
+Electric Fence is a different kind of malloc() debugger. It uses the virtual
+memory hardware of your system to detect when software overruns the boundaries
+of a malloc() buffer. It will also detect any accesses of memory that has
+been released by free(). Because it uses the VM hardware for detection,
+Electric Fence stops your program on the first instruction that causes
+a bounds violation. It's then trivial to use a debugger to display the
+offending statement.
+
+It will probably port to any ANSI/POSIX system that provides mmap(), and
+mprotect(), as long as mprotect() has the capability to turn off all access
+to a memory page, and mmap() can use /dev/zero or the MAP_ANONYMOUS flag
+to create virtual memory pages.
+
+Complete information on the use of Electric Fence is in the manual page
+libefence.3 .
diff --git a/devel/ElectricFence/pkg-plist b/devel/ElectricFence/pkg-plist
new file mode 100644
index 000000000000..fd909db17f2b
--- /dev/null
+++ b/devel/ElectricFence/pkg-plist
@@ -0,0 +1,2 @@
+lib/libefence.a
+man/man3/libefence.3.gz