aboutsummaryrefslogtreecommitdiff
path: root/devel/R-cran-data.table/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2020-09-26 08:36:54 +0000
committerWen Heping <wen@FreeBSD.org>2020-09-26 08:36:54 +0000
commit5f11b9367b53394917c2eeae49be8b91eb1a3dae (patch)
tree74579a0de179ad4c49b768ae6d348d797119c0a5 /devel/R-cran-data.table/Makefile
parent132644ced346f68648c770f3e9bf8f43f003ba4e (diff)
downloadports-5f11b9367b53394917c2eeae49be8b91eb1a3dae.tar.gz
ports-5f11b9367b53394917c2eeae49be8b91eb1a3dae.zip
- Unbreak build on i386
PR: 247631 Submitted by: wen@(myself) Approved by: tota@(maintainer)
Notes
Notes: svn path=/head/; revision=550137
Diffstat (limited to 'devel/R-cran-data.table/Makefile')
-rw-r--r--devel/R-cran-data.table/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/devel/R-cran-data.table/Makefile b/devel/R-cran-data.table/Makefile
index 0c2c02a0a148..5f525fb9c468 100644
--- a/devel/R-cran-data.table/Makefile
+++ b/devel/R-cran-data.table/Makefile
@@ -3,7 +3,7 @@
PORTNAME= data.table
DISTVERSION= 1.12.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -13,13 +13,25 @@ COMMENT= Extension of Data.frame
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_i386= unable to load datatable.so
-
-USES= cran:auto-plist,compiles
+USES= cran:auto-plist
OPTIONS_DEFINE= OPENMP
OPTIONS_DEFAULT= OPENMP
OPENMP_CONFIGURE_ENABLE= openmp
+NO_ARCH_IGNORE= datatable.so
+
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == i386
+# See PR 230888 : Missing 64 bit atomic functions for i386
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-src_Makevars
+USES+= compiler:gcc-c++11-lib
+.elif defined(PPC_ABI) && ${PPC_ABI} == ELFv1
+USE_GCC= yes
+.else
+USES+= cran:compiles
+.endif
+
.include <bsd.port.mk>