aboutsummaryrefslogtreecommitdiff
path: root/devel/R-cran-devtools/Makefile
diff options
context:
space:
mode:
authorJean-Paul Beconne <jpbeconne@free.fr>2021-11-06 21:46:07 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-11-06 21:46:07 +0000
commit9ed19b470446619630d296b4ef9673206b8e8f0c (patch)
treef0a06c48c68cd32826cda9be6808b2604f2c4d02 /devel/R-cran-devtools/Makefile
parentab12c7ab49c4f3640229f5769a4ed025d9a35482 (diff)
downloadports-9ed19b470446619630d296b4ef9673206b8e8f0c.tar.gz
ports-9ed19b470446619630d296b4ef9673206b8e8f0c.zip
devel/R-cran-devtools: New Port
Tools to Make Developing R Packages Easier. PR: 246860
Diffstat (limited to 'devel/R-cran-devtools/Makefile')
-rw-r--r--devel/R-cran-devtools/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/devel/R-cran-devtools/Makefile b/devel/R-cran-devtools/Makefile
new file mode 100644
index 000000000000..42e41baf0ffb
--- /dev/null
+++ b/devel/R-cran-devtools/Makefile
@@ -0,0 +1,36 @@
+PORTNAME= devtools
+DISTVERSION= 2.4.2
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= jpbeconne@free.fr
+COMMENT= Tools to Make Developing R Packages Easier
+
+LICENSE= MIT
+
+CRAN_DEPENDS= R-cran-callr>=3.6.0:devel/R-cran-callr \
+ R-cran-cli>=2.4.0:devel/R-cran-cli \
+ R-cran-desc>=1.3.0:devel/R-cran-desc \
+ R-cran-ellipsis>=0.3.1:devel/R-cran-ellipsis \
+ R-cran-fs>=1.5.0:sysutils/R-cran-fs \
+ R-cran-httr>=1.4.2:www/R-cran-httr \
+ R-cran-lifecycle>=1.0.0:devel/R-cran-lifecycle \
+ R-cran-memoise>=1.0.0:devel/R-cran-memoise \
+ R-cran-pkgbuild>=1.2.0:devel/R-cran-pkgbuild \
+ R-cran-pkgload>=1.2.1:devel/R-cran-pkgload \
+ R-cran-rcmdcheck>=1.3.3:devel/R-cran-rcmdcheck \
+ R-cran-remotes>=2.3.0:devel/R-cran-remotes \
+ R-cran-rlang>=0.4.10:devel/R-cran-rlang \
+ R-cran-roxygen2>=7.1.1:devel/R-cran-roxygen2 \
+ R-cran-rstudioapi>=0.13:devel/R-cran-rstudioapi \
+ R-cran-rversions>=2.0.2:devel/R-cran-rversions \
+ R-cran-sessioninfo>=1.1.1:devel/R-cran-sessioninfo \
+ R-cran-testthat>=3.0.2:devel/R-cran-testthat \
+ R-cran-usethis>=2.0.0:devel/R-cran-usethis \
+ R-cran-withr>=2.4.1:devel/R-cran-withr
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>