aboutsummaryrefslogtreecommitdiff
path: root/devel/R-cran-proto/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2011-09-10 07:52:34 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2011-09-10 07:52:34 +0000
commitaae8df2f676346fc15367d67b6f4d6ac8a8258cb (patch)
treeb9a74096e5e0b04338215a1e35dd1966b66eb311 /devel/R-cran-proto/Makefile
parentca77928f005ec3739c73fd7b3d6c1d9e461a1094 (diff)
downloadports-aae8df2f676346fc15367d67b6f4d6ac8a8258cb.tar.gz
ports-aae8df2f676346fc15367d67b6f4d6ac8a8258cb.zip
- Add a new port: devel/R-cran-proto
proto (google code name r-proto) is an R package which facilitates a style of programming known as prototype-based programming. Prototype-based programming is a type of object oriented (OO) programming in which classes and objects are unified into a single concept, prototypes. This makes proto and prototye programming simpler than the usual OO model yet it retains the OO features of inheritance (known as delegation in the prototype model) and OO dispatch. Applications, News, Additional Information sources, Proto Bugs and Avoiding R Bugs sections are given below while associated Links are in the http://code.google.com/p/r-proto/wiki/Links WWW: http://code.google.com/p/r-proto/
Notes
Notes: svn path=/head/; revision=281561
Diffstat (limited to 'devel/R-cran-proto/Makefile')
-rw-r--r--devel/R-cran-proto/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/R-cran-proto/Makefile b/devel/R-cran-proto/Makefile
new file mode 100644
index 000000000000..22512cf65657
--- /dev/null
+++ b/devel/R-cran-proto/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: R-cran-proto
+# Date created: 2011-09-09
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= proto
+DISTVERSION= 0.3-9.2
+CATEGORIES= devel
+PKGNAMEPREFIX= R-cran-
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Prototype object-based programming
+
+LICENSE= GPLv2
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>