aboutsummaryrefslogtreecommitdiff
path: root/devel/R-cran-vctrs/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2019-06-09 14:02:22 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2019-06-09 14:02:22 +0000
commiteb6c449896c45b3e49a7ffdbc36ac525af94ec1b (patch)
tree7bda94ae76a542028050df6ccb0af82881f3de57 /devel/R-cran-vctrs/Makefile
parent82cea947378406f9d5847c690e89e3b033744e61 (diff)
downloadports-eb6c449896c45b3e49a7ffdbc36ac525af94ec1b.tar.gz
ports-eb6c449896c45b3e49a7ffdbc36ac525af94ec1b.zip
- Add new port: devel/R-cran-vctrs
Defines new notions of prototype and size that are used to provide tools for consistent and well-founded type-coercion and size-recycling, and are in turn connected to ideas of type- and size-stability useful for analyzing function interfaces. WWW: https://cran.r-project.org/web/packages/vctrs/
Notes
Notes: svn path=/head/; revision=503820
Diffstat (limited to 'devel/R-cran-vctrs/Makefile')
-rw-r--r--devel/R-cran-vctrs/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/R-cran-vctrs/Makefile b/devel/R-cran-vctrs/Makefile
new file mode 100644
index 000000000000..a168889fa310
--- /dev/null
+++ b/devel/R-cran-vctrs/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= vctrs
+PORTVERSION= 0.1.0
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Vector Helpers
+
+LICENSE= GPLv3
+
+USES= cran:auto-plist,compiles
+
+CRAN_DEPENDS= R-cran-backports>0:math/R-cran-backports \
+ R-cran-digest>0:security/R-cran-digest \
+ R-cran-glue>0:devel/R-cran-glue \
+ R-cran-rlang>0:devel/R-cran-rlang \
+ R-cran-zeallot>0:devel/R-cran-zeallot
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+
+.include <bsd.port.mk>