aboutsummaryrefslogtreecommitdiff
path: root/devel/RStudio/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-02-07 05:42:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-02-07 05:42:13 +0000
commit39e64e9333bfc4bf1cc83da49aea0a8e6448c0ec (patch)
tree8190fd9691dddf81222cbdb89f200532df46baee /devel/RStudio/Makefile
parent38debecfd7c9a3e8c8d8818adf4fa67fec263f9d (diff)
downloadports-39e64e9333bfc4bf1cc83da49aea0a8e6448c0ec.tar.gz
ports-39e64e9333bfc4bf1cc83da49aea0a8e6448c0ec.zip
devel/RStudio: Add rc script for the 'server' flavor/mode
Also * Remove redundant dependencies for the 'server' flavor * Improve COMMENT for the 'desktop' flavor * Remove unnecessary shebang and file in the 'server' flavor
Notes
Notes: svn path=/head/; revision=564604
Diffstat (limited to 'devel/RStudio/Makefile')
-rw-r--r--devel/RStudio/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/devel/RStudio/Makefile b/devel/RStudio/Makefile
index c9e7367318e9..698ab9d5b1c9 100644
--- a/devel/RStudio/Makefile
+++ b/devel/RStudio/Makefile
@@ -6,7 +6,7 @@
PORTNAME= RStudio
DISTVERSIONPREFIX= v
DISTVERSION= 1.3.1093
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel math java
MASTER_SITES= https://s3.amazonaws.com/rstudio-buildtools/dictionaries/:dictionaries \
https://s3.amazonaws.com/rstudio-buildtools/:buildtools
@@ -36,9 +36,7 @@ FLAVORS= desktop server
FLAVOR?= ${FLAVORS:[1]}
server_PKGNAMESUFFIX= -server
-USES= cmake fortran localbase:ldflags pkgconfig qt:5 ssl
-USE_QT= core dbus declarative gui location network opengl printsupport quickcontrols sensors \
- sql svg webchannel webengine webkit widgets xml xmlpatterns buildtools_build qmake_build
+USES= cmake fortran localbase:ldflags pkgconfig ssl
USE_JAVA= yes
JAVA_VERSION= 8
JAVA_BUILD= yes
@@ -63,7 +61,10 @@ GWT_VERSION= 2.8.1
GIN_VERSION= 2.1.2
.if ${FLAVOR:U} == desktop
-USES+= desktop-file-utils shared-mime-info
+COMMENT+= (desktop UI version)
+USES+= desktop-file-utils qt:5 shared-mime-info
+USE_QT= core dbus declarative gui location network opengl printsupport quickcontrols sensors \
+ sql svg webchannel webengine webkit widgets xml xmlpatterns buildtools_build qmake_build
CMAKE_ARGS+= -DRSTUDIO_TARGET=Desktop
INSTALL_SUBDIR= ${PORTNAME:tl}
EXECUTABLE= ${PORTNAME:tl}
@@ -71,12 +72,12 @@ EXECUTABLE= ${PORTNAME:tl}
.if ${FLAVOR:U} == server
COMMENT+= (web UI version)
-USES+= shebangfix
-SHEBANG_FILES= src/cpp/server/extras/admin/rstudio-server.in
CMAKE_ARGS+= -DRSTUDIO_TARGET=Server
INSTALL_SUBDIR= ${PORTNAME:tl}-server
EXECUTABLE= rserver
-RUN_DEPENDS+= bash:shells/bash
+USER= nobody
+SUB_LIST= USER=${USER}
+USE_RC_SUBR= ${PORTNAME:tl}-server
.endif
post-extract:
@@ -117,7 +118,10 @@ post-install:
) > ${STAGEDIR}${PREFIX}/bin/${EXECUTABLE}
@${CHMOD} +x ${STAGEDIR}${PREFIX}/bin/${EXECUTABLE}
.if ${FLAVOR:U} == desktop
- @${REINPLACE_CMD} -e 's|^Exec=.*/rstudio|Exec=${PREFIX}/bin/${EXECUTABLE}|' ${STAGEDIR}${PREFIX}/share/applications/${EXECUTABLE}.desktop
+ ${REINPLACE_CMD} -e 's|^Exec=.*/rstudio|Exec=${PREFIX}/bin/${EXECUTABLE}|' ${STAGEDIR}${PREFIX}/share/applications/${EXECUTABLE}.desktop
+.endif
+.if ${FLAVOR:U} == server
+ ${RM} ${STAGEDIR}${LOCALBASE}/lib/${INSTALL_SUBDIR}/bin/rstudio-server # not compatible with FreeBSD
.endif
# Some functions expect the pandoc symlink.
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/${INSTALL_SUBDIR}/bin/pandoc