aboutsummaryrefslogtreecommitdiff
path: root/devel/RStudio
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-11-03 06:04:08 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-11-03 06:04:08 +0000
commite4d3999f7bd32c06fb2fb9a56dae0f2ca1635f13 (patch)
treeb23ac236936fa294f3945b1fc1fbed9721e5f44f /devel/RStudio
parent89c366171c7b96838310fefeef0123c97a6eb6d2 (diff)
downloadports-e4d3999f7bd32c06fb2fb9a56dae0f2ca1635f13.tar.gz
ports-e4d3999f7bd32c06fb2fb9a56dae0f2ca1635f13.zip
devel/RStudio: Fix the gcc version in LD_PRELOAD to be based on GCC_DEFAULT
PR: 232923 Reported by: jbeich
Notes
Notes: svn path=/head/; revision=483877
Diffstat (limited to 'devel/RStudio')
-rw-r--r--devel/RStudio/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/RStudio/Makefile b/devel/RStudio/Makefile
index 5111b4d3abc5..4344ad4169d9 100644
--- a/devel/RStudio/Makefile
+++ b/devel/RStudio/Makefile
@@ -6,7 +6,7 @@
PORTNAME= RStudio
DISTVERSIONPREFIX= v
DISTVERSION= 1.2.679
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel math java
MASTER_SITES= https://s3.amazonaws.com/rstudio-dictionaries/:dictionaries \
https://s3.amazonaws.com/rstudio-buildtools/:buildtools
@@ -84,7 +84,7 @@ post-install:
echo "fi"; \
echo ""; \
echo "# workaround for the problem that RStudio passes /lib with LD_LIBRARY_PATH that causes the /lib/libgcc_s.so.1 conflict with gcc"; \
- echo "LD_PRELOAD=${PREFIX}/lib/gcc6/libgcc_s.so ${PREFIX}/lib/rstudio/bin/rstudio \"$$@\"" \
+ echo "LD_PRELOAD=${PREFIX}/lib/gcc${GCC_DEFAULT}/libgcc_s.so ${PREFIX}/lib/rstudio/bin/rstudio \"$$@\"" \
) > ${STAGEDIR}${PREFIX}/bin/rstudio
@${CHMOD} +x ${STAGEDIR}${PREFIX}/bin/rstudio
@${REINPLACE_CMD} -e 's|^Exec=.*/rstudio|Exec=${PREFIX}/bin/rstudio|' ${STAGEDIR}${PREFIX}/share/applications/rstudio.desktop