aboutsummaryrefslogtreecommitdiff
path: root/devel/aarch64-gcc
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2018-03-23 23:53:52 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2018-03-23 23:53:52 +0000
commit9b6b838a93bdf6151f71653e0f5e9e8af6e4155b (patch)
tree62bd4cf82565587402a460797bb74349cff050d6 /devel/aarch64-gcc
parentabd7dc4985633d6a068ef0f6597f02ac81e77454 (diff)
downloadports-9b6b838a93bdf6151f71653e0f5e9e8af6e4155b.tar.gz
ports-9b6b838a93bdf6151f71653e0f5e9e8af6e4155b.zip
Fix --sysroot for cross-toolchain GCC packages
By default, GCC assumes that a cross compiler should not have any valid initial include or library paths aside from /usr/local/lib/gcc/<mumble>/. This means that one cannot use --sysroot to point to a system root for another architecture and have GCC automatically look for headers in ${sysroot}/usr/include, etc. Currently we workaround this in FreeBSD's build system with explicit -isystem, -B, and -L directives. However, this is cumbersome compared to clang (where a bare --sysroot DTRT) especially when using the compiler to build other software (such as test programs, etc.). One can override GCC's assumption and force it to assume that it should honor --sysroot by setting the '--with-sysroot' option to force GCC to assume a specific system root. By setting this to '/', this means that the cross-compiler will attempt to use the host's headers by default if --sysroot is not specified, but if --sysroot is specified then it is fully honored including for include paths and library paths. With this change I can now cross-compile both C and C++ binaries simply by using --sysroot without the need for -isystem, -B, or -L directives. Note that the base/gcc and devel/riscv64-gcc ports both use --with-sysroot='/' already. By default, GCC looks for headers in /usr/local/include (under the sysroot) before /usr/include. To disable this and only look for headers in /usr/include, patch gcc/Makefile.in to not define LOCAL_INCLUDE_DIR. Once -nostdinc is no longer required, the headers installed along with the compiler are now used for compiling worlds and test programs. The "fixed" headers in include-fixed are generally not helpful and are also derived from the host's headers which might not match the target --sysroot, so just delete them entirely. Even the stub limits.h headers GCC ships when using an empty build sysroot are not helpful and need to be removed. On a related note, I also fixed the name of the C++ include directory option to configure. By my reading it is 'with-gxx-include-dir' rather than 'with-gcc-include-dir'. Reviewed by: bapt, brooks, kan Sponsored by: DARPA / AFRL Differential Revision: https://reviews.freebsd.org/D14627
Notes
Notes: svn path=/head/; revision=465416
Diffstat (limited to 'devel/aarch64-gcc')
-rw-r--r--devel/aarch64-gcc/pkg-plist3
1 files changed, 0 insertions, 3 deletions
diff --git a/devel/aarch64-gcc/pkg-plist b/devel/aarch64-gcc/pkg-plist
index 3e513ce8990c..985237f38594 100644
--- a/devel/aarch64-gcc/pkg-plist
+++ b/devel/aarch64-gcc/pkg-plist
@@ -8,9 +8,6 @@ bin/%%GCC_TARGET%%-gcc-nm
bin/%%GCC_TARGET%%-gcc-ranlib
bin/%%GCC_TARGET%%-gcov
bin/%%GCC_TARGET%%-gcov-tool
-lib/gcc/%%GCC_TARGET%%/%%GCC_VERSION%%/include-fixed/README
-lib/gcc/%%GCC_TARGET%%/%%GCC_VERSION%%/include-fixed/limits.h
-lib/gcc/%%GCC_TARGET%%/%%GCC_VERSION%%/include-fixed/syslimits.h
lib/gcc/%%GCC_TARGET%%/%%GCC_VERSION%%/include/arm_acle.h
lib/gcc/%%GCC_TARGET%%/%%GCC_VERSION%%/include/arm_neon.h
lib/gcc/%%GCC_TARGET%%/%%GCC_VERSION%%/include/float.h