aboutsummaryrefslogtreecommitdiff
path: root/devel/ace+tao/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-19 13:00:57 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-19 13:00:57 +0000
commit47981fedc59b95a5110c036f31367f3967588788 (patch)
tree5c2b8134c97a6bfce1499e5f1ea39ea804895605 /devel/ace+tao/Makefile
parent90fc39e5b7c778ba6a92d20d5fc1a284fb64caf1 (diff)
downloadports-47981fedc59b95a5110c036f31367f3967588788.tar.gz
ports-47981fedc59b95a5110c036f31367f3967588788.zip
- Update to version 5.4.1
PR: ports/65138 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=107586
Diffstat (limited to 'devel/ace+tao/Makefile')
-rw-r--r--devel/ace+tao/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/devel/ace+tao/Makefile b/devel/ace+tao/Makefile
index 5a951290af04..586553b65ac8 100644
--- a/devel/ace+tao/Makefile
+++ b/devel/ace+tao/Makefile
@@ -7,7 +7,6 @@
PORTNAME?= ace+tao
PORTVERSION?= ${ACE_VERSION}+${TAO_VERSION}
-PORTREVISION?= 2
CATEGORIES= devel
MASTER_SITES= ftp://deuce.doc.wustl.edu/pub/previous_versions/ \
http://deuce.doc.wustl.edu/old_distribution/ \
@@ -19,8 +18,8 @@ COMMENT?= The Adaptive Communication Environment (ACE) with The ACE ORB (TAO)
CONFLICTS?= ace-*
-ACE_VERSION= 5.4.0
-TAO_VERSION= 1.4.0
+ACE_VERSION= 5.4.1
+TAO_VERSION= 1.4.1
USE_BZIP2= yes
USE_GMAKE= yes
@@ -60,7 +59,6 @@ post-patch:
${ACE_ROOT}/include/makeinclude/platform_macros.GNU; \
${CP} ${FILESDIR}/config.h ${ACE_ROOT}/ace; \
cd ${TAO_ROOT}/orbsvcs; \
- ${CHMOD} a-x default.bld; \
${CHMOD} a-x Logging_Service/Event_Logging_Service/*; \
${CHMOD} a-x Logging_Service/Notify_Logging_Service/*; \
${CHMOD} a-x Logging_Service/RTEvent_Logging_Service/*; \
@@ -134,7 +132,7 @@ test:
do-install:
@${ECHO_MSG} "Installing ACE headers into ${PREFIX}/include/ace"; \
cd ${ACE_ROOT}; \
- ${FIND} ace -not -name .shobj -type d -exec \
+ ${FIND} ace -not -path "*.shobj*" -type d -exec \
${MKDIR} ${PREFIX}/include/\{\} \; ; \
${FIND} ace -type f \( -name "*.h" -o -name "*.i" -o -name "*.inl" \
-o -name "*.cpp" \) \( -not -name "config-*.h" \
@@ -144,13 +142,13 @@ do-install:
.if !defined(WITHOUT_TAO)
@${ECHO_MSG} "Installing TAO headers into ${PREFIX}/include/tao"; \
cd ${TAO_ROOT}; \
- ${FIND} tao -not -name .shobj -not -name diffs -type d -exec \
+ ${FIND} tao -not -path "*.shobj*" -not -name diffs -type d -exec \
${MKDIR} ${PREFIX}/include/\{\} \; ; \
${FIND} tao -type f \( -name "*.h" -o -name "*.i" -o -name "*.inl" \
-o -name "*.idl" -o -name "*.pidl" -o -name "*.cpp" \) -exec \
${INSTALL_DATA} \{\} ${PREFIX}/include/\{\} \; ; \
cd ${TAO_ROOT}/orbsvcs; \
- ${FIND} orbsvcs -not -name .shobj -type d -exec \
+ ${FIND} orbsvcs -not -path "*.shobj*" -type d -exec \
${MKDIR} ${PREFIX}/include/\{\} \; ; \
${FIND} orbsvcs -type f \( -name "*.h" -o -name "*.i" -o -name "*.inl" \
-o -name "*.idl" -o -name "*.pidl" -o -name "*.cpp" \) -exec \