aboutsummaryrefslogtreecommitdiff
path: root/devel/acpicatools
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2007-09-02 14:11:33 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2007-09-02 14:11:33 +0000
commited7c21710ab26c6a64dc7dc2128a20986e480ef9 (patch)
treed38d67d338535125d4670a8b99a9bbf526cb6ad2 /devel/acpicatools
parent6e2fec5a3afdcb23bc757e8475bdf4e50c33a6cc (diff)
downloadports-ed7c21710ab26c6a64dc7dc2128a20986e480ef9.tar.gz
ports-ed7c21710ab26c6a64dc7dc2128a20986e480ef9.zip
Fix build on amd64/ia64
PR: 115897 Submitted by: Artem Naluzhny <tut@nhamon.com.ua>
Notes
Notes: svn path=/head/; revision=198647
Diffstat (limited to 'devel/acpicatools')
-rw-r--r--devel/acpicatools/Makefile4
-rw-r--r--devel/acpicatools/files/patch-osunixxf.c31
2 files changed, 29 insertions, 6 deletions
diff --git a/devel/acpicatools/Makefile b/devel/acpicatools/Makefile
index 7b4675bac7aa..7d10df6b389d 100644
--- a/devel/acpicatools/Makefile
+++ b/devel/acpicatools/Makefile
@@ -22,10 +22,6 @@ MAN8= acpidump.8
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "amd64"
-BROKEN= Does not compile on ia64 or amd64
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
${WRKDIR}/Makefile*
diff --git a/devel/acpicatools/files/patch-osunixxf.c b/devel/acpicatools/files/patch-osunixxf.c
index 5dae056fe40c..5daa75ae95e8 100644
--- a/devel/acpicatools/files/patch-osunixxf.c
+++ b/devel/acpicatools/files/patch-osunixxf.c
@@ -1,5 +1,32 @@
---- acpica-unix-20030523/osunixxf.c.orig Sat May 24 09:11:02 2003
-+++ acpica-unix-20030523/osunixxf.c Thu Jun 12 17:03:26 2003
+--- acpica-unix-20030523/osunixxf.c.orig 2003-05-24 03:11:02.000000000 +0300
++++ acpica-unix-20030523/osunixxf.c 2007-08-28 15:57:49.000000000 +0300
+@@ -452,7 +452,7 @@
+ ACPI_STATUS
+ AcpiOsMapMemory (
+ ACPI_PHYSICAL_ADDRESS where,
+- UINT32 length,
++ ACPI_SIZE length,
+ void **there)
+ {
+ *there = (void *) (UINT32) where;
+@@ -478,7 +478,7 @@
+ void
+ AcpiOsUnmapMemory (
+ void *where,
+- UINT32 length)
++ ACPI_SIZE length)
+ {
+
+ return;
+@@ -499,7 +499,7 @@
+
+ void *
+ AcpiOsAllocate (
+- UINT32 size)
++ ACPI_SIZE size)
+ {
+ void *Mem;
+
@@ -815,7 +815,7 @@
UINT32 milliseconds)
{