aboutsummaryrefslogtreecommitdiff
path: root/devel/acsccid/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-06-16 11:46:43 +0000
committerJohn Marino <marino@FreeBSD.org>2016-06-16 11:46:43 +0000
commita7634cc6c1dd15d478c1926f4c87ca41d39f0c35 (patch)
tree1746a1b65db013703679fcbeecf204c499b923cb /devel/acsccid/Makefile
parentf4786add8d6ace96c3f315357230730d917d8e21 (diff)
downloadports-a7634cc6c1dd15d478c1926f4c87ca41d39f0c35.tar.gz
ports-a7634cc6c1dd15d478c1926f4c87ca41d39f0c35.zip
devel/acsccid: Genericize to enable build on DragonFly
Also use OPSYS with OSVERSION. Approved by: non-invasive DF support blanket
Notes
Notes: svn path=/head/; revision=416957
Diffstat (limited to 'devel/acsccid/Makefile')
-rw-r--r--devel/acsccid/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/acsccid/Makefile b/devel/acsccid/Makefile
index af1b052ec0d1..14e8e458e96b 100644
--- a/devel/acsccid/Makefile
+++ b/devel/acsccid/Makefile
@@ -13,9 +13,9 @@ LICENSE= GPLv2
LIB_DEPENDS= libpcsclite.so:devel/pcsc-lite
-USES= perl5 pkgconfig tar:bz2
+USES= perl5 pkgconfig tar:bz2
-PLIST_FILES= lib/pcsc/drivers/ifd-acsccid.bundle/Contents/FreeBSD/libacsccid.so \
+PLIST_FILES= lib/pcsc/drivers/ifd-acsccid.bundle/Contents/${OPSYS}/libacsccid.so \
lib/pcsc/drivers/ifd-acsccid.bundle/Contents/Info.plist
GNU_CONFIGURE= yes
@@ -23,12 +23,12 @@ GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
# Old versions don't have pkgconfig files for libusb
-.if ${OSVERSION} < 1000024
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000024
CONFIGURE_ENV+= LIBUSB_CFLAGS="-I${LOCALBASE}/include" \
LIBUSB_LIBS="-L${LOCALBASE}/lib -lusb"
.endif
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pcsc/drivers/ifd-acsccid.bundle/Contents/FreeBSD/libacsccid.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pcsc/drivers/ifd-acsccid.bundle/Contents/${OPSYS}/libacsccid.so
.include <bsd.port.post.mk>