aboutsummaryrefslogtreecommitdiff
path: root/devel/adabooch-doc-html
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-27 06:22:23 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-27 06:22:23 +0000
commite7ac705e54f5e4f3c7971aa5694f1471a4e0b2d2 (patch)
tree2f91f456ec65168bcfe3e2b0ffcee6cb1714e004 /devel/adabooch-doc-html
parenta766e89b2b14bf9ba16a35b0efe5c267fcd56a85 (diff)
downloadports-e7ac705e54f5e4f3c7971aa5694f1471a4e0b2d2.tar.gz
ports-e7ac705e54f5e4f3c7971aa5694f1471a4e0b2d2.zip
New port: adabooch is a Booch implementation for Ada95
This is the documenation part of it. The Ada 95 version of the components will contain the same key abstractions as the C++ form (Structs, Tools and Support). However, the organization will be slightly different, particularly in the Support domain. This is because Ada 95 provides several special forms of memory management that are quite different from C++. The Structs category provides an array of structural abstractions (Bags, Collections, Deques, Graphs, Lists, Maps, Queues, Rings, Sets, Stacks, and Trees). The Tools category provides algorithmic abstractions (Searching, Sorting, etc.). The Support category contains all the "concrete" forms, plus structures to create the components. Some of the structures permit structural sharing (graphs, lists, and trees). Some structures may also be ordered (collections, dequeues, and queues). There are also multiple forms for some structures: single and double linked lists, directed and undirected graphs, and binary, multiway, and AVL trees. WWW: http://www.adapower.net/booch/ PR: ports/46448 Submitted by: David Holm <david@realityrift.com>
Notes
Notes: svn path=/head/; revision=89516
Diffstat (limited to 'devel/adabooch-doc-html')
-rw-r--r--devel/adabooch-doc-html/Makefile33
-rw-r--r--devel/adabooch-doc-html/distinfo1
-rw-r--r--devel/adabooch-doc-html/pkg-descr4
-rw-r--r--devel/adabooch-doc-html/pkg-plist18
4 files changed, 56 insertions, 0 deletions
diff --git a/devel/adabooch-doc-html/Makefile b/devel/adabooch-doc-html/Makefile
new file mode 100644
index 000000000000..c35d95d211e8
--- /dev/null
+++ b/devel/adabooch-doc-html/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: adabooch
+# Date created: 21 December 2002
+# Whom: David Holm <david@realityrift.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= adabooch-doc
+PORTVERSION= 20020602
+CATEGORIES= devel
+MASTER_SITES= http://www.adapower.net/booch/download/
+DISTNAME= bc-html-${PORTVERSION}
+EXTRACT_SUFX= .zip
+
+MAINTAINER= david@realityrift.com
+COMMENT= Manual for adabooch
+
+USE_ZIP= yes
+NO_BUILD= yes
+NO_MTREE= yes
+PREFIX= ${LOCALBASE}/share/doc
+WRKSRC= ${WRKDIR}/adabooch-doc-html
+EXTRACT_AFTER_ARGS= -d ${WRKSRC}
+
+pre-extract:
+ @${MKDIR} ${WRKSRC}
+
+do-install:
+ @${MKDIR} ${PREFIX}/adabooch
+ @${MKDIR} ${PREFIX}/adabooch/html
+ @(cd ${WRKSRC} && pax -r -w * ${PREFIX}/adabooch/html)
+
+.include <bsd.port.mk>
diff --git a/devel/adabooch-doc-html/distinfo b/devel/adabooch-doc-html/distinfo
new file mode 100644
index 000000000000..0e62054f17f2
--- /dev/null
+++ b/devel/adabooch-doc-html/distinfo
@@ -0,0 +1 @@
+MD5 (bc-html-20020602.zip) = c5ef5947d4e407d4396176f0865989dc
diff --git a/devel/adabooch-doc-html/pkg-descr b/devel/adabooch-doc-html/pkg-descr
new file mode 100644
index 000000000000..38f4afaab426
--- /dev/null
+++ b/devel/adabooch-doc-html/pkg-descr
@@ -0,0 +1,4 @@
+This is the manual for adabooch in HTML.
+
+- David Holm
+david@realityrift.com
diff --git a/devel/adabooch-doc-html/pkg-plist b/devel/adabooch-doc-html/pkg-plist
new file mode 100644
index 000000000000..6fa6239af339
--- /dev/null
+++ b/devel/adabooch-doc-html/pkg-plist
@@ -0,0 +1,18 @@
+adabooch/html/acl_faq.html
+adabooch/html/ada95lgo.gif
+adabooch/html/car-fleet.jpg
+adabooch/html/case-study.html
+adabooch/html/coldframe-hash.tgz
+adabooch/html/coldframe-hash.zip
+adabooch/html/compiler-problems.html
+adabooch/html/demos.html
+adabooch/html/documentation.html
+adabooch/html/download.html
+adabooch/html/greenline.gif
+adabooch/html/index.html
+adabooch/html/organization.jpg
+adabooch/html/overview.html
+adabooch/html/release.html
+adabooch/html/x.ada
+@dirrm adabooch/html
+@dirrm adabooch