aboutsummaryrefslogtreecommitdiff
path: root/devel/aixlog
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-06-17 05:14:08 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-06-17 05:14:08 +0000
commit55ed10dea43649f65316bdf07d22a4ffe9567221 (patch)
tree9d5aa300c2784a5d2b8b676141f7f112a35b02de /devel/aixlog
parent82c67b1071bebecf46ddf03e406c5715414d4317 (diff)
downloadports-55ed10dea43649f65316bdf07d22a4ffe9567221.tar.gz
ports-55ed10dea43649f65316bdf07d22a4ffe9567221.zip
New port: devel/aixlog: Header-only C++ logging library
Notes
Notes: svn path=/head/; revision=539404
Diffstat (limited to 'devel/aixlog')
-rw-r--r--devel/aixlog/Makefile25
-rw-r--r--devel/aixlog/distinfo3
-rw-r--r--devel/aixlog/pkg-descr11
3 files changed, 39 insertions, 0 deletions
diff --git a/devel/aixlog/Makefile b/devel/aixlog/Makefile
new file mode 100644
index 000000000000..d95f38799481
--- /dev/null
+++ b/devel/aixlog/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= aixlog
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.3.0
+CATEGORIES= devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Header-only C++ logging library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake
+USE_GITHUB= yes
+GH_ACCOUNT= badaix
+
+CMAKE_OFF= BUILD_EXAMPLE
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= include/aixlog.hpp
+
+.include <bsd.port.mk>
diff --git a/devel/aixlog/distinfo b/devel/aixlog/distinfo
new file mode 100644
index 000000000000..86a44b40e80d
--- /dev/null
+++ b/devel/aixlog/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1592370458
+SHA256 (badaix-aixlog-v1.3.0_GH0.tar.gz) = 748a00d3185eeb5cd8f0d751c4ef89d8c0948364024a432d2536eef883c9c782
+SIZE (badaix-aixlog-v1.3.0_GH0.tar.gz) = 12411
diff --git a/devel/aixlog/pkg-descr b/devel/aixlog/pkg-descr
new file mode 100644
index 000000000000..e6eddf3c51fa
--- /dev/null
+++ b/devel/aixlog/pkg-descr
@@ -0,0 +1,11 @@
+Header-only C++ logging library
+
+Features:
+* Single header file implementation
+* No dependcies, just vanilla C++11
+* Use ostream operator <<
+* Unobtrusive, typesafe and expressive
+* Easy to switch from existing "cout logging"
+* Native support for various platforms (through Sinks)
+
+WWW: https://github.com/badaix/aixlog