aboutsummaryrefslogtreecommitdiff
path: root/devel/allegro
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-04-24 20:53:10 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-04-24 20:53:10 +0000
commit3e3f01799b81cb5bdf892e7a6912e2d7f609f652 (patch)
treee2792f79760e7f6f99b41cc9f0dd3ff0663077b7 /devel/allegro
parent4b7ab768c33cfc57f81483b066df7128ef98f098 (diff)
downloadports-3e3f01799b81cb5bdf892e7a6912e2d7f609f652.tar.gz
ports-3e3f01799b81cb5bdf892e7a6912e2d7f609f652.zip
- Remove USE_REINPLACE.
- Rename some OPTIONS to more standard names: DEBUG_LIB -> DEBUG DEV_UTILS -> DEVEL PROFILE_LIB -> PROFILE - Remove unavoidable auto-detection of OPTIONS. - Format tabs, sort variables. Approved by: garga (mentor)
Notes
Notes: svn path=/head/; revision=160368
Diffstat (limited to 'devel/allegro')
-rw-r--r--devel/allegro/Makefile62
-rw-r--r--devel/allegro/pkg-plist32
2 files changed, 46 insertions, 48 deletions
diff --git a/devel/allegro/Makefile b/devel/allegro/Makefile
index 639772b5cf4f..1ddff5c955e8 100644
--- a/devel/allegro/Makefile
+++ b/devel/allegro/Makefile
@@ -14,28 +14,26 @@ MASTER_SITE_SUBDIR= alleg
MAINTAINER= alepulver@FreeBSD.org
COMMENT= A cross-platform library for games and multimedia programming
+USE_AUTOTOOLS= autoconf:259
USE_GMAKE= yes
-USE_REINPLACE= yes
USE_XLIB= yes
WANT_GNOME= yes
-USE_AUTOTOOLS= autoconf:259
-
-.include "Makefile.man"
-
-INFO= allegro
-
OPTIONS= ARTS "Enable Arts support" off \
- DEBUG_LIB "Build debugging library" off \
- DEV_UTILS "Build development utilities" on \
+ DEBUG "Build debugging library" off \
+ DEVEL "Build development utilities" on \
ESOUND "Enable Esound support" off \
OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
- PROFILE_LIB "Build profiling library" off \
+ PROFILE "Build profiling library" off \
THREADS "Enable threads" on
MAKEFILE= makefile
ALL_TARGET= full-build
+.include "Makefile.man"
+
+INFO= allegro
+
INSTALLS_SHLIB= yes
SHLIB_VER= 42
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
@@ -47,54 +45,54 @@ DEMO= demo.c demo.dat demo.h music.txt ../readme.txt
EXTRA_PATCHES= ${FILESDIR}/extra-patch-include-allegro-inline-fmaths.in
.endif
-.if defined(WITH_ARTS) || exists(${LOCALBASE}/lib/libartsc.so.0)
+.if defined(WITH_ARTS)
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
-CONFIGURE_ARGS+= --enable-artsdigi
+CONFIGURE_ARGS+=--enable-artsdigi
PLIST_SUB+= ARTS=""
.else
-CONFIGURE_ARGS+= --disable-artsdigi
+CONFIGURE_ARGS+=--disable-artsdigi
PLIST_SUB+= ARTS="@comment "
.endif
-.if defined(WITH_DEBUG_LIB)
-CONFIGURE_ARGS+= --enable-dbglib
-PLIST_SUB+= DEBUG_LIB=""
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-dbglib
+PLIST_SUB+= DEBUG=""
.else
-CONFIGURE_ARGS+= --disable-dbglib
-PLIST_SUB+= DEBUG_LIB="@comment "
+CONFIGURE_ARGS+=--disable-dbglib
+PLIST_SUB+= DEBUG="@comment "
.endif
-.if !defined(WITHOUT_DEV_UTILS)
+.if !defined(WITHOUT_DEVEL)
INSTALL_TARGET= full-install install-man install-info
-PLIST_SUB+= DEV_UTILS=""
+PLIST_SUB+= DEVEL=""
.else
INSTALL_TARGET= mini-install install-man install-info
-PLIST_SUB+= DEV_UTILS="@comment "
+PLIST_SUB+= DEVEL="@comment "
.endif
-.if defined(WITH_ESOUND) || ${HAVE_GNOME:Mesound}!=""
+.if defined(WITH_ESOUND)
USE_GNOME+= esound
-CONFIGURE_ARGS+= --enable-esddigi
+CONFIGURE_ARGS+=--enable-esddigi
PLIST_SUB+= ESOUND=""
.else
-CONFIGURE_ARGS+= --disable-esddigi
+CONFIGURE_ARGS+=--disable-esddigi
PLIST_SUB+= ESOUND="@comment "
.endif
-.if defined(WITH_PROFILE_LIB)
-CONFIGURE_ARGS+= --enable-proflib
-PLIST_SUB+= PROFILE_LIB=""
+.if defined(WITH_PROFILE)
+CONFIGURE_ARGS+=--enable-proflib
+PLIST_SUB+= PROFILE=""
.else
-CONFIGURE_ARGS+= --disable-proflib
-PLIST_SUB+= PROFILE_LIB="@comment "
+CONFIGURE_ARGS+=--disable-proflib
+PLIST_SUB+= PROFILE="@comment "
.endif
.if !defined(WITHOUT_THREADS)
-CONFIGURE_ARGS+= --enable-pthreads
+CONFIGURE_ARGS+=--enable-pthreads
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -DHAVE_LIBPTHREAD" \
LDFLAGS="${PTHREAD_LIBS}"
.else
-CONFIGURE_ARGS+= --disable-pthreads
+CONFIGURE_ARGS+=--disable-pthreads
.endif
post-patch:
@@ -118,7 +116,7 @@ post-patch:
s|-ffast-math||g ; \
s|-fomit-frame-pointer||g ; \
s|-funroll-loops||g' \
- ${CONFIGURE_WRKSRC}/configure.in
+ ${CONFIGURE_WRKSRC}/configure.in
.endif
post-install:
diff --git a/devel/allegro/pkg-plist b/devel/allegro/pkg-plist
index 03f636bedefc..79155906def8 100644
--- a/devel/allegro/pkg-plist
+++ b/devel/allegro/pkg-plist
@@ -1,14 +1,14 @@
bin/allegro-config
-%%DEV_UTILS%%bin/colormap
-%%DEV_UTILS%%bin/dat
-%%DEV_UTILS%%bin/dat2c
-%%DEV_UTILS%%bin/dat2s
-%%DEV_UTILS%%bin/exedat
-%%DEV_UTILS%%bin/grabber
-%%DEV_UTILS%%bin/pack
-%%DEV_UTILS%%bin/pat2dat
-%%DEV_UTILS%%bin/rgbmap
-%%DEV_UTILS%%bin/textconv
+%%DEVEL%%bin/colormap
+%%DEVEL%%bin/dat
+%%DEVEL%%bin/dat2c
+%%DEVEL%%bin/dat2s
+%%DEVEL%%bin/exedat
+%%DEVEL%%bin/grabber
+%%DEVEL%%bin/pack
+%%DEVEL%%bin/pat2dat
+%%DEVEL%%bin/rgbmap
+%%DEVEL%%bin/textconv
include/allegro.h
include/allegro/3d.h
include/allegro/3dmaths.h
@@ -99,15 +99,15 @@ include/xalleg.h
lib/allegro/%%SHLIB_VER%%/alleg-dga2.so
%%ESOUND%%lib/allegro/%%SHLIB_VER%%/alleg-esddigi.so
lib/allegro/%%SHLIB_VER%%/modules.lst
-%%DEBUG_LIB%%lib/liballd.so
-%%DEBUG_LIB%%lib/liballd.so.%%SHLIB_VER%%
-%%DEBUG_LIB%%lib/liballd_unsharable.a
+%%DEBUG%%lib/liballd.so
+%%DEBUG%%lib/liballd.so.%%SHLIB_VER%%
+%%DEBUG%%lib/liballd_unsharable.a
lib/liballeg.so
lib/liballeg.so.%%SHLIB_VER%%
lib/liballeg_unsharable.a
-%%PROFILE_LIB%%lib/liballp.so
-%%PROFILE_LIB%%lib/liballp.so.%%SHLIB_VER%%
-%%PROFILE_LIB%%lib/liballp_unsharable.a
+%%PROFILE%%lib/liballp.so
+%%PROFILE%%lib/liballp.so.%%SHLIB_VER%%
+%%PROFILE%%lib/liballp_unsharable.a
share/aclocal/allegro.m4
%%PORTDOCS%%%%DOCSDIR%%/abi.html
%%PORTDOCS%%%%DOCSDIR%%/ahack.html