aboutsummaryrefslogtreecommitdiff
path: root/devel/allegro
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-06-30 17:46:46 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-06-30 17:46:46 +0000
commit3e8732e462139491ef424667bdceb42ebb67b1fb (patch)
tree2929aade5916f90f12ce127ad498a1f6b1f7b8a5 /devel/allegro
parentcfb8fe6e959d91741e070cf38621bea853950bfc (diff)
downloadports-3e8732e462139491ef424667bdceb42ebb67b1fb.tar.gz
ports-3e8732e462139491ef424667bdceb42ebb67b1fb.zip
- Add WITHOUT_THREADS knob.
PR: ports/82818 Submitted by: Gunter Wambaugh <gunter@thewambaughs.net>
Notes
Notes: svn path=/head/; revision=138257
Diffstat (limited to 'devel/allegro')
-rw-r--r--devel/allegro/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/devel/allegro/Makefile b/devel/allegro/Makefile
index 207c85e6b389..3459828d3f22 100644
--- a/devel/allegro/Makefile
+++ b/devel/allegro/Makefile
@@ -20,9 +20,15 @@ WANT_GNOME= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_AUTOCONF_VER= 253
+
+.if !defined(WITHOUT_THREADS)
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -DHAVE_LIBPTHREAD" \
LDFLAGS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-vga=no
+.else
+CONFIGURE_ARGS= --enable-vga=no --enable-pthreads=no
+.endif
+
MAKEFILE= makefile
ALL_TARGET= full-build
INSTALLS_SHLIB= yes