aboutsummaryrefslogtreecommitdiff
path: root/devel/allegro
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-08-10 02:06:20 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-08-10 02:06:20 +0000
commitba40e2a699bce7ab7cb6f29948df0bf4f25610f8 (patch)
treee267e797cd6b8ea3e8635e294ce19d6cb5e46461 /devel/allegro
parentdc0fd5fb831789955f7009142dca300a17c07f06 (diff)
downloadports-ba40e2a699bce7ab7cb6f29948df0bf4f25610f8.tar.gz
ports-ba40e2a699bce7ab7cb6f29948df0bf4f25610f8.zip
- Add AL and JACK options.
- Replace INSTALLS_SHLIB with USE_LDCONFIG. - Add CONFLICTS with future port allegro-devel.
Notes
Notes: svn path=/head/; revision=170237
Diffstat (limited to 'devel/allegro')
-rw-r--r--devel/allegro/Makefile28
-rw-r--r--devel/allegro/pkg-plist2
2 files changed, 27 insertions, 3 deletions
diff --git a/devel/allegro/Makefile b/devel/allegro/Makefile
index 1ddff5c955e8..ede825289a49 100644
--- a/devel/allegro/Makefile
+++ b/devel/allegro/Makefile
@@ -16,13 +16,16 @@ COMMENT= A cross-platform library for games and multimedia programming
USE_AUTOTOOLS= autoconf:259
USE_GMAKE= yes
+USE_LDCONFIG= yes
USE_XLIB= yes
WANT_GNOME= yes
-OPTIONS= ARTS "Enable Arts support" off \
+OPTIONS= AL "Enable OpenAL support" off \
+ ARTS "Enable Arts support" off \
DEBUG "Build debugging library" off \
DEVEL "Build development utilities" on \
ESOUND "Enable Esound support" off \
+ JACK "Enable JACK support" off \
OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
PROFILE "Build profiling library" off \
THREADS "Enable threads" on
@@ -34,9 +37,10 @@ ALL_TARGET= full-build
INFO= allegro
-INSTALLS_SHLIB= yes
-SHLIB_VER= 42
+CONFLICTS= allegro-devel-[0-9]*
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
+
+SHLIB_VER= 42
DEMO= demo.c demo.dat demo.h music.txt ../readme.txt
.include <bsd.port.pre.mk>
@@ -45,6 +49,15 @@ DEMO= demo.c demo.dat demo.h music.txt ../readme.txt
EXTRA_PATCHES= ${FILESDIR}/extra-patch-include-allegro-inline-fmaths.in
.endif
+.if defined(WITH_AL)
+LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
+CONFIGURE_ARGS+=--enable-sgialdigi
+PLIST_SUB+= AL=""
+.else
+CONFIGURE_ARGS+=--disable-sgialdigi
+PLIST_SUB+= AL="@comment "
+.endif
+
.if defined(WITH_ARTS)
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
CONFIGURE_ARGS+=--enable-artsdigi
@@ -79,6 +92,15 @@ CONFIGURE_ARGS+=--disable-esddigi
PLIST_SUB+= ESOUND="@comment "
.endif
+.if defined(WITH_JACK)
+LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
+CONFIGURE_ARGS+=--enable-jackdigi
+PLIST_SUB+= JACK=""
+.else
+CONFIGURE_ARGS+=--disable-jackdigi
+PLIST_SUB+= JACK="@comment "
+.endif
+
.if defined(WITH_PROFILE)
CONFIGURE_ARGS+=--enable-proflib
PLIST_SUB+= PROFILE=""
diff --git a/devel/allegro/pkg-plist b/devel/allegro/pkg-plist
index 79155906def8..683321abbc22 100644
--- a/devel/allegro/pkg-plist
+++ b/devel/allegro/pkg-plist
@@ -98,6 +98,8 @@ include/xalleg.h
%%ARTS%%lib/allegro/%%SHLIB_VER%%/alleg-artsdigi.so
lib/allegro/%%SHLIB_VER%%/alleg-dga2.so
%%ESOUND%%lib/allegro/%%SHLIB_VER%%/alleg-esddigi.so
+%%JACK%%lib/allegro/%%SHLIB_VER%%/alleg-jackdigi.so
+%%AL%%lib/allegro/%%SHLIB_VER%%/alleg-sgialdigi.so
lib/allegro/%%SHLIB_VER%%/modules.lst
%%DEBUG%%lib/liballd.so
%%DEBUG%%lib/liballd.so.%%SHLIB_VER%%