aboutsummaryrefslogtreecommitdiff
path: root/devel/ammonite/Makefile
diff options
context:
space:
mode:
authorJens Grassel <freebsd-ports@jan0sch.de>2022-01-18 15:46:45 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-01-18 16:15:08 +0000
commit2d46959df26a2dd3e99521dc5fb5b1f0dc67c2fb (patch)
tree7be29eee3bd10c2e73945ff2997263b19830ef1a /devel/ammonite/Makefile
parent61375c027e18a6ec5ce9af4426b789fe337f0d03 (diff)
downloadports-2d46959df26a2dd3e99521dc5fb5b1f0dc67c2fb.tar.gz
ports-2d46959df26a2dd3e99521dc5fb5b1f0dc67c2fb.zip
shells/ammonite: Update to 2.5.1 and MOVE
The authors removed the shell functionality but it is still a good dev-tool. Changelog --------- * Added support for Scala 2.13.8 * Re-added old Main entry point for better compatibility with Ammonite 2.4 and older * Dropped built-in support for shell operations * move from shells/ammonite to devel/ammonite PR: 261191 Reported by: freebsd-ports@jan0sch.de (maintainer)
Diffstat (limited to 'devel/ammonite/Makefile')
-rw-r--r--devel/ammonite/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/ammonite/Makefile b/devel/ammonite/Makefile
new file mode 100644
index 000000000000..72172ba8ebc4
--- /dev/null
+++ b/devel/ammonite/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= ammonite
+DISTVERSION= 2.5.1
+CATEGORIES= devel java
+MASTER_SITES= https://github.com/lihaoyi/Ammonite/releases/download/${PORTVERSION}/
+DISTNAME= 2.13-${PORTVERSION}
+EXTRACT_SUFX=
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY=
+
+MAINTAINER= freebsd-ports@jan0sch.de
+COMMENT= Provides a system shell in the high-level Scala language
+
+LICENSE= MIT
+
+USE_JAVA= yes
+JAVA_VERSION= 1.8+
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/ammonite
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} ${WRKSRC}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>