aboutsummaryrefslogtreecommitdiff
path: root/devel/anjuta/files
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2001-03-31 16:10:34 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2001-03-31 16:10:34 +0000
commit84d831a01d66010873215e66a786dafa38f87ce6 (patch)
tree3452d214dee4886242fdb9646258aadffee752fe /devel/anjuta/files
parent8ca30908d358c8befdb8933b72d2f0a88a08c5a8 (diff)
downloadports-84d831a01d66010873215e66a786dafa38f87ce6.tar.gz
ports-84d831a01d66010873215e66a786dafa38f87ce6.zip
New port: anjuta.
Anjuta is an Integrated Development Environment for C and C++.
Notes
Notes: svn path=/head/; revision=40672
Diffstat (limited to 'devel/anjuta/files')
-rw-r--r--devel/anjuta/files/patch-Makefile.in25
-rw-r--r--devel/anjuta/files/patch-configure49
-rw-r--r--devel/anjuta/files/patch-doc-Makefile.in11
-rw-r--r--devel/anjuta/files/patch-launcher-Makefile.in26
-rw-r--r--devel/anjuta/files/patch-macros-Makefile.in11
-rw-r--r--devel/anjuta/files/patch-src-Makefile.in134
-rw-r--r--devel/anjuta/files/patch-src-anjuta_dirs.c17
7 files changed, 273 insertions, 0 deletions
diff --git a/devel/anjuta/files/patch-Makefile.in b/devel/anjuta/files/patch-Makefile.in
new file mode 100644
index 000000000000..a1c4c6178fa8
--- /dev/null
+++ b/devel/anjuta/files/patch-Makefile.in
@@ -0,0 +1,25 @@
+--- Makefile.in.orig Sat Mar 31 19:36:17 2001
++++ Makefile.in Sat Mar 31 19:37:04 2001
+@@ -110,10 +110,10 @@
+ cxxflags_set = @cxxflags_set@
+ l = @l@
+
+-SUBDIRS = intl po macros scintilla src pixmaps data help doc launcher
++SUBDIRS = intl po macros src pixmaps data help doc launcher
+
+ anjutadocdir = ${prefix}/doc/anjuta
+-anjutadoc_DATA = README COPYING AUTHORS ChangeLog INSTALL NEWS TODO ABOUT-NLS
++anjutadoc_DATA =
+
+
+ EXTRA_DIST = anjuta.prj $(anjutadoc_DATA)
+@@ -384,8 +384,7 @@
+ install-exec-am:
+ install-exec: install-exec-recursive
+
+-install-data-am: install-anjutadocDATA install-gnomemenuDATA \
+- install-data-local
++install-data-am: install-anjutadocDATA install-gnomemenuDATA
+ install-data: install-data-recursive
+
+ install-am: all-am
diff --git a/devel/anjuta/files/patch-configure b/devel/anjuta/files/patch-configure
new file mode 100644
index 000000000000..49e68803ff27
--- /dev/null
+++ b/devel/anjuta/files/patch-configure
@@ -0,0 +1,49 @@
+--- configure.orig Sat Mar 31 19:18:57 2001
++++ configure Sat Mar 31 19:19:59 2001
+@@ -8,6 +8,7 @@
+ # gives unlimited permission to copy, distribute and modify it.
+
+ # Defaults:
++GLIB_CONFIG="$GLIB_CONFIG"
+ ac_help=
+ ac_default_prefix=/usr/local
+ # Any additions from configure.in:
+@@ -4551,10 +4552,10 @@
+ PACKAGE_PIXMAPS_DIR="`gnome-config --datadir`/pixmaps/${PACKAGE}"
+
+
+-PACKAGE_HELP_DIR="`gnome-config --datadir`/gnome/help/${PACKAGE}"
++PACKAGE_HELP_DIR="`gnome-config --datadir`/help/${PACKAGE}"
+
+
+-PACKAGE_MENU_DIR="`gnome-config --datadir`/gnome/apps"
++PACKAGE_MENU_DIR="`gnome-config --datadir`/apps"
+
+
+ trap '' 1 2 15
+@@ -4663,8 +4664,6 @@
+ intl/Makefile
+ po/Makefile.in
+ macros/Makefile
+-scintilla/Makefile
+-scintilla/include/Makefile
+ anjuta.spec
+ src/Makefile
+ pixmaps/Makefile
+@@ -4743,6 +4742,7 @@
+ s%@GNOME_CAPPLET_LIBS@%$GNOME_CAPPLET_LIBS%g
+ s%@cflags_set@%$cflags_set%g
+ s%@GTK_CONFIG@%$GTK_CONFIG%g
++s%@GLIB_CONFIG@%$GLIB_CONFIG%g
+ s%@GTK_CFLAGS@%$GTK_CFLAGS%g
+ s%@GTK_LIBS@%$GTK_LIBS%g
+ s%@XPM_LIBS@%$XPM_LIBS%g
+@@ -4818,8 +4818,6 @@
+ intl/Makefile
+ po/Makefile.in
+ macros/Makefile
+-scintilla/Makefile
+-scintilla/include/Makefile
+ anjuta.spec
+ src/Makefile
+ pixmaps/Makefile
diff --git a/devel/anjuta/files/patch-doc-Makefile.in b/devel/anjuta/files/patch-doc-Makefile.in
new file mode 100644
index 000000000000..99bb77ee8669
--- /dev/null
+++ b/devel/anjuta/files/patch-doc-Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig Sat Mar 31 00:14:22 2001
++++ doc/Makefile.in Sat Mar 31 00:24:25 2001
+@@ -112,7 +112,7 @@
+
+ anjuta_docdir = ${prefix}/doc/anjuta
+
+-anjuta_doc_DATA = ScintillaDoc.html
++anjuta_doc_DATA =
+
+
+ EXTRA_DIST = $(anjuta_doc_DATA)
diff --git a/devel/anjuta/files/patch-launcher-Makefile.in b/devel/anjuta/files/patch-launcher-Makefile.in
new file mode 100644
index 000000000000..535d73f94564
--- /dev/null
+++ b/devel/anjuta/files/patch-launcher-Makefile.in
@@ -0,0 +1,26 @@
+--- launcher/Makefile.in.orig Thu Mar 29 15:54:01 2001
++++ launcher/Makefile.in Thu Mar 29 15:54:45 2001
+@@ -12,6 +12,7 @@
+
+
+ SHELL = @SHELL@
++GLIB_CONFIG = @GLIB_CONFIG@
+
+ srcdir = @srcdir@
+ top_srcdir = @top_srcdir@
+@@ -110,13 +111,13 @@
+ cxxflags_set = @cxxflags_set@
+ l = @l@
+
+-INCLUDES = `glib-config --cflags` -I. -I.. -g -O
++INCLUDES = `$(GLIB_CONFIG) --cflags` -I. -I.. -g -O
+
+ bin_PROGRAMS = anjuta_launcher
+
+ anjuta_launcher_SOURCES = anjuta_launcher.c
+
+-anjuta_launcher_LDFLAGS = `glib-config --libs`
++anjuta_launcher_LDFLAGS = `$(GLIB_CONFIG) --libs`
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES =
diff --git a/devel/anjuta/files/patch-macros-Makefile.in b/devel/anjuta/files/patch-macros-Makefile.in
new file mode 100644
index 000000000000..c190b2619193
--- /dev/null
+++ b/devel/anjuta/files/patch-macros-Makefile.in
@@ -0,0 +1,11 @@
+--- macros/Makefile.in.orig Sat Mar 31 18:51:20 2001
++++ macros/Makefile.in Sat Mar 31 18:51:11 2001
+@@ -189,7 +189,7 @@
+ install-exec-am:
+ install-exec: install-exec-am
+
+-install-data-am: install-gnome_aclocalDATA
++install-data-am:
+ install-data: install-data-am
+
+ install-am: all-am
diff --git a/devel/anjuta/files/patch-src-Makefile.in b/devel/anjuta/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..739e0d80b37b
--- /dev/null
+++ b/devel/anjuta/files/patch-src-Makefile.in
@@ -0,0 +1,134 @@
+--- src/Makefile.in.orig Sat Mar 31 19:14:49 2001
++++ src/Makefile.in Sat Mar 31 19:17:53 2001
+@@ -110,7 +110,7 @@
+ cxxflags_set = @cxxflags_set@
+ l = @l@
+
+-INCLUDES = -I$(top_srcdir)/intl $(GNOME_INCLUDEDIR) -I../scintilla/include -I. -I.. -DHAVE_CONFIG_H -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wtraditional -Wpointer-arith -Wmissing-prototypes -O1 -g
++INCLUDES = -I$(top_srcdir)/intl -I$(prefix)/include/scintilla $(GNOME_INCLUDEDIR) -I. -I.. -DHAVE_CONFIG_H -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wtraditional -Wpointer-arith -Wmissing-prototypes -O1 -g
+
+
+ bin_PROGRAMS = anjuta
+@@ -118,7 +118,7 @@
+ anjuta_SOURCES = aneditor.cxx aneditor.h anjuta.h anjuta_cbs.c anjuta_dirs.c anjuta_dirs.h anjuta_info.c anjuta_info.h appwidz_page1.c appwidz_page2.c appwidz_page3.c appwidzard.c appwidzard.h appwidzard_cbs.c appwidzard_cbs.h appwidzard_gui.c attach_process.c attach_process.h attach_process_cbs.c attach_process_cbs.h attach_process_gui.c breakpoints.c breakpoints.h breakpoints_cbs.c breakpoints_cbs.h breakpoints_gui.c build_file.c build_file.h build_project.c build_project.h clean_project.c clean_project.h commands.c commands.h compile.c compile.h compiler_options.c compiler_options.h compiler_options_cbs.c compiler_options_cbs.h compiler_options_gui.c configurer.c configurer.h controls.c controls.h debugger.c debugger.h executer.c executer.h fileselection.c fileselection.h find_in_files.c find_in_files.h find_in_files_cbs.c find_in_files_cbs.h find_in_files_gui.c find_replace.c find_replace.h find_text.c find_text.h global.h gnome_project.c gnome_project.h goto_line.c goto_line.h launcher.c launcher.h lexer.h main.c main_menubar.c main_menubar.h main_menubar_def.h mainmenu_callbacks.c mainmenu_callbacks.h messagebox.c messagebox.h messages.c messages.h pixmaps.h preferences.c preferences.h preferences_gui.c project_dbase.c project_dbase.h project_config.c project_config.h project_dbase_gui.c properties.cxx properties.h registers.c registers.h registers_cbs.c registers_cbs.h registers_gui.c sharedlib.c sharedlib.h sharedlib_cbs.c sharedlib_cbs.h sharedlib_gui.c signals.c signals.h signals_cbs.c signals_cbs.h signals_gui.c splash.c splash.h src_paths.c src_paths.h src_paths_cbs.c src_paths_cbs.h src_paths_gui.c stack_trace.c stack_trace.h stack_trace_cbs.c stack_trace_cbs.h stack_trace_gui.c support.c support.h syntax.h tags_manager.c tags_manager.h text_editor.c text_editor.h text_editor_cbs.c text_editor_cbs.h text_editor_gui.c text_editor_gui.h text_editor_menu.c text_editor_menu.h toolbar.c toolbar.h toolbar_callbacks.c toolbar_callbacks.h utilities.c utilities.h watch.c watch.h watch_cbs.c watch_cbs.h watch_gui.c about.c appwidz_page4.c source.c anjuta.c anjuta_gui.c source.h glade_iface.c glade_iface.h compatibility_0.c compatibility_0.h defaults.c defaults.h about.h
+
+
+-anjuta_LDADD = $(INTLLIBS) $(GNOME_LIBDIR) $(GNOMEUI_LIBS) -L../scintilla -lscintilla ../scintilla/LexCPP.o ../scintilla/LexConf.o ../scintilla/LexHTML.o ../scintilla/LexLua.o ../scintilla/LexOthers.o ../scintilla/LexPerl.o ../scintilla/LexPython.o ../scintilla/LexSQL.o ../scintilla/LexVB.o ../scintilla/LexPascal.o
++anjuta_LDADD = $(INTLLIBS) $(GNOME_LIBDIR) $(GNOMEUI_LIBS) -lscintilla
+
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+@@ -150,10 +150,7 @@
+ utilities.o watch.o watch_cbs.o watch_gui.o about.o appwidz_page4.o \
+ source.o anjuta.o anjuta_gui.o glade_iface.o compatibility_0.o \
+ defaults.o
+-anjuta_DEPENDENCIES = ../scintilla/LexCPP.o ../scintilla/LexConf.o \
+-../scintilla/LexHTML.o ../scintilla/LexLua.o ../scintilla/LexOthers.o \
+-../scintilla/LexPerl.o ../scintilla/LexPython.o ../scintilla/LexSQL.o \
+-../scintilla/LexVB.o ../scintilla/LexPascal.o
++anjuta_DEPENDENCIES =
+ anjuta_LDFLAGS =
+ CXXFLAGS = @CXXFLAGS@
+ CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
+@@ -279,14 +276,8 @@
+ fi; \
+ done
+ about.o: about.c ../config.h utilities.h support.h about.h
+-aneditor.o: aneditor.cxx ../config.h ../scintilla/include/Platform.h \
+- ../scintilla/include/PropSet.h ../scintilla/include/SString.h \
+- ../scintilla/include/Accessor.h \
+- ../scintilla/include/WindowAccessor.h \
+- ../scintilla/include/KeyWords.h \
+- ../scintilla/include/Scintilla.h \
+- ../scintilla/include/ScintillaWidget.h \
+- ../scintilla/include/SciLexer.h lexer.h properties.h aneditor.h
++aneditor.o: aneditor.cxx ../config.h \
++ lexer.h properties.h aneditor.h
+ anjuta.o: anjuta.c ../config.h text_editor.h global.h text_editor_menu.h \
+ preferences.h properties.h aneditor.h anjuta.h toolbar.h \
+ messagebox.h compiler_options.h src_paths.h find_replace.h \
+@@ -295,9 +286,7 @@
+ anjuta_dirs.h executer.h configurer.h utilities.h \
+ main_menubar.h fileselection.h support.h launcher.h debugger.h \
+ watch.h registers.h stack_trace.h signals.h sharedlib.h \
+- attach_process.h controls.h anjuta_info.h \
+- ../scintilla/include/Scintilla.h \
+- ../scintilla/include/ScintillaWidget.h
++ attach_process.h controls.h anjuta_info.h
+ anjuta_cbs.o: anjuta_cbs.c ../config.h text_editor.h global.h \
+ text_editor_menu.h preferences.h properties.h aneditor.h \
+ anjuta.h toolbar.h messagebox.h compiler_options.h src_paths.h \
+@@ -480,9 +469,7 @@
+ messagebox.h compiler_options.h src_paths.h find_replace.h \
+ find_text.h find_in_files.h messages.h project_dbase.h \
+ tags_manager.h project_config.h commands.h anjuta_dirs.h \
+- executer.h configurer.h utilities.h main_menubar.h controls.h \
+- ../scintilla/include/Scintilla.h \
+- ../scintilla/include/ScintillaWidget.h
++ executer.h configurer.h utilities.h main_menubar.h controls.h
+ debugger.o: debugger.c ../config.h anjuta.h toolbar.h text_editor.h \
+ global.h text_editor_menu.h preferences.h properties.h \
+ aneditor.h messagebox.h compiler_options.h src_paths.h \
+@@ -535,9 +522,7 @@
+ src_paths.h find_replace.h find_text.h find_in_files.h \
+ messages.h project_dbase.h tags_manager.h project_config.h \
+ commands.h breakpoints.h anjuta_dirs.h executer.h configurer.h \
+- utilities.h main_menubar.h support.h \
+- ../scintilla/include/Scintilla.h \
+- ../scintilla/include/ScintillaWidget.h
++ utilities.h main_menubar.h support.h
+ find_text.o: find_text.c ../config.h anjuta.h toolbar.h text_editor.h \
+ global.h text_editor_menu.h preferences.h properties.h \
+ aneditor.h messagebox.h compiler_options.h src_paths.h \
+@@ -600,8 +585,7 @@
+ launcher.h appwidzard.h debugger.h watch.h registers.h \
+ stack_trace.h signals.h sharedlib.h attach_process.h \
+ breakpoints_cbs.h goto_line.h support.h controls.h \
+- signals_cbs.h watch_cbs.h ../scintilla/include/Scintilla.h \
+- ../scintilla/include/ScintillaWidget.h
++ signals_cbs.h watch_cbs.h
+ messagebox.o: messagebox.c ../config.h text_editor.h global.h \
+ text_editor_menu.h preferences.h properties.h aneditor.h \
+ mainmenu_callbacks.h messagebox.h support.h
+@@ -653,8 +637,7 @@
+ messages.h project_dbase.h tags_manager.h project_config.h \
+ commands.h breakpoints.h anjuta_dirs.h executer.h configurer.h \
+ utilities.h main_menubar.h support.h
+-properties.o: properties.cxx ../scintilla/include/PropSet.h \
+- ../scintilla/include/SString.h properties.h
++properties.o: properties.cxx properties.h
+ registers.o: registers.c ../config.h support.h debugger.h global.h \
+ breakpoints.h properties.h text_editor.h text_editor_menu.h \
+ preferences.h aneditor.h watch.h registers.h stack_trace.h \
+@@ -758,9 +741,7 @@
+ messages.h project_dbase.h tags_manager.h project_config.h \
+ commands.h breakpoints.h anjuta_dirs.h executer.h configurer.h \
+ utilities.h main_menubar.h text_editor_gui.h text_editor_cbs.h \
+- syntax.h launcher.h ../scintilla/include/Scintilla.h \
+- ../scintilla/include/SciLexer.h \
+- ../scintilla/include/ScintillaWidget.h lexer.h controls.h
++ syntax.h launcher.h lexer.h controls.h
+ text_editor_cbs.o: text_editor_cbs.c ../config.h anjuta.h toolbar.h \
+ text_editor.h global.h text_editor_menu.h preferences.h \
+ properties.h aneditor.h messagebox.h compiler_options.h \
+@@ -768,8 +749,7 @@
+ messages.h project_dbase.h tags_manager.h project_config.h \
+ commands.h breakpoints.h anjuta_dirs.h executer.h configurer.h \
+ utilities.h main_menubar.h controls.h text_editor_cbs.h \
+- text_editor_gui.h mainmenu_callbacks.h support.h \
+- ../scintilla/include/Scintilla.h
++ text_editor_gui.h mainmenu_callbacks.h support.h
+ text_editor_gui.o: text_editor_gui.c ../config.h anjuta.h toolbar.h \
+ text_editor.h global.h text_editor_menu.h preferences.h \
+ properties.h aneditor.h messagebox.h compiler_options.h \
+@@ -777,9 +757,7 @@
+ messages.h project_dbase.h tags_manager.h project_config.h \
+ commands.h breakpoints.h anjuta_dirs.h executer.h configurer.h \
+ utilities.h main_menubar.h text_editor_cbs.h text_editor_gui.h \
+- mainmenu_callbacks.h pixmaps.h support.h \
+- ../scintilla/include/Scintilla.h \
+- ../scintilla/include/ScintillaWidget.h
++ mainmenu_callbacks.h pixmaps.h support.h
+ text_editor_menu.o: text_editor_menu.c ../config.h support.h \
+ text_editor_menu.h anjuta.h toolbar.h text_editor.h global.h \
+ preferences.h properties.h aneditor.h messagebox.h \
diff --git a/devel/anjuta/files/patch-src-anjuta_dirs.c b/devel/anjuta/files/patch-src-anjuta_dirs.c
new file mode 100644
index 000000000000..cc20423c7594
--- /dev/null
+++ b/devel/anjuta/files/patch-src-anjuta_dirs.c
@@ -0,0 +1,17 @@
+--- src/anjuta_dirs.c.orig Sat Mar 31 18:41:13 2001
++++ src/anjuta_dirs.c Sat Mar 31 18:46:47 2001
+@@ -36,11 +36,11 @@
+ {
+ sharedir = g_dirname(PACKAGE_LOCALE_DIR);
+ ad->tmp = g_strdup(g_get_tmp_dir());
+- ad->datadir = g_strconcat(sharedir, "/anjuta", NULL);
++ ad->datadir = g_strconcat(sharedir, "/gnome/anjuta", NULL);
+ ad->data = g_strdup(ad->datadir);
+ ad->templetes = g_strdup(ad->datadir);
+- ad->pixmaps = g_strconcat(ad->datadir, "/pixmaps", NULL);
+- /* ad->help = g_strconcat(ad->datadir, "/help", NULL); */
++ ad->pixmaps = g_strconcat(sharedir, "/gnome/pixmaps", NULL);
++ /* ad->help = g_strconcat(sharedir, "/gnome/help", NULL); */
+ ad->doc = g_strconcat(sharedir, "/doc/anjuta", NULL);
+ ad->home = g_strdup(g_get_home_dir());
+ ad->settings = g_strconcat(ad->home, "/.anjuta",NULL);