aboutsummaryrefslogtreecommitdiff
path: root/devel/antlr/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-21 02:53:49 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-21 02:53:49 +0000
commite17c85302c7629da2391aa8fde405b14eb0f6003 (patch)
tree59f5e00ae540cbd71308d849e889d795a0f83283 /devel/antlr/Makefile
parent222724b1016b3c1a702d206eb36bc8d012be8be7 (diff)
downloadports-e17c85302c7629da2391aa8fde405b14eb0f6003.tar.gz
ports-e17c85302c7629da2391aa8fde405b14eb0f6003.zip
New port: devel/antlr
ANTLR, ANother Tool for Language Recognition, (formerly PCCTS) is a language tool that provides a framework for constructing recognizers, compilers, and translators from grammatical descriptions containing C++ or Java actions. PR: ports/40238 Submitted by: Geoffrey Mainland <mainland@apeiron.net>
Notes
Notes: svn path=/head/; revision=73700
Diffstat (limited to 'devel/antlr/Makefile')
-rw-r--r--devel/antlr/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/devel/antlr/Makefile b/devel/antlr/Makefile
new file mode 100644
index 000000000000..4a99559c77ff
--- /dev/null
+++ b/devel/antlr/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: antlr
+# Date created: 5 July 2002
+# Whom: Geoffrey Mainland <mainland@apeiron.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= antlr
+PORTVERSION= 2.7.1
+CATEGORIES= devel java
+MASTER_SITES= http://www.ANTLR.org/nirvana/
+DISTNAME= antlr-${PORTVERSION}
+DIST_SUBDIR= antlr
+EXTRACT_ONLY= antlr-${PORTVERSION}.tar.gz
+
+MAINTAINER= mainland@apeiron.net
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/javavm:${PORTSDIR}/java/javavmwrapper
+RUN_DEPENDS= ${LOCALBASE}/bin/javavm:${PORTSDIR}/java/javavmwrapper
+
+USE_GMAKE= yes
+
+.if defined(WITH_PARSEVIEW)
+DISTFILES+= ParseView.zip
+BUILD_DEPENDS+= ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
+
+PLIST_SUB+= PARSEVIEW=""
+.else
+PLIST_SUB+= PARSEVIEW="@comment "
+.endif
+
+ALL_TARGET= antlr
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DIST_SUBDIR}/antlr-${PORTVERSION}${EXTRACT_SUFX})
+IGNORE= You must manually fetch the source distribution (antlr-${PORTVERSION}${EXTRACT_SUFX}) from http://www.jguru.com/jguru/download/view.jsp?EID=201927 (registration required), place it in ${DISTDIR}/${DIST_SUBDIR} and then run make again
+.endif
+
+.if defined(WITH_PARSEVIEW)
+post-extract:
+ (cd ${WRKSRC} && unzip -o ${DISTDIR}/${DIST_SUBDIR}/ParseView.zip)
+.endif
+
+post-configure:
+ (cd ${WRKSRC}/lib/cpp && ./configure --prefix=${PREFIX})
+
+do-build:
+ (cd ${WRKSRC}/lib/cpp && ${GMAKE})
+
+do-install:
+ @${SED} "s|%%ANTLR_JAR_PATH%%|${PREFIX}/share/antlr|" ${FILESDIR}/antlr.sh >${WRKDIR}/antlr.sh
+ @${MKDIR} ${PREFIX}/share/antlr
+ @${INSTALL_SCRIPT} ${WRKDIR}/antlr.sh ${PREFIX}/bin/antlr
+ (cd ${WRKSRC}/lib/cpp && ${GMAKE} install)
+ (cd ${WRKSRC} && (${TAR} cf - antlr doc examples/cpp examples/java | ${TAR} xf - -C ${PREFIX}/share/antlr))
+
+.include <bsd.port.post.mk>