aboutsummaryrefslogtreecommitdiff
path: root/devel/apache-rat
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2016-08-30 19:49:27 +0000
committerCy Schubert <cy@FreeBSD.org>2016-08-30 19:49:27 +0000
commitb855a97f0c6015ddf6c5ecd932d81fcb00857d55 (patch)
treef4b5bf36230f66ba19093efad44621808d74b137 /devel/apache-rat
parent9bb24e9066a3440f9dcf624e6a4cbce29087534e (diff)
downloadports-b855a97f0c6015ddf6c5ecd932d81fcb00857d55.tar.gz
ports-b855a97f0c6015ddf6c5ecd932d81fcb00857d55.zip
Introduce the new apache-rat 0.11 port.
Apache Rat is a release audit tool, focused on licenses. Use Rat to improve accuracy and efficiency when checking releases for licenses. WWW: http://creadur.apache.org/rat/ PR: 203846 Submitted by: pfg@
Notes
Notes: svn path=/head/; revision=421130
Diffstat (limited to 'devel/apache-rat')
-rw-r--r--devel/apache-rat/Makefile45
-rw-r--r--devel/apache-rat/distinfo3
-rw-r--r--devel/apache-rat/files/apache-rat.sh.in17
-rw-r--r--devel/apache-rat/pkg-descr6
-rw-r--r--devel/apache-rat/pkg-plist2
5 files changed, 73 insertions, 0 deletions
diff --git a/devel/apache-rat/Makefile b/devel/apache-rat/Makefile
new file mode 100644
index 000000000000..fb8ed6a9fcb8
--- /dev/null
+++ b/devel/apache-rat/Makefile
@@ -0,0 +1,45 @@
+# Created by: Pedro Giffuni
+# $FreeBSD$
+
+PORTNAME= apache-rat
+PORTVERSION= 0.11
+CATEGORIES= devel java
+MASTER_SITES= APACHE/creadur/${PORTNAME}-${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
+
+MAINTAINER= pfg@FreeBSD.org
+COMMENT= Release audit tool
+
+LICENSE= APACHE20
+
+USES= tar:bzip2
+USE_JAVA= yes
+
+NO_BUILD= YES
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+
+PORTDOCS= README-ANT.txt README-CLI.txt README.txt RELEASE_NOTES.txt
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+SUB_FILES= apache-rat.sh
+
+.include <bsd.port.options.mk>
+
+do-install:
+ @${ECHO_MSG} ">> Installing JAR..."
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-${PORTVERSION}.jar \
+ ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} " [ DONE ]"
+ @${ECHO_MSG} ">> Installing script..."
+ ${INSTALL_SCRIPT} ${WRKDIR}/apache-rat.sh ${STAGEDIR}${PREFIX}/bin/apache-rat
+ @${ECHO_MSG} " [ DONE ]"
+
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${ECHO_MSG} ">> Installing documentation..."
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/apache-rat/distinfo b/devel/apache-rat/distinfo
new file mode 100644
index 000000000000..9aacb797c775
--- /dev/null
+++ b/devel/apache-rat/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1472586549
+SHA256 (apache-rat-0.11-bin.tar.bz2) = 313a021845570e67d694fec716af72e6fef0731af63a10750b642b06b40b0e98
+SIZE (apache-rat-0.11-bin.tar.bz2) = 1281784
diff --git a/devel/apache-rat/files/apache-rat.sh.in b/devel/apache-rat/files/apache-rat.sh.in
new file mode 100644
index 000000000000..3dba1a24e51b
--- /dev/null
+++ b/devel/apache-rat/files/apache-rat.sh.in
@@ -0,0 +1,17 @@
+#!/bin/sh
+#
+# FreeBSD-specific script for Apache Rat.
+#
+# $FreeBSD$
+#
+# See: http://creadur.apache.org/rat/apache-rat/
+
+JAVACMD="${JAVACMD:-"%%LOCALBASE%%/bin/java"}"
+if [ ! -x "${JAVACMD}" ]; then
+ echo "Error: ${JAVACMD} is not present on your system" >&2
+ echo " Please specify the path to an existing java executable with the" >&2
+ echo " JAVACMD environment variable when running rat." >&2
+ exit 1
+fi
+
+exec "${JAVACMD}" -jar %%JAVAJARDIR%%/apache-rat.jar "$@"
diff --git a/devel/apache-rat/pkg-descr b/devel/apache-rat/pkg-descr
new file mode 100644
index 000000000000..0d67d6a341b7
--- /dev/null
+++ b/devel/apache-rat/pkg-descr
@@ -0,0 +1,6 @@
+Apache Rat.
+
+Apache Rat is a release audit tool, focused on licenses. Use Rat to improve
+accuracy and efficiency when checking releases for licenses.
+
+WWW: http://creadur.apache.org/rat/
diff --git a/devel/apache-rat/pkg-plist b/devel/apache-rat/pkg-plist
new file mode 100644
index 000000000000..837b962d5045
--- /dev/null
+++ b/devel/apache-rat/pkg-plist
@@ -0,0 +1,2 @@
+bin/apache-rat
+%%JAVAJARDIR%%/apache-rat.jar