aboutsummaryrefslogtreecommitdiff
path: root/devel/aphpbreakdown
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-12-06 15:55:46 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-12-06 15:55:46 +0000
commit96d9f747de566cc3c89126509e30a09d646ba2aa (patch)
tree8120bc28ed7721a31a5e6fc5fecc4f25dcfeb523 /devel/aphpbreakdown
parent804041bf470b061059b20efd94b6f3a84847070f (diff)
downloadports-96d9f747de566cc3c89126509e30a09d646ba2aa.tar.gz
ports-96d9f747de566cc3c89126509e30a09d646ba2aa.zip
New port: devel/aphpbreakdown
This software analyzes all files of your project and collect all PHP classes, functions and constants found in your project. For the collection of classes, functions and constants it determined all modules of PHP needed to be installed on the webserver for your project. To display the result of the analyze you can choose different ways. One way is to display an output on your command line. But what do you do if you don't have a command line access on the server you want to test? Then you use the testfile generator of aPHPbreakdown! It generates a testfile you can upload to the webserver, or sent it to you customer to upload it, and run it very simple in the browser. WWW: http://gitlab.code-mesa.com/code-mesa/aphpbreakdown/ PR: 223867 Submitted by: Felix Flor <freebsd@felix.flornet.de>
Notes
Notes: svn path=/head/; revision=455657
Diffstat (limited to 'devel/aphpbreakdown')
-rw-r--r--devel/aphpbreakdown/Makefile30
-rw-r--r--devel/aphpbreakdown/distinfo3
-rw-r--r--devel/aphpbreakdown/pkg-descr13
3 files changed, 46 insertions, 0 deletions
diff --git a/devel/aphpbreakdown/Makefile b/devel/aphpbreakdown/Makefile
new file mode 100644
index 000000000000..e72fe30fa4a0
--- /dev/null
+++ b/devel/aphpbreakdown/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= aphpbreakdown
+DISTVERSION= 1.0.0
+CATEGORIES= devel www
+MASTER_SITES= http://phar.code-mesa.com/
+EXTRACT_SUFX= .phar
+
+MAINTAINER= freebsd@code-mesa.com
+COMMENT= Code-Analyzer for PHP for Compatibility Check-UP
+
+LICENSE= BSD2CLAUSE
+
+USES= php
+USE_PHP= tokenizer phar hash
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/aphpbreakdown
+
+# Download isn't compressed or aggregated, it's just the single file
+do-extract:
+ ${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/aphpbreakdown/distinfo b/devel/aphpbreakdown/distinfo
new file mode 100644
index 000000000000..e9a41fdc004b
--- /dev/null
+++ b/devel/aphpbreakdown/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1512382399
+SHA256 (aphpbreakdown-1.0.0.phar) = d1162cd8db67b9205e4d53181609439f30f5fd0b8b2f5070c3493878fa9c2b18
+SIZE (aphpbreakdown-1.0.0.phar) = 278480
diff --git a/devel/aphpbreakdown/pkg-descr b/devel/aphpbreakdown/pkg-descr
new file mode 100644
index 000000000000..085a301c1f8f
--- /dev/null
+++ b/devel/aphpbreakdown/pkg-descr
@@ -0,0 +1,13 @@
+This software analyzes all files of your project and collect all PHP classes,
+functions and constants found in your project. For the collection of classes,
+functions and constants it determined all modules of PHP needed to be installed
+on the webserver for your project.
+
+To display the result of the analyze you can choose different ways. One way is
+to display an output on your command line. But what do you do if you don't have
+a command line access on the server you want to test? Then you use the testfile
+generator of aPHPbreakdown! It generates a testfile you can upload to the
+webserver, or sent it to you customer to upload it, and run it very simple in
+the browser.
+
+WWW: http://gitlab.code-mesa.com/code-mesa/aphpbreakdown/