aboutsummaryrefslogtreecommitdiff
path: root/devel/api-sanity-autotest
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-03-24 01:12:11 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-03-24 01:12:11 +0000
commit0a691389de90c620852a9185c23f3d4e534716e5 (patch)
treeae91a2d0d99904e38707cdeb505c53310ab5d6b0 /devel/api-sanity-autotest
parentf71c27a39ea04faaf7441e10187ab32f763fa26a (diff)
downloadports-0a691389de90c620852a9185c23f3d4e534716e5.tar.gz
ports-0a691389de90c620852a9185c23f3d4e534716e5.zip
fix post-patch; install docs
Notes
Notes: svn path=/head/; revision=271574
Diffstat (limited to 'devel/api-sanity-autotest')
-rw-r--r--devel/api-sanity-autotest/Makefile30
1 files changed, 19 insertions, 11 deletions
diff --git a/devel/api-sanity-autotest/Makefile b/devel/api-sanity-autotest/Makefile
index 39d12b0213b6..25c8bfa2b8af 100644
--- a/devel/api-sanity-autotest/Makefile
+++ b/devel/api-sanity-autotest/Makefile
@@ -7,8 +7,10 @@
PORTNAME= api-sanity-autotest
PORTVERSION= 1.12.1
+PORTREVISION= 1
CATEGORIES= devel perl5
-MASTER_SITES= http://linuxtesting.org/downloads/
+MASTER_SITES= http://linuxtesting.org/downloads/ \
+ LOCAL/bf
MAINTAINER= bf@FreeBSD.org
COMMENT= Quickly generate sanity tests for the API of a C/C++ shared library
@@ -25,16 +27,14 @@ CPPFILT?= c++filt
READELF?= readelf
post-patch:
- ${REINPLACE_CMD} \
- -e "\%my% { \
- s%\"c++filt\"%\"${CPPFILT}\"%g; \
- s%\"readelf\"%\"${READELF}\"%g; \
- s%\"g++\"%\"${CXX}\"%g; \
- s%\"gcc\"%\"${CC}\"%g; }" \
- -e "\%search_for% { \
- s%\"g++\"%\"${CXX}\"%g; \
- s%\"gcc\"%\"${CC}\"%g; }" \
- -e "s% -shared%& -fPIC%g" \
+ @${REINPLACE_CMD} \
+ -e "\|ArCmd =|s|=.*|= \"${AR}\";|" \
+ -e "\|CPP_FILT =|s|=.*|= \"${CPPFILT}\";|" \
+ -e "\|GCC_PATH =|s|=.*|= \"${CC}\";|" \
+ -e "\|GPP_PATH =|s|=.*|= \"${CXX}\";|" \
+ -e "\|ObjdumpCmd =|s|=.*|= \"${OBJDUMP}\";|" \
+ -e "\|ReadelfCmd =|s|=.*|= \"${READELF}\";|" \
+ -e "s|-shared|& -fPIC|g" \
${WRKSRC}/${PORTNAME}.pl
do-install:
@@ -43,4 +43,12 @@ do-install:
check regression-test test: build
@(cd ${WRKSRC} && ./${PORTNAME}.pl -test )
+.ifndef(NOPORTDOCS)
+PORTDOCS= Changes.html Descriptor.html Options.html Readme.html SpecType.html
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/doc; ${INSTALL_MAN} ${PORTDOCS} ${DOCSDIR})
+
+.endif
.include <bsd.port.mk>