aboutsummaryrefslogtreecommitdiff
path: root/devel/apr1/files
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-06-10 05:53:27 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-06-10 05:53:27 +0000
commitd906134aee33d170d487f20edeeb3bf06082b260 (patch)
tree8c066dd4466af9e5a60aef7b76acadc9ebd1ef20 /devel/apr1/files
parent0fb954b294873f22bf2c28028c6af645aa435d68 (diff)
downloadports-d906134aee33d170d487f20edeeb3bf06082b260.tar.gz
ports-d906134aee33d170d487f20edeeb3bf06082b260.zip
- Respect CC/CCFLAGS [1]
- use -pthread instead of -lpthread [2] - It was only ever accidental that -ldb showed up in apu-config --libs Subversion doesn't actually even use it (apr_dbm*). APR/Util is supposed to auto load the backed db library without the app ever know which one it was. Subversion uses db _directly_. Subversion 1.6.3 should account for this. [3] - Convert to bsd.options.mk - Bump PORTREVISION PR: ports/135396 [3], ports/134453 [2], ports/132432 [1] Submitted by: dev@apr.apache.org (wrowe, bojan) [3], b.f. [2], Anonymous <swell.k@gmail.com> [1]
Notes
Notes: svn path=/head/; revision=235527
Diffstat (limited to 'devel/apr1/files')
-rw-r--r--devel/apr1/files/patch-apr-util-1.3.7__apu-config.in39
1 files changed, 39 insertions, 0 deletions
diff --git a/devel/apr1/files/patch-apr-util-1.3.7__apu-config.in b/devel/apr1/files/patch-apr-util-1.3.7__apu-config.in
new file mode 100644
index 000000000000..7e8f2fa0e122
--- /dev/null
+++ b/devel/apr1/files/patch-apr-util-1.3.7__apu-config.in
@@ -0,0 +1,39 @@
+--- ./apr-util-1.3.7/apu-config.in.orig 2008-05-23 17:27:59.000000000 -0400
++++ ./apr-util-1.3.7/apu-config.in 2009-06-10 01:03:50.971447822 -0400
+@@ -31,6 +31,7 @@
+ INCLUDES="@APRUTIL_INCLUDES@"
+ LDFLAGS="@APRUTIL_LDFLAGS@"
+ LDAP_LIBS="@LDADD_ldap@"
++DBM_LIBS="@LDADD_dbm_db@ @LDADD_dbm_gdbm@ @LDADD_dbm_ndbm@"
+
+ APRUTIL_LIBNAME="@APRUTIL_LIBNAME@"
+
+@@ -56,6 +57,8 @@
+ --libs print library information
+ --avoid-ldap do not include ldap library information with --libs
+ --ldap-libs print additional library information to link with ldap
++ --avoid-dbm do not include DBM library information with --libs
++ --dbm-libs print additional library information to link with DBM
+ --srcdir print APR-util source directory
+ --link-ld print link switch(es) for linking to APR-util
+ --link-libtool print the libtool inputs for linking to APR-util
+@@ -115,12 +118,18 @@
+ --avoid-ldap)
+ LDAP_LIBS=""
+ ;;
++ --avoid-dbm)
++ DBM_LIBS=""
++ ;;
+ --libs)
+- flags="$flags $LDAP_LIBS $LIBS"
++ flags="$flags $LDAP_LIBS $DBM_LIBS $LIBS"
+ ;;
+ --ldap-libs)
+ flags="$flags $LDAP_LIBS"
+ ;;
++ --dbm-libs)
++ flags="$flags $DBM_LIBS"
++ ;;
+ --includedir)
+ if test "$location" = "installed"; then
+ flags="$includedir"