aboutsummaryrefslogtreecommitdiff
path: root/devel/arduino
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-04-17 18:32:12 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-04-17 18:32:12 +0000
commit03d1bf2fada82fa44c76609a32192a5fd539bcbe (patch)
tree3b2c62cb0a660600089801119a5e8577e0188d71 /devel/arduino
parent67009b92b17c72e5e0a5b974b7e19f75c6ddf10f (diff)
downloadports-03d1bf2fada82fa44c76609a32192a5fd539bcbe.tar.gz
ports-03d1bf2fada82fa44c76609a32192a5fd539bcbe.zip
- Fix Print.cpp, broken since avr-libc 1.8.0 [1]
- Pet portlint (add USE_LDCONFIG on shared lib) [2] - Bump PORTREVISION PR: ports/166183 [1] Reviewed by: scheidell (me) [2] Approved by: wblock@ (maintainer)
Notes
Notes: svn path=/head/; revision=294966
Diffstat (limited to 'devel/arduino')
-rw-r--r--devel/arduino/Makefile5
-rw-r--r--devel/arduino/files/patch-hardware-arduino-cores-arduino-Print.cpp12
2 files changed, 15 insertions, 2 deletions
diff --git a/devel/arduino/Makefile b/devel/arduino/Makefile
index 1899a1dcf017..3afe5b446034 100644
--- a/devel/arduino/Makefile
+++ b/devel/arduino/Makefile
@@ -5,7 +5,7 @@
PORTNAME= arduino
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= devel java lang
MASTER_SITES= GOOGLE_CODE
@@ -23,6 +23,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_JAVA= 1.6+
NO_BUILD= yes
+USE_LDCONFIG= ${PREFIX}/arduino/lib
SUB_FILES= arduino pkg-message
SUB_LIST= PORTNAME=${PORTNAME}
@@ -76,7 +77,7 @@ post-extract:
@${REINPLACE_CMD} -e 's|readlink -f|realpath|g' ${WRKSRC}/arduino
post-patch:
- @${RM} ${WRKSRC}/hardware/arduino/bootloaders/atmega8/*.orig
+ @${RM} -f ${WRKSRC}/hardware/arduino/bootloaders/atmega8/*.orig ${WRKSRC}/hardware/arduino/cores/arduino/Print.cpp.orig
.if defined(WITHOUT_REFDOCS)
@${RM} -rf ${WRKSRC}/reference
diff --git a/devel/arduino/files/patch-hardware-arduino-cores-arduino-Print.cpp b/devel/arduino/files/patch-hardware-arduino-cores-arduino-Print.cpp
new file mode 100644
index 000000000000..ff78f74e32c3
--- /dev/null
+++ b/devel/arduino/files/patch-hardware-arduino-cores-arduino-Print.cpp
@@ -0,0 +1,12 @@
+--- hardware/arduino/cores/arduino/Print.cpp.orig 2012-03-16 11:16:23.000000000 -0700
++++ hardware/arduino/cores/arduino/Print.cpp 2012-03-16 11:17:17.000000000 -0700
+@@ -41,7 +41,7 @@
+
+ size_t Print::print(const __FlashStringHelper *ifsh)
+ {
+- const prog_char *p = (const prog_char *)ifsh;
++ const char PROGMEM *p = (const char PROGMEM *)ifsh;
+ size_t n = 0;
+ while (1) {
+ unsigned char c = pgm_read_byte(p++);
+--- patch-hardware-arduino-cores-arduino-Print.cpp ends here --- \ No newline at end of file