aboutsummaryrefslogtreecommitdiff
path: root/devel/arduinoOTA
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2017-03-19 22:07:49 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2017-03-19 22:07:49 +0000
commit3343e9e6076f52ec13d2f67beca1cfe8df31f5c3 (patch)
tree6f74d6f6755324841156fef85ef05e004322c718 /devel/arduinoOTA
parent29f7a6a4fb0ec7a4c73a41315bf7fdb97b5b64a1 (diff)
downloadports-3343e9e6076f52ec13d2f67beca1cfe8df31f5c3.tar.gz
ports-3343e9e6076f52ec13d2f67beca1cfe8df31f5c3.zip
Tool for performing OTA updates on Arduino boards and the ESP8266.
WWW: https://www.arduino.cc PR: 217842 Submitted by: bsdports@kyle-evans.net
Notes
Notes: svn path=/head/; revision=436513
Diffstat (limited to 'devel/arduinoOTA')
-rw-r--r--devel/arduinoOTA/Makefile29
-rw-r--r--devel/arduinoOTA/distinfo3
-rw-r--r--devel/arduinoOTA/pkg-descr3
3 files changed, 35 insertions, 0 deletions
diff --git a/devel/arduinoOTA/Makefile b/devel/arduinoOTA/Makefile
new file mode 100644
index 000000000000..39c7dfc8e7aa
--- /dev/null
+++ b/devel/arduinoOTA/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= arduinoOTA
+PORTVERSION= 1.2.0
+CATEGORIES= devel
+
+MAINTAINER= bsdports@kyle-evans.net
+COMMENT= OTA upload tool for Arduino/ESP8266
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= go:lang/go
+
+USE_GITHUB= yes
+GH_ACCOUNT= arduino
+GH_TAGNAME= c2b8306
+
+PLIST_FILES= bin/${PORTNAME}
+COMPILEINFO= ${OPSYS}${OSREL}-${ARCH}-${GH_TAGNAME}
+
+STRIP= # stripping can break go binaries
+
+do-build:
+ (cd ${WRKSRC} && ${SETENV} ${GO_ENV} go build -o ${PORTNAME} -ldflags "-X main.compileInfo=${COMPILEINFO}" main.go)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/arduinoOTA/distinfo b/devel/arduinoOTA/distinfo
new file mode 100644
index 000000000000..66838beb6131
--- /dev/null
+++ b/devel/arduinoOTA/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1489629303
+SHA256 (arduino-arduinoOTA-1.2.0-c2b8306_GH0.tar.gz) = aa4ab21ce1d906793a4b9e1286fd4d38b2d255aa4a42111460c96bbe6d79b3b7
+SIZE (arduino-arduinoOTA-1.2.0-c2b8306_GH0.tar.gz) = 2549
diff --git a/devel/arduinoOTA/pkg-descr b/devel/arduinoOTA/pkg-descr
new file mode 100644
index 000000000000..d1fb3e80839f
--- /dev/null
+++ b/devel/arduinoOTA/pkg-descr
@@ -0,0 +1,3 @@
+Tool for performing OTA updates on Arduino boards and the ESP8266.
+
+WWW: https://www.arduino.cc