aboutsummaryrefslogtreecommitdiff
path: root/devel/asmutils
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-11-11 17:33:09 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-11-11 17:33:09 +0000
commit2aa4b42436b1e0c69f0a51cc96b754ba3fb76a65 (patch)
treebbd32e48ff5a5cccaf5f00ee0bedf66855e09f4d /devel/asmutils
parent1a9b3315837cf55bcd453daf63876a51850b99b9 (diff)
downloadports-2aa4b42436b1e0c69f0a51cc96b754ba3fb76a65.tar.gz
ports-2aa4b42436b1e0c69f0a51cc96b754ba3fb76a65.zip
Get rid of the trivial patch and dependent REINPLACE_CMD call when MAKE_ARGS
can do this job better and yet be more readable and straightforward. Verified by: comparing build logs Feature safe: yes
Notes
Notes: svn path=/head/; revision=285585
Diffstat (limited to 'devel/asmutils')
-rw-r--r--devel/asmutils/Makefile2
-rw-r--r--devel/asmutils/files/patch-MCONFIG20
2 files changed, 1 insertions, 21 deletions
diff --git a/devel/asmutils/Makefile b/devel/asmutils/Makefile
index f84a263fb921..e8a974e8cec2 100644
--- a/devel/asmutils/Makefile
+++ b/devel/asmutils/Makefile
@@ -21,6 +21,7 @@ ONLY_FOR_ARCHS= i386
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
USE_GMAKE= yes
+MAKE_ARGS= OS=${OPSYS:U} KERNEL=${OSREL:S/.//g}
# This will play merry hell with portlint(1)
BINS= bonus/asmutils basename cal cat chmod chown chroot cmp cp \
@@ -45,7 +46,6 @@ PLIST_DIRS= bin/asmutils lib/asmutils
PORTDOCS= *
post-patch:
- @${REINPLACE_CMD} -e 's,%%KERNEL%%,${OSREL:S/.//g},g' ${WRKSRC}/MCONFIG
@${REINPLACE_CMD} -e 's,^static ,,' ${WRKSRC}/lib/libm.c
# Stripping binaries will break installation
diff --git a/devel/asmutils/files/patch-MCONFIG b/devel/asmutils/files/patch-MCONFIG
deleted file mode 100644
index 4dbe0c311963..000000000000
--- a/devel/asmutils/files/patch-MCONFIG
+++ /dev/null
@@ -1,20 +0,0 @@
---- MCONFIG.orig Fri Mar 15 01:42:46 2002
-+++ MCONFIG Sun Feb 8 01:06:18 2004
-@@ -13,7 +13,7 @@
- # Target operating system. Valid values are:
- # LINUX FREEBSD OPENBSD NETBSD SOLARIS UNIXWARE BEOS ATHEOS
-
--OS = LINUX
-+OS = FREEBSD
-
- # Kernel version of target OS (1.2 = 12, 2.4 = 24, 3.6 = 36, etc)
-
-@@ -25,7 +25,7 @@
- # in executable even if it is not present in object file.
- # So, if your ld always adds .bss - you can just forget about it.
-
--KERNEL = 24
-+KERNEL = %%KERNEL%%
-
- # Optimization method (SIZE/SPEED)
-