aboutsummaryrefslogtreecommitdiff
path: root/devel/asmutils
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-11-30 13:49:40 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-11-30 13:49:40 +0000
commita73e223baeb17a60b94d4bfe67d7bbce9f202ea8 (patch)
tree67c7d5b4f4ed555be8b6fd1ef6c47975757a507a /devel/asmutils
parent8d8572161cb13a66b8c5383ffa908498a4faa55f (diff)
downloadports-a73e223baeb17a60b94d4bfe67d7bbce9f202ea8.tar.gz
ports-a73e223baeb17a60b94d4bfe67d7bbce9f202ea8.zip
- Mute ${MKDIR}'s
- $FOO -> ${FOO} - Reformat description so it looks nicer - Kill attribution (submitter's name mentioned in Makefile header) - Add SHA256 checksum per new world order
Notes
Notes: svn path=/head/; revision=150045
Diffstat (limited to 'devel/asmutils')
-rw-r--r--devel/asmutils/Makefile12
-rw-r--r--devel/asmutils/distinfo1
-rw-r--r--devel/asmutils/pkg-descr9
3 files changed, 10 insertions, 12 deletions
diff --git a/devel/asmutils/Makefile b/devel/asmutils/Makefile
index d780e3b9d561..242778b336a0 100644
--- a/devel/asmutils/Makefile
+++ b/devel/asmutils/Makefile
@@ -44,10 +44,10 @@ post-patch:
STRIP= #
do-install:
- ${MKDIR} ${PREFIX}/bin/asmutils
- ${MKDIR} ${PREFIX}/lib/asmutils
+ @${MKDIR} ${PREFIX}/bin/asmutils
+ @${MKDIR} ${PREFIX}/lib/asmutils
.for B in ${BINARIES}
- ${INSTALL_PROGRAM} ${WRKSRC}/src/$B ${PREFIX}/bin/asmutils
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${B} ${PREFIX}/bin/asmutils
.endfor
(cd ${PREFIX}/bin/asmutils && \
${LN} -sf uname arch && \
@@ -58,12 +58,12 @@ do-install:
${LN} -sf mkdir rmdir && \
${LN} -sf ln sln)
.for L in c crypto m
- ${INSTALL_PROGRAM} ${WRKSRC}/lib/lib$L.so.0 ${PREFIX}/lib/asmutils
+ ${INSTALL_PROGRAM} ${WRKSRC}/lib/lib${L}.so.0 ${PREFIX}/lib/asmutils
.endfor
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
.for D in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/$D ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${D} ${DOCSDIR}
.endfor
.endif
diff --git a/devel/asmutils/distinfo b/devel/asmutils/distinfo
index e32204e48c9e..82377ed165c5 100644
--- a/devel/asmutils/distinfo
+++ b/devel/asmutils/distinfo
@@ -1,2 +1,3 @@
MD5 (asmutils-0.17.tar.gz) = 9027cff8f8f50cf4fa9b0e62fc4a8854
+SHA256 (asmutils-0.17.tar.gz) = 6e51ee22a800244cac3d62ce0bab2de9c90b88648f87add6e6f5597ee746615a
SIZE (asmutils-0.17.tar.gz) = 332675
diff --git a/devel/asmutils/pkg-descr b/devel/asmutils/pkg-descr
index d33245bef23f..f2ba546a669f 100644
--- a/devel/asmutils/pkg-descr
+++ b/devel/asmutils/pkg-descr
@@ -1,10 +1,7 @@
asmutils is a set of miscellaneous utilities written in assembly language,
targeted on embedded systems and small distributions (like rescue or
-installation disks); also it contains small libc and crypto library.
-It features the smallest possible size and memory requirements,
-the fastest speed and good functionality.
-
-- George Reid
-greid@ukug.uk.freebsd.org
+installation disks); also it contains small libc and crypto library. It
+features the smallest possible size and memory requirements, the fastest
+speed and good functionality.
WWW: http://asm.sourceforge.net/