aboutsummaryrefslogtreecommitdiff
path: root/devel/astah-community/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2013-03-16 02:54:51 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2013-03-16 02:54:51 +0000
commit4820fa4509fa68704bce01f9c75fd9e1db08d655 (patch)
tree5cbbfc0c55fa91bd5169e216e158df83535e64a3 /devel/astah-community/Makefile
parent04927443ba49a5b93e8dc1f475676265ca2b6357 (diff)
downloadports-4820fa4509fa68704bce01f9c75fd9e1db08d655.tar.gz
ports-4820fa4509fa68704bce01f9c75fd9e1db08d655.zip
- Update to 6.7.0
- Remove indefinite article from COMMENT - Adapt to the new OPTIONS framework Release Notes: http://astah.net/release-notes/community/com-6.7.0
Notes
Notes: svn path=/head/; revision=314332
Diffstat (limited to 'devel/astah-community/Makefile')
-rw-r--r--devel/astah-community/Makefile65
1 files changed, 31 insertions, 34 deletions
diff --git a/devel/astah-community/Makefile b/devel/astah-community/Makefile
index 20edcc48c516..fa8296b53b95 100644
--- a/devel/astah-community/Makefile
+++ b/devel/astah-community/Makefile
@@ -2,56 +2,53 @@
# $FreeBSD$
PORTNAME= astah
-PORTVERSION= 6.6.4
+PORTVERSION= 6.7.0
CATEGORIES= devel java
MASTER_SITES= #
PKGNAMESUFFIX= -community
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION:S!.!_!g}-${REVISION}
MAINTAINER= tota@FreeBSD.org
-COMMENT= A Java/UML Object-Oriented Design Tool
+COMMENT= Java/UML Object-Oriented Design Tool
+
+RESTRICTED= See http://astah.net/faq/community/enduser-license-agreement
USE_ZIP= yes
-REVISION= 41775
+USE_JAVA= yes
+JAVA_VERSION= 1.7+
+REVISION= 43495
-.include <bsd.port.pre.mk>
+WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX:S!-!_!}
-JAVA_VERSION= 1.6+
+PORTDOCS= API_sample_program_license_agreement.txt \
+ API_sample_program_license_agreement_ja.txt \
+ CommandRunner.html CommandRunner_ja.html \
+ ProductInformation.txt \
+ api
+PORTEXAMPLES= astah-key.properties_org Sample.asta
+PORTDATA= astah-community.jar astah-api.jar astah-gui_en.properties_org \
+ astah.ico astah-doc.ico Welcome.asta Welcome_ja.asta \
+ lib template
-USE_JAVA= yes
-JAVA_OS= native
NO_BUILD= yes
-RESTRICTED= See http://astah.net/faq/community/enduser-license-agreement
-WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX:S!-!_!}
-REINPLACE_ARGS= -i ""
-
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
-DOWNLOAD_URL= http://members.change-vision.com/files/${PORTNAME}${PKGNAMESUFFIX:S!-!_!}/${PORTVERSION:S!.!_!}/${DISTFILES}
-IGNORE= needs you to fetch manually the distribution file\
- from ${DOWNLOAD_URL}, \
- then place it in ${DISTDIR} and run make again
-.endif
+PLIST_FILES= bin/astah bin/astah-command.sh
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}${PKGNAMESUFFIX}
DATADIR= ${JAVASHAREDIR}/${PORTNAME}${PKGNAMESUFFIX}
-PLIST_FILES= bin/astah bin/astah-command.sh
-PORTDATA= astah-community.jar astah-api.jar astah-gui_en.properties_org \
- astah.ico astah-doc.ico Welcome.asta Welcome_ja.asta \
- lib template
+REINPLACE_ARGS= -i ""
-.if !defined(NOPORTDOCS)
-PORTDOCS= API_sample_program_license_agreement.txt \
- API_sample_program_license_agreement_ja.txt \
- CommandRunner.html CommandRunner_ja.html \
- ProductInformation.txt \
- api
-.endif
+OPTIONS_DEFINE= DOCS EXAMPLES
-.if !defined(NOPORTEXAMPLES)
-PORTEXAMPLES= astah-key.properties_org Sample.asta
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+DOWNLOAD_URL= http://members.change-vision.com/files/${PORTNAME}${PKGNAMESUFFIX:S!-!_!}/${PORTVERSION:S!.!_!g}/${DISTFILES}
+IGNORE= needs you to fetch manually the distribution file\
+ from ${DOWNLOAD_URL}, \
+ then place it in ${DISTDIR} and run make again
.endif
post-patch:
@@ -60,8 +57,8 @@ post-patch:
s!%%DATADIR%%!${DATADIR}!" \
${WRKSRC}/${script}
.endfor
-.if !defined(NOPORTDOCS)
- ${REINPLACE_CMD} 's/png\\/png\//' ${WRKSRC}/api/*/doc/astahAPI_reference.html
+.if ${PORT_OPTIONS:MDOCS}
+ ${REINPLACE_CMD} 's/png\\/png\//' ${WRKSRC}/api/en/doc/astahAPI_reference.html
.endif
do-install:
@@ -70,7 +67,7 @@ do-install:
.endfor
${MKDIR} ${DATADIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" ${DATADIR})
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for docfile in ${PORTDOCS:Napi}
${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
@@ -78,7 +75,7 @@ do-install:
${MKDIR} ${DOCSDIR}/api
(cd ${WRKSRC}/api && ${COPYTREE_SHARE} \* ${DOCSDIR}/api)
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
.for examplefile in ${PORTEXAMPLES}
${INSTALL_DATA} ${WRKSRC}/${examplefile} ${EXAMPLESDIR}