aboutsummaryrefslogtreecommitdiff
path: root/devel/autoconf213
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2003-06-29 01:45:09 +0000
committerAde Lovett <ade@FreeBSD.org>2003-06-29 01:45:09 +0000
commit85e8ed21ea7377174b1d691dff4eeee35ce53dd8 (patch)
treee9f8ae4728153410277c9669c8b7e415090712f8 /devel/autoconf213
parent0e17c510f205b8416af0ac0103fb81c67629a5c8 (diff)
downloadports-85e8ed21ea7377174b1d691dff4eeee35ce53dd8.tar.gz
ports-85e8ed21ea7377174b1d691dff4eeee35ce53dd8.zip
Use the cosmetic BUILD_VERSION variable (a la libtool), switch portnames
away from using the version number twice. Unbreak autoconf257, based on work from Rui Lopes <rui@ruilopes.com>
Notes
Notes: svn path=/head/; revision=83799
Diffstat (limited to 'devel/autoconf213')
-rw-r--r--devel/autoconf213/Makefile29
-rw-r--r--devel/autoconf213/pkg-plist66
2 files changed, 47 insertions, 48 deletions
diff --git a/devel/autoconf213/Makefile b/devel/autoconf213/Makefile
index a17bf74d160a..e535c649df09 100644
--- a/devel/autoconf213/Makefile
+++ b/devel/autoconf213/Makefile
@@ -5,11 +5,7 @@
# $FreeBSD$
#
-# Upgrading this port is not possible at this time because it has
-# extensive implications for the entire ports system. It will be
-# upgraded as soon as possible. Thanks.
-
-PORTNAME= autoconf213
+PORTNAME= autoconf
PORTVERSION= 2.13.000227
PORTREVISION= 5
CATEGORIES= devel
@@ -23,12 +19,15 @@ COMMENT= Automatically configure source code on many Un*x platforms (legacy 2.13
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
+BUILD_VERSION= 213
+PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
+LATEST_LINK= autoconf${BUILD_VERSION}
USE_BZIP2= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CONFIG_SHELL=${SH}
-CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
-CONFIGURE_ARGS= --program-suffix=213
+CONFIGURE_ENV= CONFIG_SHELL=${SH} M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ARGS= --program-suffix=${BUILD_VERSION}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/autoconf
.if defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
@@ -45,16 +44,16 @@ post-patch:
@${RM} ${WRKSRC}/*.info* >/dev/null 2>&1 || true
post-install:
- @${CHMOD} +x ${PREFIX}/share/autoconf213/config.*
+ @${CHMOD} +x ${PREFIX}/share/autoconf${BUILD_VERSION}/config.*
@${INSTALL_SCRIPT} ${WRKSRC}/install-sh \
- ${PREFIX}/share/autoconf213
- @-${RM} -fr ${PREFIX}/libexec/autoconf213
- ${MKDIR} ${PREFIX}/libexec/autoconf213
+ ${PREFIX}/share/autoconf${BUILD_VERSION}
+ @-${RM} -fr ${PREFIX}/libexec/autoconf${BUILD_VERSION}
+ ${MKDIR} ${PREFIX}/libexec/autoconf${BUILD_VERSION}
.for i in autoconf autoheader autoreconf autoscan autoupdate ifnames
- ${LN} -sf ${PREFIX}/bin/${i}213 \
- ${PREFIX}/libexec/autoconf213/${i}
+ ${LN} -sf ${PREFIX}/bin/${i}${BUILD_VERSION} \
+ ${PREFIX}/libexec/autoconf${BUILD_VERSION}/${i}
.endfor
- install-info ${PREFIX}/info/autoconf213.info \
+ install-info ${PREFIX}/info/autoconf${BUILD_VERSION}.info \
${PREFIX}/info/dir
.include <bsd.port.mk>
diff --git a/devel/autoconf213/pkg-plist b/devel/autoconf213/pkg-plist
index fa84b581ed6a..f16aaab9fd77 100644
--- a/devel/autoconf213/pkg-plist
+++ b/devel/autoconf213/pkg-plist
@@ -1,33 +1,33 @@
-bin/autoconf213
-bin/autoheader213
-bin/autoreconf213
-bin/autoscan213
-bin/autoupdate213
-bin/ifnames213
-@unexec install-info --delete %D/info/autoconf213.info %D/info/dir
-info/autoconf213.info
-@exec install-info %D/info/autoconf213.info %D/info/dir
-libexec/autoconf213/autoconf
-libexec/autoconf213/autoheader
-libexec/autoconf213/autoreconf
-libexec/autoconf213/autoscan
-libexec/autoconf213/autoupdate
-libexec/autoconf213/ifnames
-share/autoconf213/acconfig.h
-share/autoconf213/acfunctions
-share/autoconf213/acgeneral.m4
-share/autoconf213/acheaders
-share/autoconf213/acidentifiers
-share/autoconf213/acmakevars
-share/autoconf213/acoldnames.m4
-share/autoconf213/acprograms
-share/autoconf213/acspecific.m4
-share/autoconf213/autoconf.m4
-share/autoconf213/autoconf.m4f
-share/autoconf213/autoheader.m4
-share/autoconf213/autoheader.m4f
-share/autoconf213/config.guess
-share/autoconf213/config.sub
-share/autoconf213/install-sh
-@dirrm libexec/autoconf213
-@dirrm share/autoconf213
+bin/autoconf%%BUILD_VERSION%%
+bin/autoheader%%BUILD_VERSION%%
+bin/autoreconf%%BUILD_VERSION%%
+bin/autoscan%%BUILD_VERSION%%
+bin/autoupdate%%BUILD_VERSION%%
+bin/ifnames%%BUILD_VERSION%%
+@unexec install-info --delete %D/info/autoconf%%BUILD_VERSION%%.info %D/info/dir
+info/autoconf%%BUILD_VERSION%%.info
+@exec install-info %D/info/autoconf%%BUILD_VERSION%%.info %D/info/dir
+libexec/autoconf%%BUILD_VERSION%%/autoconf
+libexec/autoconf%%BUILD_VERSION%%/autoheader
+libexec/autoconf%%BUILD_VERSION%%/autoreconf
+libexec/autoconf%%BUILD_VERSION%%/autoscan
+libexec/autoconf%%BUILD_VERSION%%/autoupdate
+libexec/autoconf%%BUILD_VERSION%%/ifnames
+share/autoconf%%BUILD_VERSION%%/acconfig.h
+share/autoconf%%BUILD_VERSION%%/acfunctions
+share/autoconf%%BUILD_VERSION%%/acgeneral.m4
+share/autoconf%%BUILD_VERSION%%/acheaders
+share/autoconf%%BUILD_VERSION%%/acidentifiers
+share/autoconf%%BUILD_VERSION%%/acmakevars
+share/autoconf%%BUILD_VERSION%%/acoldnames.m4
+share/autoconf%%BUILD_VERSION%%/acprograms
+share/autoconf%%BUILD_VERSION%%/acspecific.m4
+share/autoconf%%BUILD_VERSION%%/autoconf.m4
+share/autoconf%%BUILD_VERSION%%/autoconf.m4f
+share/autoconf%%BUILD_VERSION%%/autoheader.m4
+share/autoconf%%BUILD_VERSION%%/autoheader.m4f
+share/autoconf%%BUILD_VERSION%%/config.guess
+share/autoconf%%BUILD_VERSION%%/config.sub
+share/autoconf%%BUILD_VERSION%%/install-sh
+@dirrm libexec/autoconf%%BUILD_VERSION%%
+@dirrm share/autoconf%%BUILD_VERSION%%