aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-gcc-3/Makefile
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2004-04-28 20:53:33 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2004-04-28 20:53:33 +0000
commita147ec1d2023cc78189d21c7212ec2cafa8abb73 (patch)
treed27d23347e0ecf354ad56f0da2e8be52833b4943 /devel/avr-gcc-3/Makefile
parent22f357703b66bc4d3a290ce29e67ffbeb593c71d (diff)
downloadports-a147ec1d2023cc78189d21c7212ec2cafa8abb73.tar.gz
ports-a147ec1d2023cc78189d21c7212ec2cafa8abb73.zip
Upgrade to GCC 3.4.0.
This also makes the port compile (again) under all 64-bit archs. For amd64, patch-ad modifies config.guess to match GCC's expectation of x86_64.
Notes
Notes: svn path=/head/; revision=107878
Diffstat (limited to 'devel/avr-gcc-3/Makefile')
-rw-r--r--devel/avr-gcc-3/Makefile17
1 files changed, 6 insertions, 11 deletions
diff --git a/devel/avr-gcc-3/Makefile b/devel/avr-gcc-3/Makefile
index 122778bce0cf..93a410f28d9c 100644
--- a/devel/avr-gcc-3/Makefile
+++ b/devel/avr-gcc-3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gcc
-PORTVERSION= 3.3.2
+PORTVERSION= 3.4.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITES+= http://people.freebsd.org/~joerg/:local
@@ -22,8 +22,7 @@ MAINTAINER= joerg@freebsd.org
COMMENT= FSF GCC 3.x for Atmel AVR 8-bit RISC cross-development
BUILD_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
- avr-ld:${PORTSDIR}/devel/avr-binutils \
- autoheader:${PORTSDIR}/devel/autoconf
+ avr-ld:${PORTSDIR}/devel/avr-binutils
RUN_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-ld:${PORTSDIR}/devel/avr-binutils
@@ -33,10 +32,10 @@ USE_PERL5_BUILD= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= yes
-USE_GETTEXT= yes
+USE_AUTOHEADER= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --target=avr
+CONFIGURE_ARGS= --target=avr --disable-nls
MAN_AUX= gcc-man.${PORTVERSION}.tar.gz
@@ -44,16 +43,12 @@ MAKE_FLAGS= LANGUAGES="c c++"
# get rid of that silly -mcpu=pentiumpro FreeBSD 5+ is so fond of. :-(
MAKE_ENV= MACHINE_ARCH=avr
-MAN1= cpp.1 avr-gcc.1 avr-g++.1 gcov.1
+MAN1= avr-cpp.1 avr-gcc.1 avr-g++.1 avr-gcov.1
MAN7= fsf-funding.7 gfdl.7 gpl.7
-INFO= cpp gcc gccint cppinternals
+INFO= cpp gcc gccint cppinternals gccinstall
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386" && ${ARCH} != "alpha"
-BROKEN= "Does not build on !i386 and !alpha"
-.endif
-
# Since the pod2man in FreeBSD 4-stable's /usr/bin cannot be used, we
# help out by extracting precompiled manpages there.
pre-build: