aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-gcc-3
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2005-08-17 14:41:01 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2005-08-17 14:41:01 +0000
commitd57a2a1f0b766159ab41f9b420bda1d3bce31714 (patch)
treebcc9158ae24dec47590788d686404e8fd9342bf6 /devel/avr-gcc-3
parentb8ad016acfaba7aae35ace461af18267dc257b87 (diff)
downloadports-d57a2a1f0b766159ab41f9b420bda1d3bce31714.tar.gz
ports-d57a2a1f0b766159ab41f9b420bda1d3bce31714.zip
Fix the linker command (in GCC's specs file) for the AT90PWM2/3
controllers. Approved by: portmgr (linimon)
Notes
Notes: svn path=/head/; revision=140906
Diffstat (limited to 'devel/avr-gcc-3')
-rw-r--r--devel/avr-gcc-3/Makefile1
-rw-r--r--devel/avr-gcc-3/files/patch-newdevices20
2 files changed, 11 insertions, 10 deletions
diff --git a/devel/avr-gcc-3/Makefile b/devel/avr-gcc-3/Makefile
index 0b5a174d7d50..02a43e25bce2 100644
--- a/devel/avr-gcc-3/Makefile
+++ b/devel/avr-gcc-3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gcc
PORTVERSION= 3.4.4
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITES+= http://people.freebsd.org/~joerg/:local
diff --git a/devel/avr-gcc-3/files/patch-newdevices b/devel/avr-gcc-3/files/patch-newdevices
index e68ec92fbb5e..34232e1472d4 100644
--- a/devel/avr-gcc-3/files/patch-newdevices
+++ b/devel/avr-gcc-3/files/patch-newdevices
@@ -1,6 +1,6 @@
-diff -ur /tmp/gcc-orig/gcc/config/avr/avr.c ./gcc/config/avr/avr.c
---- /tmp/gcc-orig/gcc/config/avr/avr.c Sun Mar 20 22:14:28 2005
-+++ ./gcc/config/avr/avr.c Sat Jul 30 23:01:43 2005
+diff -ur ../gcc-3.4.4-orig/gcc/config/avr/avr.c ./gcc/config/avr/avr.c
+--- ../gcc-3.4.4-orig/gcc/config/avr/avr.c 2005-03-20 22:14:28.000000000 +0100
++++ ./gcc/config/avr/avr.c 2005-08-16 11:57:05.000000000 +0200
@@ -175,6 +175,12 @@
{ "at90c8534", 2, "__AVR_AT90C8534__" },
{ "at90s8535", 2, "__AVR_AT90S8535__" },
@@ -51,9 +51,9 @@ diff -ur /tmp/gcc-orig/gcc/config/avr/avr.c ./gcc/config/avr/avr.c
{ "at94k", 5, "__AVR_AT94K__" },
/* Assembler only. */
{ "avr1", 1, NULL },
-diff -ur /tmp/gcc-orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
---- /tmp/gcc-orig/gcc/config/avr/avr.h Sat Jul 30 15:01:51 2005
-+++ ./gcc/config/avr/avr.h Sat Jul 30 23:03:48 2005
+diff -ur ../gcc-3.4.4-orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
+--- ../gcc-3.4.4-orig/gcc/config/avr/avr.h 2004-03-09 03:59:55.000000000 +0100
++++ ./gcc/config/avr/avr.h 2005-08-16 11:58:10.000000000 +0200
@@ -2351,12 +2351,12 @@
Do not define this macro if it does not need to do anything. */
@@ -68,7 +68,7 @@ diff -ur /tmp/gcc-orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
-%{mmcu=atmega64|mmcu=atmega128|mmcu=atmega162|mmcu=atmega169: -Tdata 0x800100} "
+%{mmcu=atmega8*|mmcu=atmega48|mmcu=at90pwm*:-m avr4}\
+%{mmcu=atmega16*|mmcu=atmega32*|mmcu=atmega64*|mmcu=atmega128|mmcu=at90can128|mmcu=at94k:-m avr5}\
-+%{mmcu=atmega324|mmcu=atmega325|mmcu=atmega3250|mmcu=atmega329|mmcu=atmega3290|mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega644|mmcu=atmega645|mmcu=atmega6450|mmcu=atmega649|mmcu=atmega6490|mmcu=atmega128|mmcu=at90can128|mmcu=atmega162|mmcu=atmega164|mmcu=atmega168|mmcu=atmega169: -Tdata 0x800100} "
++%{mmcu=atmega324|mmcu=atmega325|mmcu=atmega3250|mmcu=atmega329|mmcu=atmega3290|mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega644|mmcu=atmega645|mmcu=atmega6450|mmcu=atmega649|mmcu=atmega6490|mmcu=atmega128|mmcu=at90can128|mmcu=atmega162|mmcu=atmega164|mmcu=atmega168|mmcu=atmega169|mmcu=at90pwm*: -Tdata 0x800100} "
/* A C string constant that tells the GCC driver program options to
pass to the linker. It can also specify how to translate options
@@ -136,9 +136,9 @@ diff -ur /tmp/gcc-orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
%{mmcu=at94k:crtat94k.o%s}"
#define EXTRA_SPECS {"crt_binutils", CRT_BINUTILS_SPECS},
-diff -ur /tmp/gcc-orig/gcc/config/avr/t-avr ./gcc/config/avr/t-avr
---- /tmp/gcc-orig/gcc/config/avr/t-avr Mon Apr 25 06:17:34 2005
-+++ ./gcc/config/avr/t-avr Sat Jul 30 23:06:40 2005
+diff -ur ../gcc-3.4.4-orig/gcc/config/avr/t-avr ./gcc/config/avr/t-avr
+--- ../gcc-3.4.4-orig/gcc/config/avr/t-avr 2005-04-25 06:17:34.000000000 +0200
++++ ./gcc/config/avr/t-avr 2005-08-16 11:57:05.000000000 +0200
@@ -46,13 +46,22 @@
mmcu?avr3=mmcu?at43usb320 mmcu?avr3=mmcu?at43usb355 \
mmcu?avr3=mmcu?at76c711 \