aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-libc/Makefile
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2004-12-21 14:39:39 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2004-12-21 14:39:39 +0000
commitfb632d156e0cd5ad930f42d1d7188c4015d4abc1 (patch)
treee7d8f4e4dcf46e1db9b8d4a9ed7f7911c85ff254 /devel/avr-libc/Makefile
parent205492ef75e7a6f5a120066f03c564f6d6308849 (diff)
downloadports-fb632d156e0cd5ad930f42d1d7188c4015d4abc1.tar.gz
ports-fb632d156e0cd5ad930f42d1d7188c4015d4abc1.zip
Handle PLIST generation correctly for the -DNOPORTDOCS case.
Notes
Notes: svn path=/head/; revision=124704
Diffstat (limited to 'devel/avr-libc/Makefile')
-rw-r--r--devel/avr-libc/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/devel/avr-libc/Makefile b/devel/avr-libc/Makefile
index d14254c71c43..6ad57a8b8fab 100644
--- a/devel/avr-libc/Makefile
+++ b/devel/avr-libc/Makefile
@@ -34,6 +34,9 @@ CONFIGURE_ENV= CC=avr-gcc PREFIX=${PREFIX}
CONFIGURE_SCRIPT= doconf
.if !defined(NOPORTDOCS)
CONFIGURE_ARGS= --enable-doc --disable-versioned-doc
+PLIST_DOC= ${PKGDIR}/pkg-plist.doc
+.else
+PLIST_DOC=
.endif
# Work around the braind***ness introduced by <bsd.cpu.mk> in freebsd-5.
# Sorry, the user is no longer be able to override the optimization and
@@ -51,6 +54,7 @@ do-build:
(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ./domake MAKE=${GMAKE})
do-install:
+ rm -f ${TMPPLIST}; cat ${PLIST_DOC} ${PLIST} > ${TMPPLIST}
(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ./domake MAKE=${GMAKE} install)
${MKDIR} ${PREFIX}/share/doc/avr-libc
${MKDIR} ${PREFIX}/share/doc/avr-libc/examples