aboutsummaryrefslogtreecommitdiff
path: root/devel/bin86
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-05 20:49:55 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-05 20:49:55 +0000
commit69a0ca8eefd6eef98d6502c47b474eb4ce0559c8 (patch)
tree4f6acad5050ebc0a3a69928ff7d7e43885da9cad /devel/bin86
parent61be7890217d775b90c67b18255f6092d8385818 (diff)
downloadports-69a0ca8eefd6eef98d6502c47b474eb4ce0559c8.tar.gz
ports-69a0ca8eefd6eef98d6502c47b474eb4ce0559c8.zip
- Update to version 0.16.18
PR: ports/168598 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=298528
Diffstat (limited to 'devel/bin86')
-rw-r--r--devel/bin86/Makefile26
-rw-r--r--devel/bin86/distinfo4
-rw-r--r--devel/bin86/files/patch-Makefile13
-rw-r--r--devel/bin86/files/patch-ld_x86_aout_h17
-rw-r--r--devel/bin86/pkg-descr6
5 files changed, 38 insertions, 28 deletions
diff --git a/devel/bin86/Makefile b/devel/bin86/Makefile
index 5598641e4f13..c4bd5286c6ae 100644
--- a/devel/bin86/Makefile
+++ b/devel/bin86/Makefile
@@ -6,22 +6,28 @@
#
PORTNAME= bin86
-PORTVERSION= 0.16.17
+PORTVERSION= 0.16.18
CATEGORIES= devel
-MASTER_SITES= http://homepage.ntlworld.com/robert.debath/dev86/ \
- http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
+MASTER_SITES= http://www.debath.co.uk/dev86/
MAINTAINER= ports@FreeBSD.org
-COMMENT= 16-bit assembler and loader (conflicts with devel/bcc)
+COMMENT= 16-bit assembler and loader
+
+MAKE_JOBS_SAFE= yes
-BINS= as/as86 ld/ld86 ld/objchop ld/catimage ld/objdump86
-CONFLICTS= bcc-[0-9]* dev86-[0-9]*
-PORTDOCS= ChangeLog README README-0.4
MAN1= as86.1 ld86.1
+PORTDOCS= ChangeLog README README-0.4
+PLIST_FILES= ${BINS:C/..\//bin\//g}
-ONLY_FOR_ARCHS= i386 amd64
+CONFLICTS= bcc-[0-9]* dev86-[0-9]*
+
+BINS= as/as86 ld/ld86 ld/objchop ld/catimage ld/objdump86
-PLIST_FILES+= ${BINS:C/..\//bin\//g}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
+.endif
do-install:
${INSTALL_MAN} ${WRKSRC}/man/*1 ${MAN1PREFIX}/man/man1
@@ -33,4 +39,4 @@ do-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/bin86/distinfo b/devel/bin86/distinfo
index 3aaa19d6ede8..8b32b4b1b453 100644
--- a/devel/bin86/distinfo
+++ b/devel/bin86/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bin86-0.16.17.tar.gz) = 429ba36cb6220083ad7cf56d644b7265d401e631c93eb42f4b7ab9bb48c6829c
-SIZE (bin86-0.16.17.tar.gz) = 152400
+SHA256 (bin86-0.16.18.tar.gz) = 10b1aa5c0813e0bb01b8cab8b06543809e75b06b8e55db462351887c4a9ed831
+SIZE (bin86-0.16.18.tar.gz) = 146383
diff --git a/devel/bin86/files/patch-Makefile b/devel/bin86/files/patch-Makefile
index 6f1575f0e558..65531217840b 100644
--- a/devel/bin86/files/patch-Makefile
+++ b/devel/bin86/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Sat Sep 14 14:35:43 2002
-+++ Makefile Sat Sep 14 14:36:04 2002
-@@ -1,9 +1,9 @@
+--- Makefile.orig 2005-02-01 05:45:39.000000000 +0900
++++ Makefile 2012-05-30 05:45:03.000000000 +0900
+@@ -1,16 +1,12 @@
-CFLAGS=-O2 -D_POSIX_SOURCE
+CFLAGS+=-D_POSIX_SOURCE
@@ -11,4 +11,11 @@
+PREFIX?=/usr/local
BINDIR=$(PREFIX)/bin
LIBDIR=$(PREFIX)/lib
+-ifeq ($(PREFIX),/usr)
+-MANDIR=$(PREFIX)/share/man/man1
+-else
MANDIR=$(PREFIX)/man/man1
+-endif
+ SUF=86
+
+ INSTALL_OPT=-m 755
diff --git a/devel/bin86/files/patch-ld_x86_aout_h b/devel/bin86/files/patch-ld_x86_aout_h
index ebc414ea786e..b82171d8b8eb 100644
--- a/devel/bin86/files/patch-ld_x86_aout_h
+++ b/devel/bin86/files/patch-ld_x86_aout_h
@@ -1,12 +1,13 @@
---- ld/x86_aout.h.orig 2008-07-14 15:03:10.000000000 -0500
-+++ ld/x86_aout.h 2008-07-14 15:04:55.000000000 -0500
-@@ -12,6 +12,9 @@
- #if defined(i386) || defined(__BCC__) || defined(MSDOS)
+--- ld/x86_aout.h.orig 2003-01-29 07:17:14.000000000 +0900
++++ ld/x86_aout.h 2012-05-30 05:49:38.000000000 +0900
+@@ -13,7 +13,9 @@
typedef long Long;
#define __OUT_OK 1
-+#elif __amd64__
-+typedef int Long;
-+#define __OUT_OK 1
#else
- typedef char Long[4];
+-typedef char Long[4];
++#define __OUT_OK 1
++#include <sys/types.h>
++typedef int32_t Long;
#endif
+
+ struct exec { /* a.out header */
diff --git a/devel/bin86/pkg-descr b/devel/bin86/pkg-descr
index ade70e6c9c6a..0354afc924ea 100644
--- a/devel/bin86/pkg-descr
+++ b/devel/bin86/pkg-descr
@@ -3,8 +3,4 @@ CPUs. Unlike the GNU binutils in the base system (recent versions
of which have 16-bit capability), these are for code written with
Intel syntax.
-This port/package conflicts with devel/bcc.
-
-WWW: http://homepage.ntlworld.com/robert.debath/
-
-Trevor Johnson
+WWW: http://www.debath.co.uk/