aboutsummaryrefslogtreecommitdiff
path: root/devel/binutils/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2012-02-23 12:43:57 +0000
committerMartin Matuska <mm@FreeBSD.org>2012-02-23 12:43:57 +0000
commit022de42f804f8afe303dd63e71f07372ea49b974 (patch)
treeb6c55540afb06aec63cee918e6b7ebcb63d994b0 /devel/binutils/Makefile
parent268105e966204b59afe1c0d199487a2a1df0144e (diff)
downloadports-022de42f804f8afe303dd63e71f07372ea49b974.tar.gz
ports-022de42f804f8afe303dd63e71f07372ea49b974.zip
Enable gold and sysroot support
PR: ports/165406 Submitted by: brooks@
Notes
Notes: svn path=/head/; revision=292117
Diffstat (limited to 'devel/binutils/Makefile')
-rw-r--r--devel/binutils/Makefile25
1 files changed, 20 insertions, 5 deletions
diff --git a/devel/binutils/Makefile b/devel/binutils/Makefile
index 3dfd7b185437..9c40d01c387a 100644
--- a/devel/binutils/Makefile
+++ b/devel/binutils/Makefile
@@ -7,6 +7,7 @@
PORTNAME= binutils
PORTVERSION= 2.22
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= binutils/releases
@@ -14,9 +15,8 @@ MASTER_SITE_SUBDIR= binutils/releases
MAINTAINER= mm@FreeBSD.org
COMMENT= GNU binary tools
-USE_BZIP2= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= multi
BUILD_DEPENDS= ${LOCALBASE}/lib/libgmp.so:${PORTSDIR}/math/gmp \
${LOCALBASE}/lib/libmpfr.so:${PORTSDIR}/math/mpfr
@@ -25,14 +25,18 @@ CONFLICTS= libbfd-[0-9]*
OPTIONS= NLS "Enable National Language Support" off
-LICENSE= GPLv3 LGPL3
-LICENSE_COMB= multi
LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING3
LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING3.LIB
+USE_BISON= build
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-system-zlib \
+ --with-sysroot=/ \
--disable-werror \
--with-gmp=${LOCALBASE} \
--with-mpfr=${LOCALBASE}
@@ -67,6 +71,14 @@ INFO= as \
.include <bsd.port.pre.mk>
+# Actual earliest version may differ slightly
+.if ${OSVERSION} >= 900044
+CONFIGURE_ARGS+= --enable-gold --enable-plugins
+PLIST_SUB+= GOLD=""
+.else
+PLIST_SUB+= GOLD="@comment "
+.endif
+
.if defined(WITH_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
@@ -80,6 +92,9 @@ ARCH= x86_64
.endif
post-install:
+.if ${OSVERSION} >= 900044
+ ${INSTALL_DATA} ${WRKSRC}/include/plugin-api.h ${PREFIX}/include/
+.endif
@${FIND} -ds ${PREFIX}/${CONFIGURE_TARGET} ! -type d | \
${SED} -e 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} -ds ${PREFIX}/${CONFIGURE_TARGET} -type d | \