aboutsummaryrefslogtreecommitdiff
path: root/devel/binutils/Makefile
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-12-16 14:52:26 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-12-16 14:52:26 +0000
commitb9c90aa46af1067eabd22c7d490335a4496964e0 (patch)
tree609d963c9518a4d6ca8e398cf784b5b086e50826 /devel/binutils/Makefile
parente66acdbd56b205e81d9d0ec78bfd5a64fb589a13 (diff)
downloadports-b9c90aa46af1067eabd22c7d490335a4496964e0.tar.gz
ports-b9c90aa46af1067eabd22c7d490335a4496964e0.zip
Update to 2.24
Do not install libiberty.a to aviod conflicts with devel/gnulibiberty [0] Do not install include/ansidecl.h, to avoid conflicts with gcc49 [1] Fix gold usage when linking c++ code, related to ctors [2] Thanks to dim for help with getting gold to build with libc++! PR: ports/176406 [0], ports/184327 [1] Submitted by: Craig Leres <leres@ee.lbl.gov> [0] Gerald Pfeifer <gerald@pfeifer.com> [1] Requested by: rdivacky [2]
Notes
Notes: svn path=/head/; revision=336642
Diffstat (limited to 'devel/binutils/Makefile')
-rw-r--r--devel/binutils/Makefile33
1 files changed, 6 insertions, 27 deletions
diff --git a/devel/binutils/Makefile b/devel/binutils/Makefile
index 964dc9ea27f2..ff773de30876 100644
--- a/devel/binutils/Makefile
+++ b/devel/binutils/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= binutils
-PORTVERSION= 2.23.2
+PORTVERSION= 2.24
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= binutils/releases
@@ -36,26 +36,6 @@ CONFIGURE_ARGS+= --with-system-zlib \
--with-gmp=${LOCALBASE} \
--with-mpfr=${LOCALBASE}
-MAN1= addr2line.1 \
- ar.1 \
- as.1 \
- c++filt.1 \
- gprof.1 \
- dlltool.1 \
- elfedit.1 \
- ld.1 \
- nlmconv.1 \
- nm.1 \
- objcopy.1 \
- objdump.1 \
- ranlib.1 \
- readelf.1 \
- size.1 \
- strings.1 \
- strip.1 \
- windmc.1 \
- windres.1
-
INFO= as \
binutils \
standards \
@@ -64,7 +44,6 @@ INFO= as \
configure \
ld
-NO_STAGE= yes
.include <bsd.port.options.mk>
# Actual earliest version may differ slightly
@@ -91,11 +70,11 @@ CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
post-install:
.if ${OSVERSION} >= 900044
- ${INSTALL_DATA} ${WRKSRC}/include/plugin-api.h ${PREFIX}/include/
+ ${INSTALL_DATA} ${WRKSRC}/include/plugin-api.h ${STAGEDIR}${PREFIX}/include/
.endif
- @${FIND} -ds ${PREFIX}/${CONFIGURE_TARGET} ! -type d | \
- ${SED} -e 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} -ds ${PREFIX}/${CONFIGURE_TARGET} -type d | \
- ${SED} -e 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+ @${FIND} -ds ${STAGEDIR}${PREFIX}/${CONFIGURE_TARGET} ! -type d | \
+ ${SED} -e 's,^${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} -ds ${STAGEDIR}${PREFIX}/${CONFIGURE_TARGET} -type d | \
+ ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.include <bsd.port.mk>