aboutsummaryrefslogtreecommitdiff
path: root/devel/binutils/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2021-10-25 16:33:09 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2021-11-11 21:18:12 +0000
commitdea411ca0ce1f3152bad6609868146f383b720c6 (patch)
tree8de8ff3d63e50d90362043e1b6260e5e88392c48 /devel/binutils/Makefile
parent83777317cecd24908bb358e97e17e6e2dd0f2bb9 (diff)
downloadports-dea411ca0ce1f3152bad6609868146f383b720c6.tar.gz
ports-dea411ca0ce1f3152bad6609868146f383b720c6.zip
devel/binutils: configure with --enable-new-dtags
This makes binutils ld use DT_RUNPATH instead of DT_RPATH by default for FreeBSD targets and brings it in line with LLVM ld. The difference between the two is that DT_RUNPATH has a lower priority than the LD_LIBRARY_PATH environment variable. This variable is used by libtool to override DT_RUNPATH when running programs directly from the build directory (e.g. during make test). PR: 259446 Approved by: maintainer timeout (2 weeks)
Diffstat (limited to 'devel/binutils/Makefile')
-rw-r--r--devel/binutils/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/devel/binutils/Makefile b/devel/binutils/Makefile
index 31280c3fa4ed..82f627387301 100644
--- a/devel/binutils/Makefile
+++ b/devel/binutils/Makefile
@@ -2,7 +2,7 @@
PORTNAME= binutils
PORTVERSION= 2.37
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH?= 1
CATEGORIES?= devel
MASTER_SITES= SOURCEWARE/binutils/releases
@@ -115,6 +115,11 @@ PLIST_SUB+= GOLD=""
PLIST_SUB+= GOLD="@comment "
.endif
+.if (${FLAVOR} == native && ${OPSYS} == FreeBSD) || \
+ (${FLAVOR} != native && ${BUTARGET:M*freebsd*})
+CONFIGURE_ARGS+= --enable-new-dtags
+.endif
+
.if ${ARCH} == amd64
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.elif ${ARCH} == powerpcspe