aboutsummaryrefslogtreecommitdiff
path: root/devel/binutils
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2020-01-15 01:10:38 +0000
committerPhilip Paeps <philip@FreeBSD.org>2020-01-15 01:10:38 +0000
commit684ba86758a971cbe39734db5df8a3232c8b0639 (patch)
tree197765b790a87bda778fcc97a3e485b61ab0bc36 /devel/binutils
parent93f42ee115245cb7515267cd3a0b3aa054c04f00 (diff)
downloadports-684ba86758a971cbe39734db5df8a3232c8b0639.tar.gz
ports-684ba86758a971cbe39734db5df8a3232c8b0639.zip
Add a riscv64_none_elf flavor to devel/binutils.
This flavor of binutils can be used as an external toolchain for riscv64 bare metal. Submitted by: kp Sponsored by: Axiado Approved by: bapt (maintainer)
Notes
Notes: svn path=/head/; revision=523075
Diffstat (limited to 'devel/binutils')
-rw-r--r--devel/binutils/Makefile5
-rw-r--r--devel/binutils/pkg-plist-riscv64-none-elf65
2 files changed, 68 insertions, 2 deletions
diff --git a/devel/binutils/Makefile b/devel/binutils/Makefile
index 497492e593c7..0968ada246e5 100644
--- a/devel/binutils/Makefile
+++ b/devel/binutils/Makefile
@@ -15,7 +15,8 @@ LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
FLAVORS= native aarch64 aarch64_none_elf amd64 arm_gnueabi arm_none_eabi \
- avr i386 mingw32 mips mips64 powerpc powerpc64 riscv64 s390x sparc64
+ avr i386 mingw32 mips mips64 powerpc powerpc64 riscv64 \
+ riscv64_none_elf s390x sparc64
FLAVOR?= native
RELRO_CONFIGURE_ON= --enable-relro
@@ -65,7 +66,7 @@ INFO_PATH= ${PKGNAMEPREFIX:S/-$//}/share/info
BROKEN_mips= fails to configure: error: C compiler cannot create executables
BROKEN_mips64= fails to configure: error: C compiler cannot create executables
BROKEN_powerpc64= fails to configure: error: C compiler cannot create executables
-.elif ${FLAVOR} == aarch64_none_elf || ${FLAVOR} == arm_none_eabi || ${FLAVOR} == mingw32 || ${FLAVOR} == avr
+.elif ${FLAVOR} == aarch64_none_elf || ${FLAVOR} == arm_none_eabi || ${FLAVOR} == riscv64_none_elf || ${FLAVOR} == mingw32 || ${FLAVOR} == avr
BUTARGET= ${FLAVOR:C/_/-/g}
.elif ${FLAVOR} == amd64
BUTARGET= x86_64-unknown-${OPSYS:tl}${OSREL}
diff --git a/devel/binutils/pkg-plist-riscv64-none-elf b/devel/binutils/pkg-plist-riscv64-none-elf
new file mode 100644
index 000000000000..a4b22ec0e508
--- /dev/null
+++ b/devel/binutils/pkg-plist-riscv64-none-elf
@@ -0,0 +1,65 @@
+%%BUTARGET%%/bin/ar
+%%BUTARGET%%/bin/as
+%%BUTARGET%%/bin/ld
+%%BUTARGET%%/bin/ld.bfd
+%%BUTARGET%%/bin/nm
+%%BUTARGET%%/bin/objcopy
+%%BUTARGET%%/bin/objdump
+%%BUTARGET%%/bin/ranlib
+%%BUTARGET%%/bin/readelf
+%%BUTARGET%%/bin/size
+%%BUTARGET%%/bin/strip
+%%BUTARGET%%/lib/ldscripts/elf32lriscv.xe
+%%BUTARGET%%/lib/ldscripts/elf64lriscv.xr
+%%BUTARGET%%/lib/ldscripts/elf64lriscv.xce
+%%BUTARGET%%/lib/ldscripts/elf64lriscv.xu
+%%BUTARGET%%/lib/ldscripts/elf32lriscv.xr
+%%BUTARGET%%/lib/ldscripts/elf64lriscv.xe
+%%BUTARGET%%/lib/ldscripts/elf32lriscv.xce
+%%BUTARGET%%/lib/ldscripts/elf32lriscv.xu
+%%BUTARGET%%/lib/ldscripts/elf32lriscv.xbn
+%%BUTARGET%%/lib/ldscripts/elf32lriscv.xw
+%%BUTARGET%%/lib/ldscripts/elf32lriscv.xwe
+%%BUTARGET%%/lib/ldscripts/elf32lriscv.xc
+%%BUTARGET%%/lib/ldscripts/elf32lriscv.x
+%%BUTARGET%%/lib/ldscripts/elf32lriscv.xn
+%%BUTARGET%%/lib/ldscripts/elf64lriscv.xwe
+%%BUTARGET%%/lib/ldscripts/elf64lriscv.xbn
+%%BUTARGET%%/lib/ldscripts/elf64lriscv.xc
+%%BUTARGET%%/lib/ldscripts/elf64lriscv.xw
+%%BUTARGET%%/lib/ldscripts/elf64lriscv.xn
+%%BUTARGET%%/lib/ldscripts/elf64lriscv.x
+bin/%%BUTARGET%%-addr2line
+bin/%%BUTARGET%%-ar
+bin/%%BUTARGET%%-as
+bin/%%BUTARGET%%-c++filt
+bin/%%BUTARGET%%-elfedit
+bin/%%BUTARGET%%-gprof
+bin/%%BUTARGET%%-ld
+bin/%%BUTARGET%%-ld.bfd
+bin/%%BUTARGET%%-nm
+bin/%%BUTARGET%%-objcopy
+bin/%%BUTARGET%%-objdump
+bin/%%BUTARGET%%-ranlib
+bin/%%BUTARGET%%-readelf
+bin/%%BUTARGET%%-size
+bin/%%BUTARGET%%-strings
+bin/%%BUTARGET%%-strip
+man/man1/%%BUTARGET%%-addr2line.1.gz
+man/man1/%%BUTARGET%%-ar.1.gz
+man/man1/%%BUTARGET%%-as.1.gz
+man/man1/%%BUTARGET%%-c++filt.1.gz
+man/man1/%%BUTARGET%%-dlltool.1.gz
+man/man1/%%BUTARGET%%-elfedit.1.gz
+man/man1/%%BUTARGET%%-gprof.1.gz
+man/man1/%%BUTARGET%%-ld.1.gz
+man/man1/%%BUTARGET%%-nm.1.gz
+man/man1/%%BUTARGET%%-objcopy.1.gz
+man/man1/%%BUTARGET%%-objdump.1.gz
+man/man1/%%BUTARGET%%-ranlib.1.gz
+man/man1/%%BUTARGET%%-readelf.1.gz
+man/man1/%%BUTARGET%%-size.1.gz
+man/man1/%%BUTARGET%%-strings.1.gz
+man/man1/%%BUTARGET%%-strip.1.gz
+man/man1/%%BUTARGET%%-windmc.1.gz
+man/man1/%%BUTARGET%%-windres.1.gz