aboutsummaryrefslogtreecommitdiff
path: root/devel/bisoncpp/Makefile
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2011-11-15 21:18:34 +0000
committerGabor Pali <pgj@FreeBSD.org>2011-11-15 21:18:34 +0000
commit8306981b7a7d109e4d59662a88044a4dd885bb35 (patch)
tree7d9e1005f9f7af0045decccc786de08debc69917 /devel/bisoncpp/Makefile
parent4f8962ecd295b77cd8b0a3b5ee1dc7a1ca47d0ed (diff)
downloadports-8306981b7a7d109e4d59662a88044a4dd885bb35.tar.gz
ports-8306981b7a7d109e4d59662a88044a4dd885bb35.zip
- Update to 2.09.03
- Switch to GCC 4.6 (requested by: gerald) - Add license information Feature safe: yes
Notes
Notes: svn path=/head/; revision=285874
Diffstat (limited to 'devel/bisoncpp/Makefile')
-rw-r--r--devel/bisoncpp/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/devel/bisoncpp/Makefile b/devel/bisoncpp/Makefile
index 57d1b9a8fb37..5e9fcbea6c9c 100644
--- a/devel/bisoncpp/Makefile
+++ b/devel/bisoncpp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bisoncpp
-PORTVERSION= 2.9.1
+PORTVERSION= 2.09.03
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/bisonc%2B%2B/${PORTVERSION}
DISTNAME= bisonc++_${PORTVERSION}
@@ -15,10 +15,11 @@ EXTRACT_SUFX= .orig.tar.gz
MAINTAINER= pgj@FreeBSD.org
COMMENT= LALR(1) parser generator that generates C++ classes
+LICENSE= GPLv3
+
BUILD_DEPENDS= icmake:${PORTSDIR}/devel/icmake \
yodl>=3.0:${PORTSDIR}/textproc/yodl \
- libbobcat>=2.09:${PORTSDIR}/devel/libbobcat \
- g++45:${PORTSDIR}/lang/gcc45
+ libbobcat>=2.18:${PORTSDIR}/devel/libbobcat
.if !defined(NO_INSTALL_MANPAGES)
MANCOMPRESSED= yes
@@ -32,12 +33,14 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
WRKSRC= ${WRKDIR}/bisonc++-${PORTVERSION}
+USE_GCC= 4.6
+
post-patch:
@${REINPLACE_CMD} 's|"/usr"|"${PREFIX}"| ; \
s|"/share/bisonc++"|"/share/${PORTNAME}-${PORTVERSION}"| ; \
s|"/share/doc/bisonc++"|"/share/doc/${PORTNAME}-${PORTVERSION}"| ; \
s|"/share/man/man1"|"/man/man1"| ; \
- s|"g++-4.5"|"g++45"|' \
+ s|"g++"|"g++46"|' \
${WRKSRC}/INSTALL.im
@${REINPLACE_CMD} 's|#!/usr/bin/icmake|#!${LOCALBASE}/bin/icmake|' \
${WRKSRC}/build \