aboutsummaryrefslogtreecommitdiff
path: root/devel/bisoncpp/Makefile
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-03-09 16:23:46 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-03-09 16:23:46 +0000
commit9205cdd2b3440b94b678fefd7c366810e08fcb25 (patch)
treec6f1cd6f512918fede44a1f9d5426d3d77c66995 /devel/bisoncpp/Makefile
parentb2208169f576d23dadda570f5ba5da3cae695919 (diff)
downloadports-9205cdd2b3440b94b678fefd7c366810e08fcb25.tar.gz
ports-9205cdd2b3440b94b678fefd7c366810e08fcb25.zip
The program bisonc++ creates a C++ parser function and -class having a
cleaner setup than the code generated by Alain Coetmeur's bison++. Furthermore, since bisonc++ more closely follows current-day ideas about C++ programming its code is easier to read. WWW: http://bisoncpp.sourceforge.net/ Approved by: tabthorpe
Notes
Notes: svn path=/head/; revision=229762
Diffstat (limited to 'devel/bisoncpp/Makefile')
-rw-r--r--devel/bisoncpp/Makefile61
1 files changed, 61 insertions, 0 deletions
diff --git a/devel/bisoncpp/Makefile b/devel/bisoncpp/Makefile
new file mode 100644
index 000000000000..f049d523a521
--- /dev/null
+++ b/devel/bisoncpp/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: bisoncpp
+# Date created: March 5, 2009
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bisoncpp
+PORTVERSION= 2.4.5
+CATEGORIES= devel
+MASTER_SITES= SF
+DISTNAME= bisonc++_${PORTVERSION}
+EXTRACT_SUFX= .orig.tar.gz
+
+MAINTAINER= pgj@FreeBSD.org
+COMMENT= LALR(1) parser generator that generates C++ classes
+
+BUILD_DEPENDS= icmake:${PORTSDIR}/devel/icmake \
+ yodl>=2.0:${PORTSDIR}/textproc/yodl
+LIB_DEPENDS= bobcat.2:${PORTSDIR}/devel/libbobcat
+
+MANCOMPRESSED= yes
+MAN1= bisonc++.1
+
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= *
+
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
+WRKSRC= ${WRKDIR}/bisonc++-${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|"/usr"|"${PREFIX}"| ; \
+ s|"/share/bisonc++"|"/share/${PORTNAME}-${PORTVERSION}"| ; \
+ s|"/share/doc/bisonc++"|"/share/doc/${PORTNAME}-${PORTVERSION}"| ; \
+ s|"/share/man/man1"|"/man/man1"|' \
+ ${WRKSRC}/INSTALL.im
+ @${REINPLACE_CMD} -e 's|#!/usr/bin/icmake|#!${LOCALBASE}/bin/icmake|' \
+ ${WRKSRC}/build
+ @${REINPLACE_CMD} -e 's|#!/usr/bin/icmake|#!${LOCALBASE}/bin/icmake| ; \
+ s|"-Wall -O3"|"-Wall ${CXXFLAGS} -I${LOCALBASE}/include"| ; \
+ s|""|"${LOCALBASE}/lib"|' \
+ ${WRKSRC}/icmake/library
+ @${REINPLACE_CMD} -e 's|"cp -d |"cp -Pp | ; \
+ s|"cp -r |"cp -R |' \
+ ${WRKSRC}/icmake/install
+
+do-build:
+ @cd ${WRKSRC} && ./build program strip && ./build man
+.if !defined(NOPORTDOCS)
+ @cd ${WRKSRC} && ./build manual
+.endif
+
+do-install:
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ./build install
+.else
+ cd ${WRKSRC} && ./build installprog
+.endif
+
+.include <bsd.port.mk>