aboutsummaryrefslogtreecommitdiff
path: root/devel/bitkeeper/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2021-03-31 02:46:05 +0000
committerCy Schubert <cy@FreeBSD.org>2021-03-31 02:46:05 +0000
commitbb11e784bc3bc6d535f15640c4d876945f1b669a (patch)
tree818d91e20193b07ce7e47cf476bbdc3c4a611fe0 /devel/bitkeeper/Makefile
parent7272a38b9087425f40a6905eba72ab726b2b54a3 (diff)
downloadports-bb11e784bc3bc6d535f15640c4d876945f1b669a.tar.gz
ports-bb11e784bc3bc6d535f15640c4d876945f1b669a.zip
devel/bitkeeper: fix poudriere build
r569286 fixed manual port stage however it broke poudriere builds. This resulted in either a nested directory tree of $STAGEDIR/$PREFIX/bitkeeper/$PREFIX/bitkeeper under poudriere or simply $STAGEDIR when building by hand, making any conventional fix mutulally exclusive. To resolve we rename DESTDIR within the port to some arbitrary name, PDESTDIR, and set the port's BINDIR to /bitkeeper, from /usr/local/bitkeeper, to avoid the other source of nesting.
Notes
Notes: svn path=/head/; revision=569607
Diffstat (limited to 'devel/bitkeeper/Makefile')
-rw-r--r--devel/bitkeeper/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/bitkeeper/Makefile b/devel/bitkeeper/Makefile
index 2fb44fa7ea78..ff0a8b75d9b0 100644
--- a/devel/bitkeeper/Makefile
+++ b/devel/bitkeeper/Makefile
@@ -37,12 +37,16 @@ MANDIRS= ${PREFIX}/bitkeeper/man
WRKSRC= ${WRKDIR}/bk-${PORTVERSION}/src
ALL_TARGET= p
+post-patch:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
+ 's/DESTDIR/PDESTDIR/g'
+
do-build:
@(cd ${WRKSRC}; ${MAKE_CMD} ${ALL_TARGET})
do-install:
@(cd ${WRKSRC}; \
- ${MAKE_CMD} DESTDIR=${STAGEDIR}${PREFIX}/bitkeeper ${INSTALL_TARGET}); \
+ ${MAKE_CMD} PDESTDIR=${STAGEDIR}${PREFIX} ${INSTALL_TARGET})
${INSTALL_SCRIPT} ${WRKDIR}/bk ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKDIR}/bk-man.conf \
${STAGEDIR}${PREFIX}/etc/man.d/bk.conf