aboutsummaryrefslogtreecommitdiff
path: root/devel/bmake
diff options
context:
space:
mode:
authorMikolaj Golub <trociny@FreeBSD.org>2016-02-27 06:59:15 +0000
committerMikolaj Golub <trociny@FreeBSD.org>2016-02-27 06:59:15 +0000
commit31b2651a5691056b3e4d3e22db2ddfd2fc1afa9a (patch)
tree85d95226a1dd13e96f55f813ffc79488c262a324 /devel/bmake
parent01529e80fd9c6b0d7cbf694c6cb20a239ca2c1d6 (diff)
downloadports-31b2651a5691056b3e4d3e22db2ddfd2fc1afa9a.tar.gz
ports-31b2651a5691056b3e4d3e22db2ddfd2fc1afa9a.zip
- update to 20160220
- remove outdated patch (it was needed for 8.3)
Notes
Notes: svn path=/head/; revision=409653
Diffstat (limited to 'devel/bmake')
-rw-r--r--devel/bmake/Makefile4
-rw-r--r--devel/bmake/distinfo8
-rw-r--r--devel/bmake/files/patch-var.c87
3 files changed, 6 insertions, 93 deletions
diff --git a/devel/bmake/Makefile b/devel/bmake/Makefile
index 09e9cb2229f0..f912dc5a4540 100644
--- a/devel/bmake/Makefile
+++ b/devel/bmake/Makefile
@@ -2,13 +2,13 @@
# $FreeBSD$
PORTNAME= bmake
-PORTVERSION= 20151022
+PORTVERSION= 20160220
CATEGORIES= devel
MASTER_SITES= ftp://ftp.netbsd.org/pub/NetBSD/misc/sjg/ \
http://www.gtlib.cc.gatech.edu/pub/NetBSD/misc/sjg/ \
ftp://ftp.uk.netbsd.org/pub/NetBSD/misc/sjg/ \
ftp://ftp.de.netbsd.org/pub/NetBSD/misc/sjg/
-DISTFILES= bmake-${PORTVERSION}.tar.gz mk-${PORTVERSION}.tar.gz
+DISTFILES= bmake-${PORTVERSION}.tar.gz mk-20151111.tar.gz
MAINTAINER= trociny@FreeBSD.org
COMMENT= Portable version of NetBSD 'make' utility
diff --git a/devel/bmake/distinfo b/devel/bmake/distinfo
index 6331046d36fa..b2656611ccbc 100644
--- a/devel/bmake/distinfo
+++ b/devel/bmake/distinfo
@@ -1,4 +1,4 @@
-SHA256 (bmake-20151022.tar.gz) = 9183a78ea10303141158aa99f62493823e5ee3598e512cbc6d35c98e4031b366
-SIZE (bmake-20151022.tar.gz) = 534269
-SHA256 (mk-20151022.tar.gz) = 2cb3654b3fe582d9254c5227608427209b9aaf360fd23654b3f4cae58e3fdce8
-SIZE (mk-20151022.tar.gz) = 87745
+SHA256 (bmake-20160220.tar.gz) = df874ff0976a161d2b94476299cae4d13f69ad2d238c10582378e41dcfd5ccdd
+SIZE (bmake-20160220.tar.gz) = 537825
+SHA256 (mk-20151111.tar.gz) = beebba89da0ba068c904599d3358e6f08c35418b13300fac787c11774a525bc1
+SIZE (mk-20151111.tar.gz) = 88106
diff --git a/devel/bmake/files/patch-var.c b/devel/bmake/files/patch-var.c
deleted file mode 100644
index 13abe14e8215..000000000000
--- a/devel/bmake/files/patch-var.c
+++ /dev/null
@@ -1,87 +0,0 @@
-------------------------------------------------------------------------
-r250164 | sjg | 2013-05-02 02:58:39 +0300 (Thu, 02 May 2013) | 8 lines
-
-Local hack to allow smooth transition for ports.
-bsd.port.mk can set .MAKE.FreeBSD_UL=yes
-to cause :L and :U to have their old behavior.
-This should be reverted when 8.3 is EOL.
-
-PR: 173299
-Reviewed by: obrien
-
---- var.c.orig 2013-03-04 03:01:57.000000000 +0200
-+++ var.c 2013-05-04 10:28:21.832274582 +0300
-@@ -140,6 +140,17 @@ __RCSID("$NetBSD: var.c,v 1.173 2013/02/
- #include "job.h"
-
- /*
-+ * XXX transition hack for FreeBSD ports.
-+ * bsd.port.mk can set .MAKE.FreeBSD_UL=yes
-+ * to cause us to treat :[LU] as aliases for :t[lu]
-+ * To be reverted when ports converts to :t[lu] (when 8.3 is EOL)
-+ */
-+#define MAKE_FREEBSD_UL ".MAKE.FreeBSD_UL"
-+#ifdef MAKE_FREEBSD_UL
-+static int FreeBSD_UL = FALSE;
-+#endif
-+
-+/*
- * This lets us tell if we have replaced the original environ
- * (which we cannot free).
- */
-@@ -965,6 +976,11 @@ Var_Set(const char *name, const char *va
- setenv(MAKE_LEVEL_SAFE, tmp, 1);
- #endif
- }
-+#ifdef MAKE_FREEBSD_UL
-+ if (strcmp(MAKE_FREEBSD_UL, name) == 0) {
-+ FreeBSD_UL = getBoolean(MAKE_FREEBSD_UL, FALSE);
-+ }
-+#endif
-
-
- out:
-@@ -2660,8 +2676,24 @@ ApplyModifiers(char *nstr, const char *t
- free(loop.str);
- break;
- }
-- case 'D':
- case 'U':
-+#ifdef MAKE_FREEBSD_UL
-+ if (FreeBSD_UL) {
-+ int nc = tstr[1];
-+
-+ /* we have to be careful, since :U is used internally */
-+ if (nc == ':' || nc == endc) {
-+ char *dp = bmake_strdup(nstr);
-+ for (newStr = dp; *dp; dp++)
-+ *dp = toupper((unsigned char)*dp);
-+ cp = tstr + 1;
-+ termc = *cp;
-+ break; /* yes inside the conditional */
-+ }
-+ /* FALLTHROUGH */
-+ }
-+#endif
-+ case 'D':
- {
- Buffer buf; /* Buffer for patterns */
- int wantit; /* want data in buffer */
-@@ -2721,6 +2753,17 @@ ApplyModifiers(char *nstr, const char *t
- break;
- }
- case 'L':
-+#ifdef MAKE_FREEBSD_UL
-+ if (FreeBSD_UL) {
-+ char *dp = bmake_strdup(nstr);
-+ for (newStr = dp; *dp; dp++)
-+ *dp = tolower((unsigned char)*dp);
-+ cp = tstr + 1;
-+ termc = *cp;
-+ break;
-+ }
-+ /* FALLTHROUGH */
-+#endif
- {
- if ((v->flags & VAR_JUNK) != 0)
- v->flags |= VAR_KEEP;