aboutsummaryrefslogtreecommitdiff
path: root/devel/boehm-gc-redirect/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 09:17:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 09:17:03 +0000
commit36aec2ee4d4789c8cc6ad940264e1a101d8a7977 (patch)
treefadc33ad2f29c6931b7a10a46ca3d20a561a3331 /devel/boehm-gc-redirect/Makefile
parent59642d1219c0fc9ff42830b664320824c78e3a3f (diff)
downloadports-36aec2ee4d4789c8cc6ad940264e1a101d8a7977.tar.gz
ports-36aec2ee4d4789c8cc6ad940264e1a101d8a7977.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=299101
Diffstat (limited to 'devel/boehm-gc-redirect/Makefile')
-rw-r--r--devel/boehm-gc-redirect/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/boehm-gc-redirect/Makefile b/devel/boehm-gc-redirect/Makefile
index 2c71c67841e7..0ea869b0d67b 100644
--- a/devel/boehm-gc-redirect/Makefile
+++ b/devel/boehm-gc-redirect/Makefile
@@ -27,7 +27,7 @@ INSTLIBS= cord gc gccpp
GC_VARIANT= redirect
SOVER= 1
-OPTIONS= FULLDEBUG "Debugging support (see documentation)" off
+OPTIONS_DEFINE= DEBUG
PLIST_FILES= ${INSTLIBS:S,^,lib/lib,g:S,$,-${GC_VARIANT}.so.${SOVER},g} \
${INSTLIBS:S,^,lib/lib,g:S,$,-${GC_VARIANT}.so,g}
@@ -38,7 +38,7 @@ PLIST_FILES= ${INSTLIBS:S,^,lib/lib,g:S,$,-${GC_VARIANT}.so.${SOVER},g} \
BROKEN= Does not compile on ia64
.endif
-.if defined(WITH_FULLDEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-gc-debug
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+fulldebug
.endif