aboutsummaryrefslogtreecommitdiff
path: root/devel/bonobo
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
commit19a718ac4c38750e766de7abf027f0491981495d (patch)
tree8fad9fa05facfd939ca92589f047e5224dffd236 /devel/bonobo
parent47c68887b223642a73baccd0fa69c8caf7845044 (diff)
downloadports-19a718ac4c38750e766de7abf027f0491981495d.tar.gz
ports-19a718ac4c38750e766de7abf027f0491981495d.zip
Convert all core GNOME1 components and some of the most popular GNOME1
apps to bsd.gnomeng.mk. The goal is to make GNOME1 framework more modular, which will allow to use GNOME1 apps with GNOME2 desktop as well as considerably reduce langht of dependency chains for GNOME1 ports (for example after this commit AbiWord's dependency chain was reduced by 7 ports from 57 to only 50, while Gnumeric's - from 60 to 53 and so on). The most of the GNOME1 apps are still not converted, so that lot of work is still ahead. Please report any unusual problems to gnome@FreeBSD.org. Discussed with: marcus Reviewed by: marcus
Notes
Notes: svn path=/head/; revision=62821
Diffstat (limited to 'devel/bonobo')
-rw-r--r--devel/bonobo/Makefile15
-rw-r--r--devel/bonobo/files/patch-ac12
-rw-r--r--devel/bonobo/pkg-plist4
3 files changed, 5 insertions, 26 deletions
diff --git a/devel/bonobo/Makefile b/devel/bonobo/Makefile
index 24bba8ba24af..26d4cac04bb5 100644
--- a/devel/bonobo/Makefile
+++ b/devel/bonobo/Makefile
@@ -15,27 +15,22 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gnomeprint.16:${PORTSDIR}/print/gnomeprint
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix oaf gnomehier gnomeprint
+GNOME_HTML_DIR= ${PREFIX}/share/doc/bonobo
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
LIBTOOLFILES= configure libefs/configure
-CONFIGURE_ARGS= --disable-gtk-doc \
- --with-html-dir=${PREFIX}/share/doc/bonobo
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/devel/bonobo/files/patch-ac b/devel/bonobo/files/patch-ac
deleted file mode 100644
index 727e795ebd2f..000000000000
--- a/devel/bonobo/files/patch-ac
+++ /dev/null
@@ -1,12 +0,0 @@
---- libefs/Makefile.in.orig Mon May 14 17:01:15 2001
-+++ libefs/Makefile.in Tue May 22 11:04:58 2001
-@@ -37,3 +37,3 @@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(prefix)/libdata/pkgconfig
- pkgincludedir = $(includedir)/@PACKAGE@
-@@ -85,3 +85,3 @@
-
--pcdir = $(libdir)/pkgconfig
-+pcdir = $(pkglibdir)
- pc_SCRIPTS = libefs.pc
diff --git a/devel/bonobo/pkg-plist b/devel/bonobo/pkg-plist
index 42e8abccacef..140e6e747380 100644
--- a/devel/bonobo/pkg-plist
+++ b/devel/bonobo/pkg-plist
@@ -244,14 +244,10 @@ share/locale/uk/LC_MESSAGES/bonobo.mo
share/locale/wa/LC_MESSAGES/bonobo.mo
share/locale/zh_CN/LC_MESSAGES/bonobo.mo
share/locale/zh_TW/LC_MESSAGES/bonobo.mo
-@dirrm share/gnome/ui
@dirrm share/gnome/help/audio_ulaw/C/images
@dirrm share/gnome/help/audio_ulaw/C
@dirrm share/gnome/help/audio_ulaw
@dirrm share/doc/bonobo/libefs
@dirrm share/doc/bonobo/bonobo
@dirrm share/doc/bonobo
-@dirrm lib/bonobo/plugin
@dirrm include/gnome-1.0/bonobo
-@unexec /bin/rmdir %D/lib/bonobo/monikers 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/lib/bonobo 2>/dev/null || /usr/bin/true