aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-libs
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2016-03-14 07:37:48 +0000
committerDon Lewis <truckman@FreeBSD.org>2016-03-14 07:37:48 +0000
commitabd75dc85a7f7a51f5e31cf9c4f2f6fba15773c2 (patch)
tree21cfc2228ca4468b03bf10d11e2129455c8c1bb9 /devel/boost-libs
parent68a2249e718449883c43080ea57f993d32c1b1d8 (diff)
downloadports-abd75dc85a7f7a51f5e31cf9c4f2f6fba15773c2.tar.gz
ports-abd75dc85a7f7a51f5e31cf9c4f2f6fba15773c2.zip
Import upstream commit bae401b1eb0594932c4e780d496cba852c23b75f to
unbreak users of boost/asio/ssl when openssl is built without SSLv3 support. PR: 207429
Notes
Notes: svn path=/head/; revision=411050
Diffstat (limited to 'devel/boost-libs')
-rw-r--r--devel/boost-libs/Makefile2
-rw-r--r--devel/boost-libs/files/patch-bae401b1eb0594932c4e780d496cba852c23b75f49
2 files changed, 50 insertions, 1 deletions
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index 26924170cc81..11cbe43a0ac5 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= boost-libs
-PORTREVISION= 9
+PORTREVISION= 10
COMMENT= Free portable C++ libraries (without Boost.Python)
diff --git a/devel/boost-libs/files/patch-bae401b1eb0594932c4e780d496cba852c23b75f b/devel/boost-libs/files/patch-bae401b1eb0594932c4e780d496cba852c23b75f
new file mode 100644
index 000000000000..1fc8e3db0eff
--- /dev/null
+++ b/devel/boost-libs/files/patch-bae401b1eb0594932c4e780d496cba852c23b75f
@@ -0,0 +1,49 @@
+--- boost/asio/ssl/impl/context.ipp.orig 2013-10-26 23:25:53 UTC
++++ boost/asio/ssl/impl/context.ipp
+@@ -87,6 +87,14 @@ context::context(context::method m)
+ handle_ = ::SSL_CTX_new(::SSLv2_server_method());
+ break;
+ #endif // defined(OPENSSL_NO_SSL2)
++#if defined(OPENSSL_NO_SSL3)
++ case context::sslv3:
++ case context::sslv3_client:
++ case context::sslv3_server:
++ boost::asio::detail::throw_error(
++ boost::asio::error::invalid_argument, "context");
++ break;
++#else // defined(OPENSSL_NO_SSL3)
+ case context::sslv3:
+ handle_ = ::SSL_CTX_new(::SSLv3_method());
+ break;
+@@ -96,6 +104,7 @@ context::context(context::method m)
+ case context::sslv3_server:
+ handle_ = ::SSL_CTX_new(::SSLv3_server_method());
+ break;
++#endif // defined(OPENSSL_NO_SSL3)
+ case context::tlsv1:
+ handle_ = ::SSL_CTX_new(::TLSv1_method());
+ break;
+--- boost/asio/ssl/old/detail/openssl_context_service.hpp.orig 2013-05-20 12:32:20 UTC
++++ boost/asio/ssl/old/detail/openssl_context_service.hpp
+@@ -85,6 +85,13 @@ public:
+ impl = ::SSL_CTX_new(::SSLv2_server_method());
+ break;
+ #endif // defined(OPENSSL_NO_SSL2)
++#if defined(OPENSSL_NO_SSL3)
++ case context_base::sslv3:
++ case context_base::sslv3_client:
++ case context_base::sslv3_server:
++ boost::asio::detail::throw_error(boost::asio::error::invalid_argument);
++ break;
++#else // defined(OPENSSL_NO_SSL3)
+ case context_base::sslv3:
+ impl = ::SSL_CTX_new(::SSLv3_method());
+ break;
+@@ -94,6 +101,7 @@ public:
+ case context_base::sslv3_server:
+ impl = ::SSL_CTX_new(::SSLv3_server_method());
+ break;
++#endif // defined(OPENSSL_NO_SSL3)
+ case context_base::tlsv1:
+ impl = ::SSL_CTX_new(::TLSv1_method());
+ break;