aboutsummaryrefslogtreecommitdiff
path: root/devel/boost_build
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-12-30 18:08:28 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-12-30 18:08:28 +0000
commitd2630f9e50f6a14911ef867f4ada3a0a96986fc1 (patch)
tree7605f9eabff1858ba1ee9f134d335957bb9938ad /devel/boost_build
parent767d3c1c35f0d4d7c16d4f99a9f812c051daa595 (diff)
downloadports-d2630f9e50f6a14911ef867f4ada3a0a96986fc1.tar.gz
ports-d2630f9e50f6a14911ef867f4ada3a0a96986fc1.zip
devel/boost_build: Update to the latest revision because it includes runtime fixes needed on FreeBSD
Notes
Notes: svn path=/head/; revision=559678
Diffstat (limited to 'devel/boost_build')
-rw-r--r--devel/boost_build/Makefile10
-rw-r--r--devel/boost_build/distinfo6
-rw-r--r--devel/boost_build/pkg-plist2
3 files changed, 13 insertions, 5 deletions
diff --git a/devel/boost_build/Makefile b/devel/boost_build/Makefile
index 19ea2ad7f6ae..a081813327d1 100644
--- a/devel/boost_build/Makefile
+++ b/devel/boost_build/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= boost_build
-DISTVERSION= 4.3.0
+DISTVERSION= 4.3.0.20201229
CATEGORIES= devel
MAINTAINER= ports@FreeBSD.org
@@ -13,11 +13,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${LOCALBASE}/bin/bjam:devel/boost-jam
-USES= tar:bzip2
+USES= python:test shebangfix tar:bzip2
USE_GITHUB= yes
GH_ACCOUNT= boostorg
GH_PROJECT= build
+GH_TAGNAME= 29baa79
+
+SHEBANG_GLOB= *.py
SUB_FILES= pkg-message
@@ -27,4 +30,7 @@ do-build:
do-install:
cd ${WRKSRC} && ./b2 toolset=clang install --prefix=${STAGEDIR}${PREFIX}
+do-test: # test target fails: https://github.com/boostorg/build/issues/698
+ cd ${WRKSRC} && ./b2 toolset=clang test --prefix=${STAGEDIR}${PREFIX}
+
.include <bsd.port.mk>
diff --git a/devel/boost_build/distinfo b/devel/boost_build/distinfo
index c07fa87981b6..5d43bb323dd0 100644
--- a/devel/boost_build/distinfo
+++ b/devel/boost_build/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1603558994
-SHA256 (boostorg-build-4.3.0_GH0.tar.gz) = 97eb98343da636c314edccb08173e25cea13b155233ebb4d74e065d55f791364
-SIZE (boostorg-build-4.3.0_GH0.tar.gz) = 1119238
+TIMESTAMP = 1609351082
+SHA256 (boostorg-build-4.3.0.20201229-29baa79_GH0.tar.gz) = 88d8cc22bc1fc8ce5e777e08a0635a75e7ba2c6cc54bd795a20751096b931fcd
+SIZE (boostorg-build-4.3.0.20201229-29baa79_GH0.tar.gz) = 1125544
diff --git a/devel/boost_build/pkg-plist b/devel/boost_build/pkg-plist
index 50329b90eb1b..d05c2037c37c 100644
--- a/devel/boost_build/pkg-plist
+++ b/devel/boost_build/pkg-plist
@@ -69,6 +69,7 @@ share/boost-build/src/tools/features/archiveflags-feature.jam
share/boost-build/src/tools/features/asmflags-feature.jam
share/boost-build/src/tools/features/build-feature.jam
share/boost-build/src/tools/features/cflags-feature.jam
+share/boost-build/src/tools/features/compileflags-feature.jam
share/boost-build/src/tools/features/conditional-feature.jam
share/boost-build/src/tools/features/coverage-feature.jam
share/boost-build/src/tools/features/cxx-template-depth-feature.jam
@@ -100,6 +101,7 @@ share/boost-build/src/tools/features/objcflags-feature.jam
share/boost-build/src/tools/features/optimization-feature.jam
share/boost-build/src/tools/features/os-feature.jam
share/boost-build/src/tools/features/relevant-feature.jam
+share/boost-build/src/tools/features/response-file-feature.jam
share/boost-build/src/tools/features/rtti-feature.jam
share/boost-build/src/tools/features/runtime-feature.jam
share/boost-build/src/tools/features/sanitizers-feature.jam