aboutsummaryrefslogtreecommitdiff
path: root/devel/bugzilla2
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-13 14:45:08 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-13 14:45:08 +0000
commite99ceadaf6c77b80c19e16d91306e944305b1c88 (patch)
treee8a8f4dac51e148717ae07e2de0c635ec5d58833 /devel/bugzilla2
parent3a5afbdcc87c8da2cc12bd67ec501257e48bc034 (diff)
downloadports-e99ceadaf6c77b80c19e16d91306e944305b1c88.tar.gz
ports-e99ceadaf6c77b80c19e16d91306e944305b1c88.zip
Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.
Notes
Notes: svn path=/head/; revision=93890
Diffstat (limited to 'devel/bugzilla2')
-rw-r--r--devel/bugzilla2/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/devel/bugzilla2/Makefile b/devel/bugzilla2/Makefile
index 8733d2f2543b..66b92c25b7f7 100644
--- a/devel/bugzilla2/Makefile
+++ b/devel/bugzilla2/Makefile
@@ -75,11 +75,11 @@ pre-everything::
@${ECHO_MSG} ""
post-patch:
- @find -d ${WRKSRC} -name CVS -type d -exec ${RM} -rf {} \;
- @find -d ${WRKSRC} -name sgml -type d -exec ${RM} -rf {} \;
- @find ${WRKSRC} -name .cvsignore -type f -exec ${RM} -f {} \;
- @find ${WRKSRC} -name README.docs -type f -exec ${RM} -f {} \;
- @find ${WRKSRC} -name \*.orig -type f -exec ${RM} -f {} \;
+ @${FIND} -d ${WRKSRC} -name CVS -type d -exec ${RM} -rf {} \;
+ @${FIND} -d ${WRKSRC} -name sgml -type d -exec ${RM} -rf {} \;
+ @${FIND} ${WRKSRC} -name .cvsignore -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name README.docs -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name \*.orig -type f -exec ${RM} -f {} \;
.for i in ${BONSAIPERLWC}
@${REINPLACE_CMD} -e 's@#!/usr/bonsaitools/bin/perl@#!/usr/bin/perl@' \
${WRKSRC}/$i
@@ -88,16 +88,16 @@ post-patch:
@${REINPLACE_CMD} -e 's@/usr/lib/sendmail@/usr/sbin/sendmail@' \
${WRKSRC}/$i
.endfor
- @find ${WRKSRC} -name \*.bak -type f -exec ${RM} -f {} \;
+ @${FIND} ${WRKSRC} -name \*.bak -type f -exec ${RM} -f {} \;
pre-install:
- @find ${WRKSRC}/docs -type d -exec ${CHMOD} 755 {} \;
- @find ${WRKSRC}/docs -type f -exec ${CHMOD} ${MANMODE} {} \;
- @find ${WRKSRC}/docs -type f -exec ${CHOWN} root:wheel {} \;
+ @${FIND} ${WRKSRC}/docs -type d -exec ${CHMOD} 755 {} \;
+ @${FIND} ${WRKSRC}/docs -type f -exec ${CHMOD} ${MANMODE} {} \;
+ @${FIND} ${WRKSRC}/docs -type f -exec ${CHOWN} root:wheel {} \;
do-install:
${MKDIR} ${PREFIX}/${BUGZILLADIR}
- find ${WRKSRC} \! -type d -maxdepth 1 \! -name UPGRADING* -exec \
+ ${FIND} ${WRKSRC} \! -type d -maxdepth 1 \! -name UPGRADING* -exec \
${INSTALL_SCRIPT} {} ${PREFIX}/${BUGZILLADIR} \;
${TAR} -C ${WRKSRC} -cf - template css | ${TAR} --unlink -C ${PREFIX}/${BUGZILLADIR} -xf -
.if !defined(NOPORTDOCS)