aboutsummaryrefslogtreecommitdiff
path: root/devel/bugzilla44
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-04-23 06:58:15 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-04-23 06:58:15 +0000
commit1c24add6777a1a94ae56c4732bb2f204c4583cbf (patch)
tree9aad6d3c5b5e633f752a557e208013b8b2ada5ec /devel/bugzilla44
parentc392097b4e6bf8711726dda52969222c45107464 (diff)
downloadports-1c24add6777a1a94ae56c4732bb2f204c4583cbf.tar.gz
ports-1c24add6777a1a94ae56c4732bb2f204c4583cbf.zip
- Remove unnecessary PERL_LEVEL check
- Add NO_ARCH - Convert to new options helper - Use bsd.port.mk instead of bsd.port.pre.mk + bsd.port.post.mk With hat: perl Approved by: portmgr (blanket)
Notes
Notes: svn path=/head/; revision=413849
Diffstat (limited to 'devel/bugzilla44')
-rw-r--r--devel/bugzilla44/Makefile168
-rw-r--r--devel/bugzilla44/Makefile.common1
2 files changed, 50 insertions, 119 deletions
diff --git a/devel/bugzilla44/Makefile b/devel/bugzilla44/Makefile
index 9bcfcea3eaa6..fdf6ebf2e340 100644
--- a/devel/bugzilla44/Makefile
+++ b/devel/bugzilla44/Makefile
@@ -11,6 +11,8 @@ COMMENT= Bug-tracking system developed by Mozilla Project
LICENSE= MPL
# see Bugzilla/Install/Requirements.pm
+# PR 194782: silence Module::Pluggable deprecated warnings
+# PR 196060,196100: explicitly depend on textproc/p5-Text-Tabv
RUN_DEPENDS= \
p5-CGI>=3.51:www/p5-CGI \
p5-DBI>=1.614:databases/p5-DBI \
@@ -21,7 +23,9 @@ RUN_DEPENDS= \
p5-Encode-Detect>=0:converters/p5-Encode-Detect \
p5-List-MoreUtils>=0.32:lang/p5-List-MoreUtils \
p5-Math-Random-ISAAC>=1.001:math/p5-Math-Random-ISAAC \
+ p5-Module-Pluggable>=5.1:devel/p5-Module-Pluggable \
p5-Template-Toolkit>=2.24:www/p5-Template-Toolkit \
+ p5-Text-Tabs+Wrap>=2013.0523:textproc/p5-Text-Tabs+Wrap \
p5-TimeDate>=2.23:devel/p5-TimeDate \
p5-URI>=1.55:net/p5-URI
@@ -39,130 +43,56 @@ EMPTY_DIRS_LIST=data graphs contrib lib t xt
.include "${.CURDIR}/Makefile.common"
.include "${.CURDIR}/Makefile.options"
-.include <bsd.port.options.mk>
-
-.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} >= 501800
-# PR 194782: silence Module::Pluggable deprecated warnings
-RUN_DEPENDS+= p5-Module-Pluggable>=5.1:devel/p5-Module-Pluggable
-# PR 196060,196100: explicitly depend on textproc/p5-Text-Tabv
-RUN_DEPENDS+= p5-Text-Tabs+Wrap>=2013.0523:textproc/p5-Text-Tabs+Wrap
-.endif
-
-.if ${PORT_OPTIONS:MMODPERL}
-USE_APACHE_RUN= 22+
-.endif
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-RUN_DEPENDS+= p5-DBD-mysql>=4.0001:databases/p5-DBD-mysql
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USES+= pgsql
-RUN_DEPENDS+= p5-DBD-Pg>=3.4.2:databases/p5-DBD-Pg
-.endif
-
-.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= yes
-RUN_DEPENDS+= p5-DBD-SQLite>=1.29:databases/p5-DBD-SQLite \
- sqlite3>=3:databases/sqlite3
-.endif
-
-.if ${PORT_OPTIONS:MGRAPH_REPORTS}
-RUN_DEPENDS+= p5-GD>=1.20:graphics/p5-GD \
- p5-GD-Graph>=0:graphics/p5-GD-Graph \
- p5-GD-TextUtil>=0:graphics/p5-GD-TextUtil \
- p5-Template-GD>=0:www/p5-Template-GD
-.endif
-
-.if ${PORT_OPTIONS:MCHARTING_MODULES}
-RUN_DEPENDS+= p5-Chart>=2.4.10:graphics/p5-Chart
-.endif
-
-.if ${PORT_OPTIONS:MPATCH_VIEWER}
-RUN_DEPENDS+= p5-PatchReader>=0.9.6:devel/p5-PatchReader \
- interdiff:misc/patchutils
-.endif
-
-.if ${PORT_OPTIONS:MMORE_HTML}
-RUN_DEPENDS+= p5-HTML-Parser>=3.67:www/p5-HTML-Parser \
- p5-HTML-Scrubber>=0:www/p5-HTML-Scrubber
-.endif
-
-.if ${PORT_OPTIONS:MINBOUND_EMAIL}
-RUN_DEPENDS+= p5-Email-MIME-Attachment-Stripper>=0:mail/p5-Email-MIME-Attachment-Stripper \
- p5-Email-Reply>=0:mail/p5-Email-Reply \
- p5-HTML-FormatText-WithLinks>=0.13:textproc/p5-HTML-FormatText-WithLinks
-.endif
-
-.if ${PORT_OPTIONS:MMAIL_QUEUEING}
-RUN_DEPENDS+= p5-TheSchwartz>=1.10:devel/p5-TheSchwartz \
- p5-Daemon-Generic>=0:net/p5-Daemon-Generic \
- p5-File-Slurp>=9999.13:devel/p5-File-Slurp
-.endif
-
-.if ${PORT_OPTIONS:MMOVE_BUGZ}
-RUN_DEPENDS+= p5-MIME-Tools>=5.406:mail/p5-MIME-Tools \
- p5-XML-Twig>=0:textproc/p5-XML-Twig
-.endif
-
-.if ${PORT_OPTIONS:MBMP2PNG}
-RUN_DEPENDS+= convert:graphics/ImageMagick
-.endif
+MODPERL_USE= APACHE_RUN=22+
+MYSQL_USE= MYSQL=yes
+MYSQL_RUN_DEPENDS= p5-DBD-mysql>=4.0001:databases/p5-DBD-mysql
+PGSQL_USES= pgsql
+PGSQL_RUN_DEPENDS= p5-DBD-Pg>=3.4.2:databases/p5-DBD-Pg
+SQLITE_USE= SQLITE=yes
+SQLITE_RUN_DEPENDS= p5-DBD-SQLite>=1.29:databases/p5-DBD-SQLite \
+ sqlite3>=3:databases/sqlite3
+GRAPH_REPORTS_RUN_DEPENDS= p5-GD>=1.20:graphics/p5-GD \
+ p5-GD-Graph>=0:graphics/p5-GD-Graph \
+ p5-GD-TextUtil>=0:graphics/p5-GD-TextUtil \
+ p5-Template-GD>=0:www/p5-Template-GD
+CHARTING_MODULES_RUN_DEPENDS= p5-Chart>=2.4.10:graphics/p5-Chart
+PATCH_VIEWER_RUN_DEPENDS= p5-PatchReader>=0.9.6:devel/p5-PatchReader \
+ interdiff:misc/patchutils
+MORE_HTML_RUN_DEPENDS= p5-HTML-Parser>=3.67:www/p5-HTML-Parser \
+ p5-HTML-Scrubber>=0:www/p5-HTML-Scrubber
+INBOUND_EMAIL_RUN_DEPENDS= p5-Email-MIME-Attachment-Stripper>=0:mail/p5-Email-MIME-Attachment-Stripper \
+ p5-Email-Reply>=0:mail/p5-Email-Reply \
+ p5-HTML-FormatText-WithLinks>=0.13:textproc/p5-HTML-FormatText-WithLinks
+MAIL_QUEUEING_RUN_DEPENDS= p5-TheSchwartz>=1.10:devel/p5-TheSchwartz \
+ p5-Daemon-Generic>=0:net/p5-Daemon-Generic \
+ p5-File-Slurp>=9999.13:devel/p5-File-Slurp
+MOVE_BUGZ_RUN_DEPENDS= p5-MIME-Tools>=5.406:mail/p5-MIME-Tools \
+ p5-XML-Twig>=0:textproc/p5-XML-Twig
+BMP2PNG_RUN_DEPENDS= convert:graphics/ImageMagick
# Note: XML-RPC and JSON-RPC are deprecated in favor of REST
# and will likely be removed in the Bugzilla 7.0 release.
-.if ${PORT_OPTIONS:MXMLRPC} || ${PORT_OPTIONS:MJSONRPC}
-RUN_DEPENDS+= p5-Test-Taint>=1.06:devel/p5-Test-Taint
-.endif
-
-.if ${PORT_OPTIONS:MXMLRPC}
-RUN_DEPENDS+= p5-XMLRPC-Lite>=0.712:net/p5-XMLRPC-Lite
# XXX SOAP::Lite can be removed if upstream officially depends on
# XMLRPC::Lite>=0.717, see Bugzilla/Install/Requirements.pm
-RUN_DEPENDS+= p5-SOAP-Lite>=0.712:net/p5-SOAP-Lite
-.endif
-
-.if ${PORT_OPTIONS:MJSONRPC}
-RUN_DEPENDS+= p5-JSON-RPC>=0:devel/p5-JSON-RPC \
- p5-JSON-XS>=2.0:converters/p5-JSON-XS
-.endif
-
-.if ${PORT_OPTIONS:MMODPERL}
-RUN_DEPENDS+= ${APACHE_PKGNAMEPREFIX}mod_perl2>=0:www/mod_perl2 \
- p5-Apache-DBI>=0:www/p5-Apache-DBI
-.endif
-
-.if ${PORT_OPTIONS:MGRAPHVIZ}
-RUN_DEPENDS+= dot:graphics/graphviz
-.endif
-
-.if ${PORT_OPTIONS:MEXPORT_IMPORT}
-RUN_DEPENDS+= p5-XML-Parser>=0:textproc/p5-XML-Parser \
- p5-XML-Twig>=0:textproc/p5-XML-Twig
-.endif
-
-.if ${PORT_OPTIONS:MLDAP}
-RUN_DEPENDS+= p5-perl-ldap>=0:net/p5-perl-ldap
-.endif
-
-.if ${PORT_OPTIONS:MRADIUS}
-RUN_DEPENDS+= p5-Authen-Radius>=0:security/p5-Authen-Radius
-.endif
+XMLRPC_RUN_DEPENDS= p5-Test-Taint>=1.06:devel/p5-Test-Taint \
+ p5-XMLRPC-Lite>=0.712:net/p5-XMLRPC-Lite \
+ p5-SOAP-Lite>=0.712:net/p5-SOAP-Lite
+JSONRPC_RUN_DEPENDS= p5-Test-Taint>=1.06:devel/p5-Test-Taint \
+ p5-JSON-RPC>=0:devel/p5-JSON-RPC \
+ p5-JSON-XS>=2.0:converters/p5-JSON-XS
+MODPERL_RUN_DEPENDS= ${APACHE_PKGNAMEPREFIX}mod_perl2>=0:www/mod_perl2 \
+ p5-Apache-DBI>=0:www/p5-Apache-DBI
+GRAPHVIZ_RUN_DEPENDS= dot:graphics/graphviz
+EXPORT_IMPORT_RUN_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser \
+ p5-XML-Twig>=0:textproc/p5-XML-Twig
+LDAP_RUN_DEPENDS= p5-perl-ldap>=0:net/p5-perl-ldap
+RADIUS_RUN_DEPENDS= p5-Authen-Radius>=0:security/p5-Authen-Radius
+SMTP_AUTH_RUN_DEPENDS= p5-Authen-SASL>=2.16:security/p5-Authen-SASL
+SMTP_SSL_RUN_DEPENDS= p5-Net-SMTP-SSL>=1.01:mail/p5-Net-SMTP-SSL
+MIME_SNIFF_RUN_DEPENDS= p5-File-MimeInfo>=0.16:devel/p5-File-MimeInfo \
+ p5-IO-stringy>=2.110:devel/p5-IO-stringy
-.if ${PORT_OPTIONS:MSMTP_AUTH}
-RUN_DEPENDS+= p5-Authen-SASL>=2.16:security/p5-Authen-SASL
-.endif
-
-.if ${PORT_OPTIONS:MSMTP_SSL}
-RUN_DEPENDS+= p5-Net-SMTP-SSL>=1.01:mail/p5-Net-SMTP-SSL
-.endif
-
-.if ${PORT_OPTIONS:MMIME_SNIFF}
-RUN_DEPENDS+= p5-File-MimeInfo>=0.16:devel/p5-File-MimeInfo \
- p5-IO-stringy>=2.110:devel/p5-IO-stringy
-.endif
+.include <bsd.port.options.mk>
post-extract:
${RM} -r ${WRKSRC}/.git
@@ -203,4 +133,4 @@ do-install-CONTRIB-on:
@${MKDIR} ${STAGEDIR}${WWWDIR}/contrib
(cd ${WRKSRC}/contrib && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}/contrib)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/bugzilla44/Makefile.common b/devel/bugzilla44/Makefile.common
index 73dd50e0affb..509e1da1a5b3 100644
--- a/devel/bugzilla44/Makefile.common
+++ b/devel/bugzilla44/Makefile.common
@@ -13,5 +13,6 @@ WWWDIR= ${PREFIX}/www/bugzilla
BINMODE= 700
+NO_ARCH= yes
NO_BUILD= yes