aboutsummaryrefslogtreecommitdiff
path: root/devel/caf/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2015-07-09 08:54:25 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2015-07-09 08:54:25 +0000
commit1465fec18b1c4432940deea66098370f87bd966d (patch)
tree0254cad5a0648b0b42999023c7cc8eeedbf42a92 /devel/caf/Makefile
parentcf62f99b9ccb8c623193d47627570bb959d12610 (diff)
downloadports-1465fec18b1c4432940deea66098370f87bd966d.tar.gz
ports-1465fec18b1c4432940deea66098370f87bd966d.zip
Upgrade to 0.14.0, and support FreeBSD < 10.0.
PR: 201410 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=391622
Diffstat (limited to 'devel/caf/Makefile')
-rw-r--r--devel/caf/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/devel/caf/Makefile b/devel/caf/Makefile
index 8a845986a375..99acbdab8af1 100644
--- a/devel/caf/Makefile
+++ b/devel/caf/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= actor-framework
-PORTVERSION= 0.13
+PORTVERSION= 0.14.0
CATEGORIES= devel
MAINTAINER= vallentin@icir.org
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
CXXFLAGS+= -std=c++11 -Wextra -Wall -pedantic
LDFLAGS+= -pthread
-USES= compiler:c++11-lang cmake:outsource
+USES= cmake:outsource compiler:c++11-lang
USE_LDCONFIG= yes
USE_GITHUB= yes
@@ -22,6 +22,7 @@ OPTIONS_RADIO= LOG_LEVEL
OPTIONS_RADIO_LOG_LEVEL= LOG_LEVEL_ERROR LOG_LEVEL_WARN LOG_LEVEL_INFO LOG_LEVEL_DEBUG LOG_LEVEL_TRACE
OPTIONS_DEFAULT= TEST
OPTIONS_SUB= yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
TEST_DESC= Build with unit tests
STATIC_DESC= Additionally build static version of library
@@ -53,7 +54,13 @@ regression-test: build
.endif
.if ${OSVERSION} < 1001000
-BROKEN= require clang & libc++
+# require clang & libc++
+BUILD_DEPENDS+= ${LOCALBASE}/bin/clang34:${PORTSDIR}/lang/clang34 \
+ ${LOCALBASE}/lib/c++/libstdc++.so:${PORTSDIR}/devel/libc++
+CC= clang34
+CXX= clang++34
+CXXFLAGS+= -stdlib=libc++ -I${LOCALBASE}/include/c++/v1
+CPP= clang-cpp34
.endif
.include <bsd.port.mk>