aboutsummaryrefslogtreecommitdiff
path: root/devel/ccache
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2017-02-03 22:15:22 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2017-02-03 22:15:22 +0000
commit1f348f0ff5af47725487429d2bcd4874199268bb (patch)
treefcdc32dc2abcb7a60636a755e2612733b8f68641 /devel/ccache
parent99b5ee1ef7a075ae47191ed86df1785b39b4baef (diff)
downloadports-1f348f0ff5af47725487429d2bcd4874199268bb.tar.gz
ports-1f348f0ff5af47725487429d2bcd4874199268bb.zip
- Update to 3.2.9
Notes
Notes: svn path=/head/; revision=433269
Diffstat (limited to 'devel/ccache')
-rw-r--r--devel/ccache/Makefile3
-rw-r--r--devel/ccache/distinfo5
-rw-r--r--devel/ccache/files/patch-CCACHE_CPP2_Wp_MT75
-rw-r--r--devel/ccache/files/patch-CCACHE_CPP2_Wp_MT-fix-Wp23
4 files changed, 4 insertions, 102 deletions
diff --git a/devel/ccache/Makefile b/devel/ccache/Makefile
index dd30e6a9d692..08ddfab3ceb6 100644
--- a/devel/ccache/Makefile
+++ b/devel/ccache/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ccache
-PORTVERSION= 3.2.5
-PORTREVISION= 4
+PORTVERSION= 3.2.9
CATEGORIES= devel
MASTER_SITES= http://www.samba.org/ftp/ccache/ \
LOCAL/bdrewery
diff --git a/devel/ccache/distinfo b/devel/ccache/distinfo
index 3fade555cd2b..935e09723aba 100644
--- a/devel/ccache/distinfo
+++ b/devel/ccache/distinfo
@@ -1,2 +1,3 @@
-SHA256 (ccache-3.2.5.tar.gz) = a0e3cf20483e0a13d70398ea2e01a21f544bd15da0de243f1a30758f2481ee03
-SIZE (ccache-3.2.5.tar.gz) = 444925
+TIMESTAMP = 1486160032
+SHA256 (ccache-3.2.9.tar.gz) = 1e13961b83a3d215c4013469c149414a79312a22d3c7bf9f946abac9ee33e63f
+SIZE (ccache-3.2.9.tar.gz) = 447006
diff --git a/devel/ccache/files/patch-CCACHE_CPP2_Wp_MT b/devel/ccache/files/patch-CCACHE_CPP2_Wp_MT
deleted file mode 100644
index 85cb7ec80ce2..000000000000
--- a/devel/ccache/files/patch-CCACHE_CPP2_Wp_MT
+++ /dev/null
@@ -1,75 +0,0 @@
-From 026ba6b9fdbeb3ab57d9eb424025a0a0850baae6 Mon Sep 17 00:00:00 2001
-From: Joel Rosdahl <joel@rosdahl.net>
-Date: Wed, 7 Sep 2016 20:46:18 +0200
-Subject: [PATCH] Only pass -Wp,-MT and similar to the preprocessor
-
-This fixes an issue when compiler option -Wp,-MT,path is used instead of
--MT path (and similar for -MF, -MP and -MQ) and run_second_cpp
-(CCACHE_CPP2) is enabled.
-
-Fixes #129.
----
- NEWS.txt | 4 ++++
- ccache.c | 9 +++++++++
- test/test_argument_processing.c | 9 +++++----
- 3 files changed, 18 insertions(+), 4 deletions(-)
-
-diff --git a/ccache.c b/ccache.c
-index 591c7d7..5635cc1 100644
---- ccache.c
-+++ ccache.c
-@@ -2249,6 +2249,11 @@ cc_process_args(struct args *args, struct args **preprocessor_args,
- output_dep = make_relative_path(x_strdup(argv[i] + 9));
- args_add(dep_args, argv[i]);
- continue;
-+ } else if (str_startswith(argv[i], "-Wp,-M")) {
-+ /* -MF, -MP, -MQ, -MT, etc. TODO: Make argument to MF/MQ/MT
-+ * relative. */
-+ args_add(dep_args, argv[i]);
-+ continue;
- } else if (conf->direct_mode) {
- /*
- * -Wp, can be used to pass too hard options to
-@@ -2258,6 +2263,10 @@ cc_process_args(struct args *args, struct args **preprocessor_args,
- cc_log("Unsupported compiler option for direct mode: %s", argv[i]);
- conf->direct_mode = false;
- }
-+
-+ /* Any other -Wp,* arguments are only relevant for the preprocessor. */
-+ args_add(cpp_args, argv[i]);
-+ continue;
- }
- if (str_eq(argv[i], "-MP")) {
- args_add(dep_args, argv[i]);
-diff --git a/test/test_argument_processing.c b/test/test_argument_processing.c
-index 0ecefd1..a1b6ecb 100644
---- test/test_argument_processing.c
-+++ test/test_argument_processing.c
-@@ -1,5 +1,5 @@
- /*
-- * Copyright (C) 2010-2015 Joel Rosdahl
-+ * Copyright (C) 2010-2016 Joel Rosdahl
- *
- * This program is free software; you can redistribute it and/or modify it
- * under the terms of the GNU General Public License as published by the Free
-@@ -57,7 +57,7 @@ TEST(dependency_flags_should_only_be_sent_to_the_preprocessor)
- {
- #define CMD \
- "cc -MD -MMD -MP -MF foo.d -MT mt1 -MT mt2 -MQ mq1 -MQ mq2" \
-- " -Wp,-MD,wpmd -Wp,-MMD,wpmmd"
-+ " -Wp,-MD,wpmd -Wp,-MMD,wpmmd -Wp,-MP -Wp,-MT,wpmt -Wp,-MQ,wpmq -Wp,-MF,wpf"
- struct args *orig = args_init_from_string(CMD " -c foo.c -o foo.o");
- struct args *exp_cpp = args_init_from_string(CMD);
- #undef CMD
-@@ -79,8 +79,9 @@ TEST(preprocessor_only_flags_should_only_be_sent_to_the_preprocessor)
- " -include test.h -include-pch test.pch -iprefix . -iquote ." \
- " -isysroot . -isystem . -iwithprefix . -iwithprefixbefore ." \
- " -DTEST_MACRO -DTEST_MACRO2=1 -F. -trigraphs -fworking-directory" \
-- " -fno-working-directory -MD -MMD -MP -MF foo.d -MT mt1 -MT mt2 " \
-- " -MQ mq1 -MQ mq2 -Wp,-MD,wpmd -Wp,-MMD,wpmmd"
-+ " -fno-working-directory -MD -MMD -MP -MF foo.d -MT mt1 -MT mt2" \
-+ " -MQ mq1 -MQ mq2 -Wp,-MD,wpmd -Wp,-MMD,wpmmd -Wp,-MP -Wp,-MT,wpmt" \
-+ " -Wp,-MQ,wpmq -Wp,-MF,wpf"
- struct args *orig = args_init_from_string(CMD " -c foo.c -o foo.o");
- struct args *exp_cpp = args_init_from_string(CMD);
- #undef CMD
diff --git a/devel/ccache/files/patch-CCACHE_CPP2_Wp_MT-fix-Wp b/devel/ccache/files/patch-CCACHE_CPP2_Wp_MT-fix-Wp
deleted file mode 100644
index 96038da238fb..000000000000
--- a/devel/ccache/files/patch-CCACHE_CPP2_Wp_MT-fix-Wp
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/ccache.c b/ccache.c
-index 5635cc1..ddbc822 100644
---- ccache.c
-+++ ccache.c
-@@ -2249,9 +2249,15 @@ cc_process_args(struct args *args, struct args **preprocessor_args,
- output_dep = make_relative_path(x_strdup(argv[i] + 9));
- args_add(dep_args, argv[i]);
- continue;
-- } else if (str_startswith(argv[i], "-Wp,-M")) {
-- /* -MF, -MP, -MQ, -MT, etc. TODO: Make argument to MF/MQ/MT
-- * relative. */
-+ } else if (str_eq(argv[i], "-Wp,-MP")
-+ || (strlen(argv[i]) > 8
-+ && str_startswith(argv[i], "-Wp,-M")
-+ && argv[i][7] == ','
-+ && (argv[i][6] == 'F'
-+ || argv[i][6] == 'Q'
-+ || argv[i][6] == 'T')
-+ && !strchr(argv[i] + 8, ','))) {
-+ /* TODO: Make argument to MF/MQ/MT relative. */
- args_add(dep_args, argv[i]);
- continue;
- } else if (conf->direct_mode) {